aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-03-01 14:57:03 +0800
committerlofi <lofi@FreeBSD.org>2005-03-01 14:57:03 +0800
commit9071680a273c18da18f2e1202491a030b06c64dd (patch)
tree4ffc376252d01398f6d9d3c4e3a02c12b7c1d886
parentf91d8c68eddb3bc3612fe9a3a1ae1fa03169aeff (diff)
downloadfreebsd-ports-gnome-9071680a273c18da18f2e1202491a030b06c64dd.tar.gz
freebsd-ports-gnome-9071680a273c18da18f2e1202491a030b06c64dd.tar.zst
freebsd-ports-gnome-9071680a273c18da18f2e1202491a030b06c64dd.zip
Add padkey, a program that sends keystrokes to X according to buttons
being pressed on an SNES pad connected to the parallel port. PR: ports/75285 Submitted by: Travis Poppe <tlp@LiquidX.org>
-rw-r--r--x11/Makefile1
-rw-r--r--x11/padkey/Makefile40
-rw-r--r--x11/padkey/distinfo2
-rw-r--r--x11/padkey/pkg-descr13
4 files changed, 56 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index c5dd82151a74..e23e3f15c3b2 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -143,6 +143,7 @@
SUBDIR += p5-X11-GUITest
SUBDIR += p5-X11-IdleTime
SUBDIR += p5-X11-Protocol
+ SUBDIR += padkey
SUBDIR += panoramixext
SUBDIR += peeper
SUBDIR += portoseguro
diff --git a/x11/padkey/Makefile b/x11/padkey/Makefile
new file mode 100644
index 000000000000..87adebb718a9
--- /dev/null
+++ b/x11/padkey/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: padkey
+# Date created: 19 Dec 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= padkey
+PORTVERSION= 0.2
+CATEGORIES= x11 games
+MASTER_SITES= http://www.liquidx.org/padkey/releases/dist/
+DISTNAME= bsd${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Use an authentic SNES controller to play games
+
+USE_GZIP= yes
+USE_XLIB= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+.if defined(NOPORTDOCS)
+PLIST_FILES= bin/padkey
+.else
+PLIST_FILES= bin/padkey %%DOCSDIR%%/CREDITS %%DOCSDIR%%/README
+PLIST_DIRS= %%DOCSDIR%%
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/X11R6/|${X11BASE}/|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/padkey ${PREFIX}/bin/padkey
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}/CREDITS
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/padkey/distinfo b/x11/padkey/distinfo
new file mode 100644
index 000000000000..e965586f6113
--- /dev/null
+++ b/x11/padkey/distinfo
@@ -0,0 +1,2 @@
+MD5 (bsdpadkey-0.2.tar.gz) = f08e360f3b4f322500d7a845cc5bdcd0
+SIZE (bsdpadkey-0.2.tar.gz) = 5146
diff --git a/x11/padkey/pkg-descr b/x11/padkey/pkg-descr
new file mode 100644
index 000000000000..650b0e7c79dd
--- /dev/null
+++ b/x11/padkey/pkg-descr
@@ -0,0 +1,13 @@
+BSD PadKey is a small program for FreeBSD that sends keys to your X display
+according to which buttons are being pressed on a modified SNES pad connected
+to the parallel port.
+
+In short, PadKey allows you to play games on FreeBSD with an authentic SNES
+controller.
+
+Note: This version only works with ONE pad connected to the parallel port!
+
+WWW: http://www.liquidx.org/padkey/index.html
+
+- Travis Poppe
+tlp@liquidx.org