aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-22 01:39:06 +0800
committererwin <erwin@FreeBSD.org>2005-12-22 01:39:06 +0800
commit90d49d35505e88171cf03683f7141ec59f2a46a8 (patch)
treecc4268207a28b768a05227078d21547e4c3e9173
parent46f21625cda4aed517d341ed8cb83ac5a292f14c (diff)
downloadfreebsd-ports-gnome-90d49d35505e88171cf03683f7141ec59f2a46a8.tar.gz
freebsd-ports-gnome-90d49d35505e88171cf03683f7141ec59f2a46a8.tar.zst
freebsd-ports-gnome-90d49d35505e88171cf03683f7141ec59f2a46a8.zip
TEA is a 64-bit symmetric block cipher with a 128-bit key and a variable number
of rounds (32 is recommended). It has a low setup time, and depends on a large number of rounds for security, rather than a complex algorithm. It was developed by David J. Wheeler and Roger M. Needham, and is described at http://www.ftp.cl.cam.ac.uk/ftp/papers/djw-rmn/djw-rmn-tea.html . WWW: http://search.cpan.org/dist/Crypt-TEA PR: ports/90717 Submitted by: Gabor Kovesdan
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-TEA/Makefile24
-rw-r--r--security/p5-Crypt-TEA/distinfo3
-rw-r--r--security/p5-Crypt-TEA/pkg-descr7
-rw-r--r--security/p5-Crypt-TEA/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6b0d474ede7b..8807e7f287c5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -345,6 +345,7 @@
SUBDIR += p5-Crypt-Shark
SUBDIR += p5-Crypt-SmbHash
SUBDIR += p5-Crypt-Solitaire
+ SUBDIR += p5-Crypt-TEA
SUBDIR += p5-Crypt-TripleDES
SUBDIR += p5-Crypt-Twofish
SUBDIR += p5-Crypt-Twofish2
diff --git a/security/p5-Crypt-TEA/Makefile b/security/p5-Crypt-TEA/Makefile
new file mode 100644
index 000000000000..44ecfafa37a2
--- /dev/null
+++ b/security/p5-Crypt-TEA/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-TEA
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-TEA
+PORTVERSION= 1.25
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to Tiny Encryption Algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::TEA.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-TEA/distinfo b/security/p5-Crypt-TEA/distinfo
new file mode 100644
index 000000000000..559511a1605e
--- /dev/null
+++ b/security/p5-Crypt-TEA/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-TEA-1.25.tar.gz) = 6e53511e455724b40007e4f2c0050270
+SHA256 (Crypt-TEA-1.25.tar.gz) = fb89a96a160bcf6fe489a4624b52476ede0c10188a22ad746309c1607ba9dbd3
+SIZE (Crypt-TEA-1.25.tar.gz) = 7786
diff --git a/security/p5-Crypt-TEA/pkg-descr b/security/p5-Crypt-TEA/pkg-descr
new file mode 100644
index 000000000000..2fb3f87d04c6
--- /dev/null
+++ b/security/p5-Crypt-TEA/pkg-descr
@@ -0,0 +1,7 @@
+TEA is a 64-bit symmetric block cipher with a 128-bit key and a variable number
+of rounds (32 is recommended). It has a low setup time, and depends on a
+large number of rounds for security, rather than a complex algorithm. It was
+developed by David J. Wheeler and Roger M. Needham, and is described at
+http://www.ftp.cl.cam.ac.uk/ftp/papers/djw-rmn/djw-rmn-tea.html .
+
+WWW: http://search.cpan.org/dist/Crypt-TEA
diff --git a/security/p5-Crypt-TEA/pkg-plist b/security/p5-Crypt-TEA/pkg-plist
new file mode 100644
index 000000000000..b6219d076d92
--- /dev/null
+++ b/security/p5-Crypt-TEA/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/TEA.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/TEA/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/TEA/TEA.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/TEA/TEA.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/TEA/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true