aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-07 04:31:50 +0800
committerbapt <bapt@FreeBSD.org>2013-09-07 04:31:50 +0800
commit9128609dfa8c12f87b1d8dcb16daffb509696302 (patch)
tree37490b07f02b45facdeddc1587a902a773200fc9
parentaa0b036852eb03b64fb5eb45d30d3b217a28ee79 (diff)
downloadfreebsd-ports-gnome-9128609dfa8c12f87b1d8dcb16daffb509696302.tar.gz
freebsd-ports-gnome-9128609dfa8c12f87b1d8dcb16daffb509696302.tar.zst
freebsd-ports-gnome-9128609dfa8c12f87b1d8dcb16daffb509696302.zip
Add an explicit dependency on pkgconf
-rw-r--r--deskutils/tomboy-plugin-todo/Makefile8
-rw-r--r--multimedia/mpv/Makefile2
-rw-r--r--net/openmpi/Makefile2
3 files changed, 4 insertions, 8 deletions
diff --git a/deskutils/tomboy-plugin-todo/Makefile b/deskutils/tomboy-plugin-todo/Makefile
index 5fd9dedcadef..7a09b02a4585 100644
--- a/deskutils/tomboy-plugin-todo/Makefile
+++ b/deskutils/tomboy-plugin-todo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tomboy-plugin-todo
-# Date created: 2009-06-09
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= tomboy-plugin-todo
PORTVERSION= 1.0.0
@@ -19,6 +15,6 @@ BUILD_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
RUN_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
.include <bsd.port.mk>
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index 34d1e5065af5..661c9187d733 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1 \
RUN_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1
USE_XZ= yes
-USES= gmake iconv
+USES= gmake iconv pkgconfig
USE_XORG= x11 xv xxf86vm
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index cc95cf8d0c48..b047ef23551c 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
USE_BZIP2= yes
HAS_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
MPIBASE?= mpi
MPIDIR?= ${MPIBASE}/${UNIQUENAME}