aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-09-04 22:22:29 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-09-04 22:22:29 +0800
commit93b44aa61751791c5bd0c3e31bf87c6f1dc69396 (patch)
tree2fdfab6a70eae207320f912cd7163355ec11f2e7
parente4ffdbc3c398e34c05d9d7c02544a5327594bfdb (diff)
downloadfreebsd-ports-gnome-93b44aa61751791c5bd0c3e31bf87c6f1dc69396.tar.gz
freebsd-ports-gnome-93b44aa61751791c5bd0c3e31bf87c6f1dc69396.tar.zst
freebsd-ports-gnome-93b44aa61751791c5bd0c3e31bf87c6f1dc69396.zip
Escape automatically in Template-Toolkit.
WWW: http://search.cpan.org/dist/Template-Stash-AutoEscape/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Stash-AutoEscape/Makefile27
-rw-r--r--www/p5-Template-Stash-AutoEscape/distinfo3
-rw-r--r--www/p5-Template-Stash-AutoEscape/pkg-descr3
-rw-r--r--www/p5-Template-Stash-AutoEscape/pkg-plist11
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 48970e4ee58c..7e2ef4a09a9f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1172,6 +1172,7 @@
SUBDIR += p5-Template-Plugin-VMethods
SUBDIR += p5-Template-Provider-Encoding
SUBDIR += p5-Template-Provider-FromDATA
+ SUBDIR += p5-Template-Stash-AutoEscape
SUBDIR += p5-Template-Timer
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-Template-Toolkit-Simple
diff --git a/www/p5-Template-Stash-AutoEscape/Makefile b/www/p5-Template-Stash-AutoEscape/Makefile
new file mode 100644
index 000000000000..62f47112deaf
--- /dev/null
+++ b/www/p5-Template-Stash-AutoEscape/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Template::Stash::AutoEscape
+# Date created: 04 Sep 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Stash-AutoEscape
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to escape automatically in Template-Toolkit
+
+RUN_DEPENDS= \
+ p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Stash::AutoEscape.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Stash-AutoEscape/distinfo b/www/p5-Template-Stash-AutoEscape/distinfo
new file mode 100644
index 000000000000..5ee3ccd60b41
--- /dev/null
+++ b/www/p5-Template-Stash-AutoEscape/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Stash-AutoEscape-0.02.tar.gz) = 9bbcadc6d3f96c78912df2ed2873d55c
+SHA256 (Template-Stash-AutoEscape-0.02.tar.gz) = 2c8333bb3bbffc194d0d3840d0a3221d3ccffcfbe7bf6e81fce4627fe64370ba
+SIZE (Template-Stash-AutoEscape-0.02.tar.gz) = 45770
diff --git a/www/p5-Template-Stash-AutoEscape/pkg-descr b/www/p5-Template-Stash-AutoEscape/pkg-descr
new file mode 100644
index 000000000000..7d5c66ef109d
--- /dev/null
+++ b/www/p5-Template-Stash-AutoEscape/pkg-descr
@@ -0,0 +1,3 @@
+Escape automatically in Template-Toolkit.
+
+WWW: http://search.cpan.org/dist/Template-Stash-AutoEscape/
diff --git a/www/p5-Template-Stash-AutoEscape/pkg-plist b/www/p5-Template-Stash-AutoEscape/pkg-plist
new file mode 100644
index 000000000000..13e988b88aa3
--- /dev/null
+++ b/www/p5-Template-Stash-AutoEscape/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Stash/AutoEscape/.packlist
+%%SITE_PERL%%/Template/Stash/AutoEscape.pm
+%%SITE_PERL%%/Template/Stash/AutoEscape/Escaped/Base.pm
+%%SITE_PERL%%/Template/Stash/AutoEscape/Escaped/HTML.pm
+%%SITE_PERL%%/Template/Stash/AutoEscape/Escaped/YourCode.pm
+%%SITE_PERL%%/Template/Stash/AutoEscape/RawString.pm
+@dirrm %%SITE_PERL%%/Template/Stash/AutoEscape/Escaped
+@dirrm %%SITE_PERL%%/Template/Stash/AutoEscape
+@dirrmtry %%SITE_PERL%%/Template/Stash
+@dirrmtry %%SITE_PERL%%/Template
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Stash/AutoEscape