aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordryice <dryice@FreeBSD.org>2008-01-28 17:23:35 +0800
committerdryice <dryice@FreeBSD.org>2008-01-28 17:23:35 +0800
commit94febd1c24f48ca1db50fc17d1ebac39dfa2c305 (patch)
treea62b199f76e25741dda2b886afd7cb4ccf96472a
parent40ff39cecab75569bb6177202201512ea7701582 (diff)
downloadfreebsd-ports-gnome-94febd1c24f48ca1db50fc17d1ebac39dfa2c305.tar.gz
freebsd-ports-gnome-94febd1c24f48ca1db50fc17d1ebac39dfa2c305.tar.zst
freebsd-ports-gnome-94febd1c24f48ca1db50fc17d1ebac39dfa2c305.zip
Installing DecoratorTools gives access to the peak.util.decorators module.
The tools in this module have been bundled for years inside of PEAK, PyProtocols, RuleDispatch, and the zope.interface package, so they have been widely used and tested. Recent versions of the TurboGears framework (ported to FreeBSD as www/py-turbogears) require the DecoratorTools package. PR: ports/119835 Submitted by: alexander smishlajev <alex@ank-sia.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-decoratortools/Makefile25
-rw-r--r--devel/py-decoratortools/distinfo3
-rw-r--r--devel/py-decoratortools/pkg-descr10
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bb2a0d12fd36..68e7e90977e9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1935,6 +1935,7 @@
SUBDIR += py-dateutil
SUBDIR += py-dbus
SUBDIR += py-decorator
+ SUBDIR += py-decoratortools
SUBDIR += py-dialog
SUBDIR += py-distorm
SUBDIR += py-durus
diff --git a/devel/py-decoratortools/Makefile b/devel/py-decoratortools/Makefile
new file mode 100644
index 000000000000..a334a9f4c0a6
--- /dev/null
+++ b/devel/py-decoratortools/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-DecoratorTools
+# Date created: 20-jan-2008
+# Whom: alexander smishlajev
+#
+# $FreeBSD$
+#
+
+PORTNAME= DecoratorTools
+PORTVERSION= 1.7
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/D/DecoratorTools
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Class, function, and metaclass decorators
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= easy_install
+
+USE_ZIP= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/devel/py-decoratortools/distinfo b/devel/py-decoratortools/distinfo
new file mode 100644
index 000000000000..e3528122527c
--- /dev/null
+++ b/devel/py-decoratortools/distinfo
@@ -0,0 +1,3 @@
+MD5 (DecoratorTools-1.7.zip) = 84df0a86aabec6a7d802439ffaa17585
+SHA256 (DecoratorTools-1.7.zip) = 55283e6acc4e5f66cb6e104f98d08f93b1bd29823d17d7e2f852541738a53a11
+SIZE (DecoratorTools-1.7.zip) = 27481
diff --git a/devel/py-decoratortools/pkg-descr b/devel/py-decoratortools/pkg-descr
new file mode 100644
index 000000000000..52c418a42f8d
--- /dev/null
+++ b/devel/py-decoratortools/pkg-descr
@@ -0,0 +1,10 @@
+Want to use decorators, but still need to support Python 2.3?
+Wish you could have class decorators, decorate arbitrary assignments,
+or match decorated function signatures to their original functions?
+Want to get metaclass features without creating metaclasses?
+How about synchronized methods?
+
+"DecoratorTools" gets you all of this and more.
+
+Author: Phillip J. Eby
+WWW: http://cheeseshop.python.org/pypi/DecoratorTools