aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-04-16 10:49:14 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-04-16 10:49:14 +0800
commit96297b4a96bf7b62695d2143c4b7198b9f79eb30 (patch)
tree2dcbec682e27052fdba0e5389cde46ca5aaf16ff
parent94b3ff36f7b4df9a34facf7a63c0a205a9bc96f0 (diff)
downloadfreebsd-ports-gnome-96297b4a96bf7b62695d2143c4b7198b9f79eb30.tar.gz
freebsd-ports-gnome-96297b4a96bf7b62695d2143c4b7198b9f79eb30.tar.zst
freebsd-ports-gnome-96297b4a96bf7b62695d2143c4b7198b9f79eb30.zip
- Fix build WITHOUT_TORRENT
-rw-r--r--games/springlobby/files/patch-CMakeLists.txt18
1 files changed, 13 insertions, 5 deletions
diff --git a/games/springlobby/files/patch-CMakeLists.txt b/games/springlobby/files/patch-CMakeLists.txt
index 5156536d9117..f8966020e937 100644
--- a/games/springlobby/files/patch-CMakeLists.txt
+++ b/games/springlobby/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2010-01-26 22:06:42.000000000 +0300
-+++ CMakeLists.txt 2010-01-31 05:34:06.000000000 +0300
-@@ -89,7 +89,6 @@
+--- CMakeLists.txt.orig 2010-04-10 03:37:25.000000000 +0400
++++ CMakeLists.txt 2010-04-15 19:08:24.000000000 +0400
+@@ -92,7 +92,6 @@
# Did we find wxWidgets ? This condition will fail for as long as the internal Vars do not point to the proper wxWidgets Configuration.
IF(wxWidgets_FOUND)
# Include wxWidgets macros
@@ -8,7 +8,7 @@
IF(MSVC)
INCLUDE_DIRECTORIES( ${wxWidgets_ROOT_DIR}/include/msvc )
ENDIF(MSVC)
-@@ -97,6 +96,9 @@
+@@ -100,6 +99,9 @@
SET(wxWidgets_RC_DIR ${wxWidgets_ROOT_DIR}/include)
ENDIF(MINGW)
INCLUDE_DIRECTORIES( ${wxWidgets_INCLUDE_DIRS} )
@@ -18,7 +18,7 @@
ELSE(wxWidgets_FOUND)
# For Convenience. If we cannot continue, inform the User.
MESSAGE( FATAL_ERROR "wxWidgets library not found! Please install the package to continue")
-@@ -117,7 +119,7 @@
+@@ -120,7 +122,7 @@
Add_Subdirectory( ${springlobby_SOURCE_DIR}/src/sound/alure )
INCLUDE_DIRECTORIES( ${springlobby_SOURCE_DIR}/src/sound/alure/include )
@@ -27,3 +27,11 @@
ELSE ( OPTION_SOUND )
# Disable sound.
ADD_DEFINITIONS( -DDISABLE_SOUND )
+@@ -174,6 +176,7 @@
+ LIST( APPEND SLSharedWithSettings ${curlSRC} )
+ ELSE( OPTION_TORRENT_SYSTEM )
+ ADD_DEFINITIONS( -DNO_TORRENT_SYSTEM )
++ LIST( APPEND SLSharedWithSettings ${curlSRC} )
+ ENDIF( OPTION_TORRENT_SYSTEM )
+
+