aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-06-17 16:13:39 +0800
committerrafan <rafan@FreeBSD.org>2007-06-17 16:13:39 +0800
commit973caec171f80e8ac85f8e5ffb5d5a8d0bbc5686 (patch)
tree0950c283ce9181ccbfe5995990ce5c5af6e69a2e
parent072b65c0686a7894fdfcefc491b16a257e1d1752 (diff)
downloadfreebsd-ports-gnome-973caec171f80e8ac85f8e5ffb5d5a8d0bbc5686.tar.gz
freebsd-ports-gnome-973caec171f80e8ac85f8e5ffb5d5a8d0bbc5686.tar.zst
freebsd-ports-gnome-973caec171f80e8ac85f8e5ffb5d5a8d0bbc5686.zip
This module contains some common calculation utilities
that are required to perform datetime calculations. WWW: http://search.cpan.org/dist/DateTime-Util-Calc/ PR: ports/113753 Submitted by: Masahiro Teramoto <markun at onohara.to>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Util-Calc/Makefile34
-rw-r--r--devel/p5-DateTime-Util-Calc/distinfo3
-rw-r--r--devel/p5-DateTime-Util-Calc/pkg-descr4
-rw-r--r--devel/p5-DateTime-Util-Calc/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 41ec9dd0ec4b..aedbf7ffe278 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1069,6 +1069,7 @@
SUBDIR += p5-DateTime-TimeZone
SUBDIR += p5-DateTime-TimeZone-Alias
SUBDIR += p5-DateTime-TimeZone-LMT
+ SUBDIR += p5-DateTime-Util-Calc
SUBDIR += p5-Decision-ACL
SUBDIR += p5-Devel-Arena
SUBDIR += p5-Devel-Caller
diff --git a/devel/p5-DateTime-Util-Calc/Makefile b/devel/p5-DateTime-Util-Calc/Makefile
new file mode 100644
index 000000000000..11790128810f
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-DateTime-Util-Calc
+# Date created: 2007-06-16
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Util-Calc
+PORTVERSION= 0.13002
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= DateTime Calculation Utilities
+
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Math-BigInt>=0:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Util::Calc.3
+
+OPTIONS= GMP "Use GMP library" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GMP)
+BUILD_DEPENDS+= p5-Math-BigInt-GMP>=0:${PORTSDIR}/math/p5-Math-BigInt-GMP
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Util-Calc/distinfo b/devel/p5-DateTime-Util-Calc/distinfo
new file mode 100644
index 000000000000..6ac0327dba84
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/distinfo
@@ -0,0 +1,3 @@
+MD5 (DateTime-Util-Calc-0.13002.tar.gz) = 5d289484b093d43fa29efbe97c5f2e53
+SHA256 (DateTime-Util-Calc-0.13002.tar.gz) = e12184868c13c85dc4390f9e553ab36b03a7713108a12c27e2f3de69dcc2cc9a
+SIZE (DateTime-Util-Calc-0.13002.tar.gz) = 25601
diff --git a/devel/p5-DateTime-Util-Calc/pkg-descr b/devel/p5-DateTime-Util-Calc/pkg-descr
new file mode 100644
index 000000000000..4b8ee824d709
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/pkg-descr
@@ -0,0 +1,4 @@
+This module contains some common calculation utilities
+that are required to perform datetime calculations.
+
+WWW: http://search.cpan.org/dist/DateTime-Util-Calc/
diff --git a/devel/p5-DateTime-Util-Calc/pkg-plist b/devel/p5-DateTime-Util-Calc/pkg-plist
new file mode 100644
index 000000000000..dffb3116ebdf
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Util/Calc/.packlist
+%%SITE_PERL%%/DateTime/Util/Calc.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Util/Calc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Util
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/DateTime/Util/Calc
+@dirrmtry %%SITE_PERL%%/DateTime/Util
+@dirrmtry %%SITE_PERL%%/DateTime