aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-06 01:09:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-06 01:09:54 +0800
commit97d15c4e03d39b7e5984f961072610459eea14e1 (patch)
tree3b39e03b75593bdc873df7437aa3a55411a92cb6
parent90430eebf929082cd42c031c3f91bc51360ed5e4 (diff)
downloadfreebsd-ports-gnome-97d15c4e03d39b7e5984f961072610459eea14e1.tar.gz
freebsd-ports-gnome-97d15c4e03d39b7e5984f961072610459eea14e1.tar.zst
freebsd-ports-gnome-97d15c4e03d39b7e5984f961072610459eea14e1.zip
- Add p5-XML-LibXML-PrettyPrint 0.002
Long XML files can be daunting for humans to read. Of course, XML is really designed for computers to read - not people - but there are times when mere mortals do need to read and edit XML by hand. For example, if your application stores its configuration in XML, or you need to dump some XML to STDOUT for debugging purposes. Syntax highlighting helps, but to really make sense of some XML, proper indentation can be vital. Hence XML::LibXML::PrettyPrint - it can be applied to an XML::LibXML DOM tree to reformat it into a more readable result. Pretty-printing XML is not as CPU-efficient as dumping it out sloppily, so unless you're pretty sure that a human is going to need to make sense of your XML, you should probably not use this module. WWW: http://search.cpan.org/dist/XML-LibXML-PrettyPrint/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-LibXML-PrettyPrint/Makefile29
-rw-r--r--textproc/p5-XML-LibXML-PrettyPrint/distinfo2
-rw-r--r--textproc/p5-XML-LibXML-PrettyPrint/pkg-descr15
-rw-r--r--textproc/p5-XML-LibXML-PrettyPrint/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 247568f0c5c5..196e294a91b4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -915,6 +915,7 @@
SUBDIR += p5-XML-Hash-LX
SUBDIR += p5-XML-LibXML
SUBDIR += p5-XML-LibXML-Iterator
+ SUBDIR += p5-XML-LibXML-PrettyPrint
SUBDIR += p5-XML-LibXML-SAX-ChunkParser
SUBDIR += p5-XML-LibXML-Simple
SUBDIR += p5-XML-LibXSLT
diff --git a/textproc/p5-XML-LibXML-PrettyPrint/Makefile b/textproc/p5-XML-LibXML-PrettyPrint/Makefile
new file mode 100644
index 000000000000..cc950b6bcf15
--- /dev/null
+++ b/textproc/p5-XML-LibXML-PrettyPrint/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-XML-LibXML-PrettyPrint
+# Date created: 2011-10-21
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXML-PrettyPrint
+PORTVERSION= 0.002
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Add pleasant whitespace to a DOM tree
+
+BUILD_DEPENDS= p5-Pragmatic>=0:${PORTSDIR}/devel/p5-Pragmatic \
+ p5-XML-LibXML>=1.62:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
+RUN_DEPENDS= p5-Pragmatic>=0:${PORTSDIR}/devel/p5-Pragmatic \
+ p5-XML-LibXML>=1.62:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN3= XML::LibXML::PrettyPrint.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-LibXML-PrettyPrint/distinfo b/textproc/p5-XML-LibXML-PrettyPrint/distinfo
new file mode 100644
index 000000000000..25401831988f
--- /dev/null
+++ b/textproc/p5-XML-LibXML-PrettyPrint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-LibXML-PrettyPrint-0.002.tar.gz) = d27f5aa535ddfa7aaa9be168b99791936c834b72cc650c129d46b82ddeb9b3f1
+SIZE (XML-LibXML-PrettyPrint-0.002.tar.gz) = 52574
diff --git a/textproc/p5-XML-LibXML-PrettyPrint/pkg-descr b/textproc/p5-XML-LibXML-PrettyPrint/pkg-descr
new file mode 100644
index 000000000000..f5135b212205
--- /dev/null
+++ b/textproc/p5-XML-LibXML-PrettyPrint/pkg-descr
@@ -0,0 +1,15 @@
+Long XML files can be daunting for humans to read. Of course, XML is really
+designed for computers to read - not people - but there are times when mere
+mortals do need to read and edit XML by hand. For example, if your application
+stores its configuration in XML, or you need to dump some XML to STDOUT for
+debugging purposes.
+
+Syntax highlighting helps, but to really make sense of some XML, proper
+indentation can be vital. Hence XML::LibXML::PrettyPrint - it can be applied to
+an XML::LibXML DOM tree to reformat it into a more readable result.
+
+Pretty-printing XML is not as CPU-efficient as dumping it out sloppily, so
+unless you're pretty sure that a human is going to need to make sense of your
+XML, you should probably not use this module.
+
+WWW: http://search.cpan.org/dist/XML-LibXML-PrettyPrint/
diff --git a/textproc/p5-XML-LibXML-PrettyPrint/pkg-plist b/textproc/p5-XML-LibXML-PrettyPrint/pkg-plist
new file mode 100644
index 000000000000..16f89786d923
--- /dev/null
+++ b/textproc/p5-XML-LibXML-PrettyPrint/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/XML/LibXML/PrettyPrint.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML/PrettyPrint/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML/PrettyPrint
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/LibXML
+@dirrmtry %%SITE_PERL%%/XML