aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2008-02-03 16:24:41 +0800
committerjohans <johans@FreeBSD.org>2008-02-03 16:24:41 +0800
commit992614013251b29da841ed6d7cca0551c20eac08 (patch)
tree78c8dfffdf5d256565d183eddd9253876ca188a4
parentebd04c41e154710b48202cd44f764a0e2b8f5538 (diff)
downloadfreebsd-ports-gnome-992614013251b29da841ed6d7cca0551c20eac08.tar.gz
freebsd-ports-gnome-992614013251b29da841ed6d7cca0551c20eac08.tar.zst
freebsd-ports-gnome-992614013251b29da841ed6d7cca0551c20eac08.zip
- Update to 3.5 g1
- Use standard $WWWDIR - Remove conflict with Apache
-rw-r--r--www/xshttpd/Makefile22
-rw-r--r--www/xshttpd/distinfo6
-rw-r--r--www/xshttpd/files/xshttpd.sh.in2
-rw-r--r--www/xshttpd/pkg-plist13
4 files changed, 25 insertions, 18 deletions
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index fdb619ce13ed..6fa4d831abb9 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xshttpd
-DISTVERSION= 3.4g01
+DISTVERSION= 3.5g01
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
ftp://mud.stack.nl/pub/xs-httpd/release/
@@ -15,13 +15,15 @@ DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
MAINTAINER= johans@stack.nl
COMMENT= A webserver with CGI as own user and SSL suport
-RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
+RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support \
+ ppmtogif:${PORTSDIR}/graphics/netpbm
-CONFLICTS+= apache-[0-9]* xshttpd-devel-[0-9]*
+CONFLICTS+= xshttpd-devel-[0-9]*
MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
- readxs.1 xsindex.1 xspasswd.1
+ readxs.1 xschpass.1 xsindex.1 xspasswd.1
MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
+MAN7= httpd_cgi.7 httpd_ssi.7
USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
@@ -29,20 +31,19 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SSL "Enable https support" On \
+ PCRE "Enable pcre rewriting support" On \
LDAP "Enable ldap support" Off \
- PCRE "Enable pcre rewriting support" Off \
CURL "Enable curl (proxy) support" Off \
M4_CONFIG "Enable m4 configuration preprocessor" Off \
PERSISTENT_PERL "Enable persistent perl interpreter" Off
-PORTDOCS= README BUGS COPYING ChangeLog
+PORTDOCS= README COPYING ChangeLog
+.include <bsd.port.pre.mk>
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
-WWWDIR?= ${PREFIX}/www
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
-.include <bsd.port.pre.mk>
-
.if !defined(WITHOUT_SSL)
.include <${PORTSDIR}/Mk/bsd.openssl.mk>
#USE_OPENSSL= yes
@@ -95,7 +96,8 @@ post-patch:
-e 's|nogroup|${WWWGRP}|g' \
${WRKSRC}/$i
.endfor
- @${REINPLACE_CMD} -e 's|\(MIMETYPESFILE\ "\).*|\1${LOCALBASE}/etc/mime.types"|' \
+ @${REINPLACE_CMD} \
+ -e 's|\(MIME_TYPES\).*|\1 "${LOCALBASE}/etc/mime.types"|' \
${WRKSRC}/src/confuser.h
@${REINPLACE_CMD} -e 's|mime.types ||g' \
${WRKSRC}/config/Makefile.in
diff --git a/www/xshttpd/distinfo b/www/xshttpd/distinfo
index 84ca2768ce14..859291d176bf 100644
--- a/www/xshttpd/distinfo
+++ b/www/xshttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (xshttpd-34g01.tar.bz2) = e18d3985a46118807976d7ac48c5cf06
-SHA256 (xshttpd-34g01.tar.bz2) = 3331a81c0568375c43444325469bfa9e049f4914f3e8f11adb3989fa6c24f90c
-SIZE (xshttpd-34g01.tar.bz2) = 200916
+MD5 (xshttpd-35g01.tar.bz2) = 4dca46e2cd8b4c632e1af4e05fbc60f9
+SHA256 (xshttpd-35g01.tar.bz2) = e1bd174d2be0ab0d891750696c3aa87f1d08a6b9e680a0b462fffc5baadbbb0e
+SIZE (xshttpd-35g01.tar.bz2) = 219795
diff --git a/www/xshttpd/files/xshttpd.sh.in b/www/xshttpd/files/xshttpd.sh.in
index cf038023446d..8380f36caef0 100644
--- a/www/xshttpd/files/xshttpd.sh.in
+++ b/www/xshttpd/files/xshttpd.sh.in
@@ -25,5 +25,7 @@ load_rc_config $name
pidfile="/var/run/httpd.pid"
command="%%PREFIX%%/bin/httpd"
+stop_cmd="%%PREFIX%%/bin/httpdc kill"
+restart_cmd="%%PREFIX%%/bin/httpdc restart"
run_rc_command "$1"
diff --git a/www/xshttpd/pkg-plist b/www/xshttpd/pkg-plist
index a53e0c9d173b..f3a5461818dc 100644
--- a/www/xshttpd/pkg-plist
+++ b/www/xshttpd/pkg-plist
@@ -8,6 +8,10 @@ bin/xspasswd
%%WWWDIR%%/cgi-bin/gfxcount
%%WWWDIR%%/cgi-bin/imagemap
%%WWWDIR%%/cgi-bin/xschpass
+%%WWWDIR%%/conf/httpd.conf.sample
+%%WWWDIR%%/conf/mime.index
+%%WWWDIR%%/conf/script.methods.sample
+%%WWWDIR%%/conf/compress.methods.sample
%%WWWDIR%%/contrib/SSL-Makefile
%%WWWDIR%%/contrib/agentstats.pl
%%WWWDIR%%/contrib/caroot.pem
@@ -15,7 +19,6 @@ bin/xspasswd
%%WWWDIR%%/contrib/persistent.pl
%%WWWDIR%%/contrib/powered-by-xs.gif
%%WWWDIR%%/contrib/wwwstats.pl
-%%WWWDIR%%/compress.methods.sample
%%WWWDIR%%/gfxcount/digital0.ppm
%%WWWDIR%%/gfxcount/digital1.ppm
%%WWWDIR%%/gfxcount/digital2.ppm
@@ -46,7 +49,6 @@ bin/xspasswd
%%WWWDIR%%/gfxcount/largecol7.ppm
%%WWWDIR%%/gfxcount/largecol8.ppm
%%WWWDIR%%/gfxcount/largecol9.ppm
-%%WWWDIR%%/httpd.conf.sample
%%WWWDIR%%/icons/xs-audio.gif
%%WWWDIR%%/icons/xs-back.gif
%%WWWDIR%%/icons/xs-base.gif
@@ -62,11 +64,12 @@ bin/xspasswd
%%WWWDIR%%/icons/xs-unknown.gif
%%WWWDIR%%/icons/xs-video.gif
%%WWWDIR%%/icons/xs-zip.gif
-%%WWWDIR%%/mime.index
-%%WWWDIR%%/script.methods.sample
+@exec mkdir -p %%WWWDIR%%/htdocs
@dirrm %%WWWDIR%%/contrib
@dirrm %%WWWDIR%%/gfxcount
-@dirrm %%WWWDIR%%/icons
@dirrmtry %%WWWDIR%%/cgi-bin
+@dirrmtry %%WWWDIR%%/conf
@dirrmtry %%WWWDIR%%/htdocs
+@dirrmtry %%WWWDIR%%/icons
@dirrmtry %%WWWDIR%%/logs
+@dirrmtry %%WWWDIR%%