aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-02 02:11:34 +0800
committeraz <az@FreeBSD.org>2013-09-02 02:11:34 +0800
commit9a5c6f5cfdf6034da71f78f1d558acdd91fe0f6e (patch)
tree4fd437540b45d077b1fe4864f19de0c6ab5c6da6
parenta899ad12c108052b4c1ddcbfe4166057207d4352 (diff)
downloadfreebsd-ports-gnome-9a5c6f5cfdf6034da71f78f1d558acdd91fe0f6e.tar.gz
freebsd-ports-gnome-9a5c6f5cfdf6034da71f78f1d558acdd91fe0f6e.tar.zst
freebsd-ports-gnome-9a5c6f5cfdf6034da71f78f1d558acdd91fe0f6e.zip
- Convert to new perl5 framework
- Convert USE_GMAKE to USES With hat: perl@
-rw-r--r--devel/libparserutils/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/libparserutils/Makefile b/devel/libparserutils/Makefile
index d203739167c5..734b07d391e6 100644
--- a/devel/libparserutils/Makefile
+++ b/devel/libparserutils/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= unobe@cpan.org
COMMENT= Library useful when writing parsers (formerly a part of NetSurf)
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -31,7 +31,8 @@ LDFLAGS+= -liconv
.if ${PORT_OPTIONS:MSTATIC}
PLIST_SUB+= NO_STATIC="@comment " STATIC=""
.else
-USE_PERL5_BUILD=yes
+USES+= perl5
+USE_PERL5= build
USE_LDCONFIG= yes
COMPONENT_TYPE= lib-shared
MAKE_ENV+= COMPONENT_TYPE=${COMPONENT_TYPE}
@@ -39,7 +40,8 @@ PLIST_SUB+= NO_STATIC="" STATIC="@comment "
.endif
.if ${PORT_OPTIONS:MTEST}
-USE_PERL5_BUILD=yes
+USES+= perl5
+USE_PERL5= build
ALL_TARGET+= test
.endif