aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-06 14:27:16 +0800
committerwill <will@FreeBSD.org>2000-12-06 14:27:16 +0800
commit9b7dec971800651b35086accf7828067c9386c27 (patch)
tree67ed20acd33a032230632e4abe705ed07b48e896
parent7b34590ab5c52efce32b000fa2a5701f737443f8 (diff)
downloadfreebsd-ports-gnome-9b7dec971800651b35086accf7828067c9386c27.tar.gz
freebsd-ports-gnome-9b7dec971800651b35086accf7828067c9386c27.tar.zst
freebsd-ports-gnome-9b7dec971800651b35086accf7828067c9386c27.zip
Update to QT 2.2.2; mostly minor bugfixes. Required for KDE 2.0.1.
Remove a patch in configure by replacing it with "yes yes" to automate accepting the GPL license (*sigh*) and avoiding interactive configure. *THIS TIME* I checked to make sure *.so wasn't removed accidentally. ;-)
-rw-r--r--x11-toolkits/qt22/Makefile17
-rw-r--r--x11-toolkits/qt22/distinfo2
-rw-r--r--x11-toolkits/qt22/files/patch-ae18
-rw-r--r--x11-toolkits/qt22/pkg-plist8
-rw-r--r--x11-toolkits/qt23/Makefile17
-rw-r--r--x11-toolkits/qt23/distinfo2
-rw-r--r--x11-toolkits/qt23/pkg-plist8
-rw-r--r--x11-toolkits/qt30/Makefile17
-rw-r--r--x11-toolkits/qt30/distinfo2
-rw-r--r--x11-toolkits/qt30/pkg-plist8
-rw-r--r--x11-toolkits/qt31/Makefile17
-rw-r--r--x11-toolkits/qt31/distinfo2
-rw-r--r--x11-toolkits/qt31/pkg-plist8
-rw-r--r--x11-toolkits/qt32/Makefile17
-rw-r--r--x11-toolkits/qt32/distinfo2
-rw-r--r--x11-toolkits/qt32/pkg-plist8
-rw-r--r--x11-toolkits/qt33/Makefile17
-rw-r--r--x11-toolkits/qt33/distinfo2
-rw-r--r--x11-toolkits/qt33/pkg-plist8
19 files changed, 60 insertions, 120 deletions
diff --git a/x11-toolkits/qt22/Makefile b/x11-toolkits/qt22/Makefile
index 7afd742c3a2f..add4d433e44a 100644
--- a/x11-toolkits/qt22/Makefile
+++ b/x11-toolkits/qt22/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
DISTNAME= qt-x11-${PORTVERSION}
@@ -17,6 +16,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+YES?= /usr/bin/yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
@@ -25,7 +25,7 @@ USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV= QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-${STATIC}
@@ -43,17 +43,6 @@ INSTALLS_SHLIB=yes
.endif
pre-fetch:
-.if !defined(QT_GIF_AVAILABLE) && !defined(HAVE_UNISYS_LICENSE)
- @${ECHO}
- @${ECHO} "GIF support is disabled in QT by default due to the"
- @${ECHO} "restrictive license on LZW compression owned by Unisys."
- @${ECHO} "To build with GIF support, use"
- @${ECHO}
- @${ECHO} " ${MAKE} -DQT_GIF_AVAILABLE [other args]"
- @${ECHO} "or"
- @${ECHO} " ${MAKE} -DHAVE_UNISYS_LICENSE [other args]"
- @${ECHO}
-.endif
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@${ECHO} "An older version of QT2 is installed. To avoid clobbering"
diff --git a/x11-toolkits/qt22/distinfo b/x11-toolkits/qt22/distinfo
index e7dbb76ab284..3d5ba8515875 100644
--- a/x11-toolkits/qt22/distinfo
+++ b/x11-toolkits/qt22/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.2.1.tar.gz) = c5a65c4ded0330fa6b44c24fd93b938e
+MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
diff --git a/x11-toolkits/qt22/files/patch-ae b/x11-toolkits/qt22/files/patch-ae
deleted file mode 100644
index 541ab816cb76..000000000000
--- a/x11-toolkits/qt22/files/patch-ae
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure Sun Sep 3 12:41:17 2000
-+++ configure.new Sun Sep 10 15:16:38 2000
-@@ -56,6 +56,7 @@
-
-
- # Free edition - may only be used under the terms of the QPL.
-+if false; then
- if [ -f LICENSE.QPL -a -f LICENSE.GPL ]
- then
- Edition=free
-@@ -184,6 +185,7 @@
- echo
- exit 0
- fi
-+fi
- fi
-
- # Remove the build options file
diff --git a/x11-toolkits/qt22/pkg-plist b/x11-toolkits/qt22/pkg-plist
index 75c2940bfb6b..ff6704797bce 100644
--- a/x11-toolkits/qt22/pkg-plist
+++ b/x11-toolkits/qt22/pkg-plist
@@ -43,9 +43,11 @@ include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
include/qt2/qconfig-dist.h
-include/qt2/qconfig-embedded.h
+include/qt2/qconfig-large.h
+include/qt2/qconfig-medium.h
include/qt2/qconfig-minimal.h
-include/qt2/qconfig-qpim.h
+include/qt2/qconfig-qpe.h
+include/qt2/qconfig-small.h
include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
@@ -725,6 +727,8 @@ share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
share/doc/qt2/html/qconststring-members.html
share/doc/qt2/html/qconststring.html
+share/doc/qt2/html/qcopchannel-members.html
+share/doc/qt2/html/qcopchannel.html
share/doc/qt2/html/qcstring-h.html
share/doc/qt2/html/qcstring-members.html
share/doc/qt2/html/qcstring.html
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 7afd742c3a2f..add4d433e44a 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
DISTNAME= qt-x11-${PORTVERSION}
@@ -17,6 +16,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+YES?= /usr/bin/yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
@@ -25,7 +25,7 @@ USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV= QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-${STATIC}
@@ -43,17 +43,6 @@ INSTALLS_SHLIB=yes
.endif
pre-fetch:
-.if !defined(QT_GIF_AVAILABLE) && !defined(HAVE_UNISYS_LICENSE)
- @${ECHO}
- @${ECHO} "GIF support is disabled in QT by default due to the"
- @${ECHO} "restrictive license on LZW compression owned by Unisys."
- @${ECHO} "To build with GIF support, use"
- @${ECHO}
- @${ECHO} " ${MAKE} -DQT_GIF_AVAILABLE [other args]"
- @${ECHO} "or"
- @${ECHO} " ${MAKE} -DHAVE_UNISYS_LICENSE [other args]"
- @${ECHO}
-.endif
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@${ECHO} "An older version of QT2 is installed. To avoid clobbering"
diff --git a/x11-toolkits/qt23/distinfo b/x11-toolkits/qt23/distinfo
index e7dbb76ab284..3d5ba8515875 100644
--- a/x11-toolkits/qt23/distinfo
+++ b/x11-toolkits/qt23/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.2.1.tar.gz) = c5a65c4ded0330fa6b44c24fd93b938e
+MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
diff --git a/x11-toolkits/qt23/pkg-plist b/x11-toolkits/qt23/pkg-plist
index 75c2940bfb6b..ff6704797bce 100644
--- a/x11-toolkits/qt23/pkg-plist
+++ b/x11-toolkits/qt23/pkg-plist
@@ -43,9 +43,11 @@ include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
include/qt2/qconfig-dist.h
-include/qt2/qconfig-embedded.h
+include/qt2/qconfig-large.h
+include/qt2/qconfig-medium.h
include/qt2/qconfig-minimal.h
-include/qt2/qconfig-qpim.h
+include/qt2/qconfig-qpe.h
+include/qt2/qconfig-small.h
include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
@@ -725,6 +727,8 @@ share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
share/doc/qt2/html/qconststring-members.html
share/doc/qt2/html/qconststring.html
+share/doc/qt2/html/qcopchannel-members.html
+share/doc/qt2/html/qcopchannel.html
share/doc/qt2/html/qcstring-h.html
share/doc/qt2/html/qcstring-members.html
share/doc/qt2/html/qcstring.html
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index 7afd742c3a2f..add4d433e44a 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
DISTNAME= qt-x11-${PORTVERSION}
@@ -17,6 +16,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+YES?= /usr/bin/yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
@@ -25,7 +25,7 @@ USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV= QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-${STATIC}
@@ -43,17 +43,6 @@ INSTALLS_SHLIB=yes
.endif
pre-fetch:
-.if !defined(QT_GIF_AVAILABLE) && !defined(HAVE_UNISYS_LICENSE)
- @${ECHO}
- @${ECHO} "GIF support is disabled in QT by default due to the"
- @${ECHO} "restrictive license on LZW compression owned by Unisys."
- @${ECHO} "To build with GIF support, use"
- @${ECHO}
- @${ECHO} " ${MAKE} -DQT_GIF_AVAILABLE [other args]"
- @${ECHO} "or"
- @${ECHO} " ${MAKE} -DHAVE_UNISYS_LICENSE [other args]"
- @${ECHO}
-.endif
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@${ECHO} "An older version of QT2 is installed. To avoid clobbering"
diff --git a/x11-toolkits/qt30/distinfo b/x11-toolkits/qt30/distinfo
index e7dbb76ab284..3d5ba8515875 100644
--- a/x11-toolkits/qt30/distinfo
+++ b/x11-toolkits/qt30/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.2.1.tar.gz) = c5a65c4ded0330fa6b44c24fd93b938e
+MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
diff --git a/x11-toolkits/qt30/pkg-plist b/x11-toolkits/qt30/pkg-plist
index 75c2940bfb6b..ff6704797bce 100644
--- a/x11-toolkits/qt30/pkg-plist
+++ b/x11-toolkits/qt30/pkg-plist
@@ -43,9 +43,11 @@ include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
include/qt2/qconfig-dist.h
-include/qt2/qconfig-embedded.h
+include/qt2/qconfig-large.h
+include/qt2/qconfig-medium.h
include/qt2/qconfig-minimal.h
-include/qt2/qconfig-qpim.h
+include/qt2/qconfig-qpe.h
+include/qt2/qconfig-small.h
include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
@@ -725,6 +727,8 @@ share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
share/doc/qt2/html/qconststring-members.html
share/doc/qt2/html/qconststring.html
+share/doc/qt2/html/qcopchannel-members.html
+share/doc/qt2/html/qcopchannel.html
share/doc/qt2/html/qcstring-h.html
share/doc/qt2/html/qcstring-members.html
share/doc/qt2/html/qcstring.html
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index 7afd742c3a2f..add4d433e44a 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
DISTNAME= qt-x11-${PORTVERSION}
@@ -17,6 +16,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+YES?= /usr/bin/yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
@@ -25,7 +25,7 @@ USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV= QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-${STATIC}
@@ -43,17 +43,6 @@ INSTALLS_SHLIB=yes
.endif
pre-fetch:
-.if !defined(QT_GIF_AVAILABLE) && !defined(HAVE_UNISYS_LICENSE)
- @${ECHO}
- @${ECHO} "GIF support is disabled in QT by default due to the"
- @${ECHO} "restrictive license on LZW compression owned by Unisys."
- @${ECHO} "To build with GIF support, use"
- @${ECHO}
- @${ECHO} " ${MAKE} -DQT_GIF_AVAILABLE [other args]"
- @${ECHO} "or"
- @${ECHO} " ${MAKE} -DHAVE_UNISYS_LICENSE [other args]"
- @${ECHO}
-.endif
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@${ECHO} "An older version of QT2 is installed. To avoid clobbering"
diff --git a/x11-toolkits/qt31/distinfo b/x11-toolkits/qt31/distinfo
index e7dbb76ab284..3d5ba8515875 100644
--- a/x11-toolkits/qt31/distinfo
+++ b/x11-toolkits/qt31/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.2.1.tar.gz) = c5a65c4ded0330fa6b44c24fd93b938e
+MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
diff --git a/x11-toolkits/qt31/pkg-plist b/x11-toolkits/qt31/pkg-plist
index 75c2940bfb6b..ff6704797bce 100644
--- a/x11-toolkits/qt31/pkg-plist
+++ b/x11-toolkits/qt31/pkg-plist
@@ -43,9 +43,11 @@ include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
include/qt2/qconfig-dist.h
-include/qt2/qconfig-embedded.h
+include/qt2/qconfig-large.h
+include/qt2/qconfig-medium.h
include/qt2/qconfig-minimal.h
-include/qt2/qconfig-qpim.h
+include/qt2/qconfig-qpe.h
+include/qt2/qconfig-small.h
include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
@@ -725,6 +727,8 @@ share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
share/doc/qt2/html/qconststring-members.html
share/doc/qt2/html/qconststring.html
+share/doc/qt2/html/qcopchannel-members.html
+share/doc/qt2/html/qcopchannel.html
share/doc/qt2/html/qcstring-h.html
share/doc/qt2/html/qcstring-members.html
share/doc/qt2/html/qcstring.html
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index 7afd742c3a2f..add4d433e44a 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
DISTNAME= qt-x11-${PORTVERSION}
@@ -17,6 +16,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+YES?= /usr/bin/yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
@@ -25,7 +25,7 @@ USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV= QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-${STATIC}
@@ -43,17 +43,6 @@ INSTALLS_SHLIB=yes
.endif
pre-fetch:
-.if !defined(QT_GIF_AVAILABLE) && !defined(HAVE_UNISYS_LICENSE)
- @${ECHO}
- @${ECHO} "GIF support is disabled in QT by default due to the"
- @${ECHO} "restrictive license on LZW compression owned by Unisys."
- @${ECHO} "To build with GIF support, use"
- @${ECHO}
- @${ECHO} " ${MAKE} -DQT_GIF_AVAILABLE [other args]"
- @${ECHO} "or"
- @${ECHO} " ${MAKE} -DHAVE_UNISYS_LICENSE [other args]"
- @${ECHO}
-.endif
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@${ECHO} "An older version of QT2 is installed. To avoid clobbering"
diff --git a/x11-toolkits/qt32/distinfo b/x11-toolkits/qt32/distinfo
index e7dbb76ab284..3d5ba8515875 100644
--- a/x11-toolkits/qt32/distinfo
+++ b/x11-toolkits/qt32/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.2.1.tar.gz) = c5a65c4ded0330fa6b44c24fd93b938e
+MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
diff --git a/x11-toolkits/qt32/pkg-plist b/x11-toolkits/qt32/pkg-plist
index 75c2940bfb6b..ff6704797bce 100644
--- a/x11-toolkits/qt32/pkg-plist
+++ b/x11-toolkits/qt32/pkg-plist
@@ -43,9 +43,11 @@ include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
include/qt2/qconfig-dist.h
-include/qt2/qconfig-embedded.h
+include/qt2/qconfig-large.h
+include/qt2/qconfig-medium.h
include/qt2/qconfig-minimal.h
-include/qt2/qconfig-qpim.h
+include/qt2/qconfig-qpe.h
+include/qt2/qconfig-small.h
include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
@@ -725,6 +727,8 @@ share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
share/doc/qt2/html/qconststring-members.html
share/doc/qt2/html/qconststring.html
+share/doc/qt2/html/qcopchannel-members.html
+share/doc/qt2/html/qcopchannel.html
share/doc/qt2/html/qcstring-h.html
share/doc/qt2/html/qcstring-members.html
share/doc/qt2/html/qcstring.html
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 7afd742c3a2f..add4d433e44a 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
DISTNAME= qt-x11-${PORTVERSION}
@@ -17,6 +16,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+YES?= /usr/bin/yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
USE_GMAKE= yes
@@ -25,7 +25,7 @@ USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV= QTDIR=${WRKSRC}
+CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-${STATIC}
@@ -43,17 +43,6 @@ INSTALLS_SHLIB=yes
.endif
pre-fetch:
-.if !defined(QT_GIF_AVAILABLE) && !defined(HAVE_UNISYS_LICENSE)
- @${ECHO}
- @${ECHO} "GIF support is disabled in QT by default due to the"
- @${ECHO} "restrictive license on LZW compression owned by Unisys."
- @${ECHO} "To build with GIF support, use"
- @${ECHO}
- @${ECHO} " ${MAKE} -DQT_GIF_AVAILABLE [other args]"
- @${ECHO} "or"
- @${ECHO} " ${MAKE} -DHAVE_UNISYS_LICENSE [other args]"
- @${ECHO}
-.endif
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@${ECHO} "An older version of QT2 is installed. To avoid clobbering"
diff --git a/x11-toolkits/qt33/distinfo b/x11-toolkits/qt33/distinfo
index e7dbb76ab284..3d5ba8515875 100644
--- a/x11-toolkits/qt33/distinfo
+++ b/x11-toolkits/qt33/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.2.1.tar.gz) = c5a65c4ded0330fa6b44c24fd93b938e
+MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
diff --git a/x11-toolkits/qt33/pkg-plist b/x11-toolkits/qt33/pkg-plist
index 75c2940bfb6b..ff6704797bce 100644
--- a/x11-toolkits/qt33/pkg-plist
+++ b/x11-toolkits/qt33/pkg-plist
@@ -43,9 +43,11 @@ include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
include/qt2/qconfig-dist.h
-include/qt2/qconfig-embedded.h
+include/qt2/qconfig-large.h
+include/qt2/qconfig-medium.h
include/qt2/qconfig-minimal.h
-include/qt2/qconfig-qpim.h
+include/qt2/qconfig-qpe.h
+include/qt2/qconfig-small.h
include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
@@ -725,6 +727,8 @@ share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
share/doc/qt2/html/qconststring-members.html
share/doc/qt2/html/qconststring.html
+share/doc/qt2/html/qcopchannel-members.html
+share/doc/qt2/html/qcopchannel.html
share/doc/qt2/html/qcstring-h.html
share/doc/qt2/html/qcstring-members.html
share/doc/qt2/html/qcstring.html