aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2008-11-25 23:34:53 +0800
committerlth <lth@FreeBSD.org>2008-11-25 23:34:53 +0800
commit9c08caf86e305081a0426f91a2a6747ad333a62c (patch)
treef4a7f782562e021cdd8911f09cf0ef94e394c688
parent962b94dba7ae01a6bb357735a8782e7bfd7ae56b (diff)
downloadfreebsd-ports-gnome-9c08caf86e305081a0426f91a2a6747ad333a62c.tar.gz
freebsd-ports-gnome-9c08caf86e305081a0426f91a2a6747ad333a62c.tar.zst
freebsd-ports-gnome-9c08caf86e305081a0426f91a2a6747ad333a62c.zip
Add p5-Test-WWW-Mechanize-CGI 0.1, test CGI applications with
Test::WWW::Mechanize.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGI/Makefile25
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGI/distinfo3
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGI/pkg-descr4
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGI/pkg-plist9
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3c84d1b5fb69..e7f413ec79ba 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1810,6 +1810,7 @@
SUBDIR += p5-Test-Unit
SUBDIR += p5-Test-UseAllModules
SUBDIR += p5-Test-WWW-Mechanize
+ SUBDIR += p5-Test-WWW-Mechanize-CGI
SUBDIR += p5-Test-WWW-Mechanize-CGIApp
SUBDIR += p5-Test-WWW-Mechanize-Catalyst
SUBDIR += p5-Test-Warn
diff --git a/devel/p5-Test-WWW-Mechanize-CGI/Makefile b/devel/p5-Test-WWW-Mechanize-CGI/Makefile
new file mode 100644
index 000000000000..1a16a71ec2aa
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGI/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Test-WWW-Mechanize-CGI
+# Date created: 25 November 2008
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-WWW-Mechanize-CGI
+PORTVERSION= 0.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Test CGI applications with Test::WWW::Mechanize
+
+RUN_DEPENDS= p5-WWW-Mechanize-CGI>=0.2:${PORTSDIR}/www/p5-WWW-Mechanize-CGI \
+ p5-Test-WWW-Mechanize>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::WWW::Mechanize::CGI.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-WWW-Mechanize-CGI/distinfo b/devel/p5-Test-WWW-Mechanize-CGI/distinfo
new file mode 100644
index 000000000000..383dcfbac646
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-WWW-Mechanize-CGI-0.1.tar.gz) = 55fea6cdaa85433060c3d55a4982272e
+SHA256 (Test-WWW-Mechanize-CGI-0.1.tar.gz) = a576a0b22e3bd1afc9274fc563b037aeee77713849c9ebf6a6ad4415c16c9c2f
+SIZE (Test-WWW-Mechanize-CGI-0.1.tar.gz) = 1621
diff --git a/devel/p5-Test-WWW-Mechanize-CGI/pkg-descr b/devel/p5-Test-WWW-Mechanize-CGI/pkg-descr
new file mode 100644
index 000000000000..6d0a3dc0f4a2
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGI/pkg-descr
@@ -0,0 +1,4 @@
+Provides a convenient way of testing CGI applications without a
+external daemon.
+
+WWW: http://search.cpan.org/dist/Test-WWW-Mechanize-CGI/
diff --git a/devel/p5-Test-WWW-Mechanize-CGI/pkg-plist b/devel/p5-Test-WWW-Mechanize-CGI/pkg-plist
new file mode 100644
index 000000000000..15b751e6be51
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGI/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Test/WWW/Mechanize/CGI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize/CGI/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize/CGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/Test/WWW
+@dirrmtry %%SITE_PERL%%/Test