aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-01-09 05:57:12 +0800
committerglarkin <glarkin@FreeBSD.org>2010-01-09 05:57:12 +0800
commit9c2beeef230bb253477e75ca3413526130d2acd7 (patch)
treedbe0e790dae250834b0c0d9693ee326d0b6f8528
parent18d46ecb12a546dfab36488c74e011f8dd1292f9 (diff)
downloadfreebsd-ports-gnome-9c2beeef230bb253477e75ca3413526130d2acd7.tar.gz
freebsd-ports-gnome-9c2beeef230bb253477e75ca3413526130d2acd7.tar.zst
freebsd-ports-gnome-9c2beeef230bb253477e75ca3413526130d2acd7.zip
This script takes information from "SHOW STATUS LIKE..."
and "SHOW VARIABLES LIKE..." then attempts to produce sane recommendations for tuning server variables. It is compatible with all versions of MySQL 3.23 - 5.1. WWW: https://launchpad.net/mysql-tuning-primer PR: ports/140641 Submitted by: Joe Horn <joehorn at gmail.com>
-rw-r--r--databases/Makefile1
-rw-r--r--databases/tuning-primer/Makefile30
-rw-r--r--databases/tuning-primer/distinfo3
-rw-r--r--databases/tuning-primer/pkg-descr7
4 files changed, 41 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 66e2a42e9416..d2c6410b1b1e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -687,6 +687,7 @@
SUBDIR += tokyocabinet
SUBDIR += tokyotyrant
SUBDIR += tora
+ SUBDIR += tuning-primer
SUBDIR += typhoon
SUBDIR += unixODBC
SUBDIR += useracc
diff --git a/databases/tuning-primer/Makefile b/databases/tuning-primer/Makefile
new file mode 100644
index 000000000000..47cd2c77de1f
--- /dev/null
+++ b/databases/tuning-primer/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: tuning-primer
+# Date created: 2009-11-18
+# Whom: Joe Horn <joehorn@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuning-primer
+PORTVERSION= 1.5.r5
+CATEGORIES= databases
+MASTER_SITES= http://launchpadlibrarian.net/36004840/
+DISTNAME= ${PORTNAME}.sh
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= joehorn@gmail.com
+COMMENT= MySQL performance tuning primer script
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ @${CP} ${DISTDIR}/${PORTNAME}.sh \
+ ${PREFIX}/bin/${PORTNAME}
+ @${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}
+ @${ECHO_CMD} '@exec ${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}' \
+ >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/databases/tuning-primer/distinfo b/databases/tuning-primer/distinfo
new file mode 100644
index 000000000000..d38f61f6301d
--- /dev/null
+++ b/databases/tuning-primer/distinfo
@@ -0,0 +1,3 @@
+MD5 (tuning-primer.sh) = a56a4e1a57b56105141d9cda653678f8
+SHA256 (tuning-primer.sh) = f13ab4a62f009870fe65c0baa72b8a9882e8d5475e5f35fde68f6d9fba4b03f1
+SIZE (tuning-primer.sh) = 49824
diff --git a/databases/tuning-primer/pkg-descr b/databases/tuning-primer/pkg-descr
new file mode 100644
index 000000000000..d09b5e5fbab6
--- /dev/null
+++ b/databases/tuning-primer/pkg-descr
@@ -0,0 +1,7 @@
+This script takes information from "SHOW STATUS LIKE..."
+and "SHOW VARIABLES LIKE..." then attempts to produce
+sane recommendations for tuning server variables.
+
+It is compatible with all versions of MySQL 3.23 - 5.1.
+
+WWW: https://launchpad.net/mysql-tuning-primer