aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-03 04:01:57 +0800
committererwin <erwin@FreeBSD.org>2005-12-03 04:01:57 +0800
commit9c9d1804670f36412873d101a083c0551e19cc7c (patch)
tree98f28d0c9744abcd479009cfbeed800a9f2c410d
parentd253bbef93ea2ad3487659167058d34df7e05935 (diff)
downloadfreebsd-ports-gnome-9c9d1804670f36412873d101a083c0551e19cc7c.tar.gz
freebsd-ports-gnome-9c9d1804670f36412873d101a083c0551e19cc7c.tar.zst
freebsd-ports-gnome-9c9d1804670f36412873d101a083c0551e19cc7c.zip
ExtUtils::AutoInstall lets module writers to specify a more
sophisticated form of dependency information than the PREREQ_PM option offered by ExtUtils::MakeMaker. This module works best with the Module::Install framework, a drop-in replacement for MakeMaker. WWW: http://search.cpan.org/dist/ExtUtils-AutoInstall/ PR: ports/89855 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-AutoInstall/Makefile35
-rw-r--r--devel/p5-ExtUtils-AutoInstall/distinfo3
-rw-r--r--devel/p5-ExtUtils-AutoInstall/pkg-descr8
-rw-r--r--devel/p5-ExtUtils-AutoInstall/pkg-plist5
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b72c1066407b..e8e9d34b9174 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -891,6 +891,7 @@
SUBDIR += p5-Exception-Class
SUBDIR += p5-Exporter-Lite
SUBDIR += p5-Exporter-Tidy
+ SUBDIR += p5-ExtUtils-AutoInstall
SUBDIR += p5-ExtUtils-CBuilder
SUBDIR += p5-ExtUtils-Constant
SUBDIR += p5-ExtUtils-Depends
diff --git a/devel/p5-ExtUtils-AutoInstall/Makefile b/devel/p5-ExtUtils-AutoInstall/Makefile
new file mode 100644
index 000000000000..dda4b8edde02
--- /dev/null
+++ b/devel/p5-ExtUtils-AutoInstall/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ExtUtils-AutoInstall
+# Date created: 2 December 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-AutoInstall
+PORTVERSION= 0.63
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Automatic install of dependencies via CPAN
+
+BUILD_DEPENDS= p5-ExtUtils-MakeMaker>=0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
+ p5-version>=0.28:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::AutoInstall.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higer. Install lang/perl5 or lang/perl5.8 and try again.
+.endif
+
+post-extract:
+ @${PERL} -i.bak -ne 'print unless m,^features, .. m,^\);,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-ExtUtils-AutoInstall/distinfo b/devel/p5-ExtUtils-AutoInstall/distinfo
new file mode 100644
index 000000000000..65ff35dc5ef1
--- /dev/null
+++ b/devel/p5-ExtUtils-AutoInstall/distinfo
@@ -0,0 +1,3 @@
+MD5 (ExtUtils-AutoInstall-0.63.tar.gz) = 87ce9c44a8ab52e9b0553a2e46805525
+SHA256 (ExtUtils-AutoInstall-0.63.tar.gz) = 829d4976e85d04dd18e24f500d03fb662e40aabf8609b633331b1925e0455299
+SIZE (ExtUtils-AutoInstall-0.63.tar.gz) = 26951
diff --git a/devel/p5-ExtUtils-AutoInstall/pkg-descr b/devel/p5-ExtUtils-AutoInstall/pkg-descr
new file mode 100644
index 000000000000..9871ddf27ac2
--- /dev/null
+++ b/devel/p5-ExtUtils-AutoInstall/pkg-descr
@@ -0,0 +1,8 @@
+ExtUtils::AutoInstall lets module writers to specify a more
+sophisticated form of dependency information than the PREREQ_PM
+option offered by ExtUtils::MakeMaker.
+
+This module works best with the Module::Install framework,
+a drop-in replacement for MakeMaker.
+
+WWW: http://search.cpan.org/dist/ExtUtils-AutoInstall/
diff --git a/devel/p5-ExtUtils-AutoInstall/pkg-plist b/devel/p5-ExtUtils-AutoInstall/pkg-plist
new file mode 100644
index 000000000000..8f2f51037f00
--- /dev/null
+++ b/devel/p5-ExtUtils-AutoInstall/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/AutoInstall/.packlist
+%%SITE_PERL%%/ExtUtils/AutoInstall.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/AutoInstall
+@unexec rmdir %D/%%SITE_PERL%%/ExtUtils 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils 2>/dev/null || true