aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-07-17 12:02:02 +0800
committermiwi <miwi@FreeBSD.org>2013-07-17 12:02:02 +0800
commit9d09ed657a145e5a8ffea19c29f8abf1b25cdb4e (patch)
tree95e9433e22469019a0d016bbe704a0eef4a0ed28
parentf7aa78360b01f78c3017376905be8fc09f3a4ec7 (diff)
downloadfreebsd-ports-gnome-9d09ed657a145e5a8ffea19c29f8abf1b25cdb4e.tar.gz
freebsd-ports-gnome-9d09ed657a145e5a8ffea19c29f8abf1b25cdb4e.tar.zst
freebsd-ports-gnome-9d09ed657a145e5a8ffea19c29f8abf1b25cdb4e.zip
- Update to 0.9.5
-rw-r--r--security/pam_ssh_agent_auth/Makefile10
-rw-r--r--security/pam_ssh_agent_auth/distinfo4
-rw-r--r--security/pam_ssh_agent_auth/files/patch-openbsd85
3 files changed, 5 insertions, 94 deletions
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index 25a60e8c506e..225d4692e666 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -1,13 +1,8 @@
-# Ports collection makefile for: pam_ssh_agent_auth
-# Date created: 26 December 2009
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pam_ssh_agent_auth
-PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTVERSION= 0.9.5
CATEGORIES= security
MASTER_SITES= SF/pamsshagentauth/${PORTNAME}/v${PORTVERSION}/
@@ -16,6 +11,7 @@ COMMENT= PAM module which permits authentication via ssh-agent
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= ac_cv_func_strnvis=no
CONFIGURE_ARGS= --libexecdir=${LOCALBASE}/lib
USE_PERL5= yes
diff --git a/security/pam_ssh_agent_auth/distinfo b/security/pam_ssh_agent_auth/distinfo
index 5b1bec9e0db6..2b05c73ee34d 100644
--- a/security/pam_ssh_agent_auth/distinfo
+++ b/security/pam_ssh_agent_auth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pam_ssh_agent_auth-0.9.4.tar.bz2) = 496de600771d6296c7a7d01636399fd603e5a79930416ffbdc150c3784d80ca9
-SIZE (pam_ssh_agent_auth-0.9.4.tar.bz2) = 239250
+SHA256 (pam_ssh_agent_auth-0.9.5.tar.bz2) = c0933b57a44003e32e761a742f3b117978aaa9780dc4d2808378db13a47730aa
+SIZE (pam_ssh_agent_auth-0.9.5.tar.bz2) = 238267
diff --git a/security/pam_ssh_agent_auth/files/patch-openbsd b/security/pam_ssh_agent_auth/files/patch-openbsd
deleted file mode 100644
index 7f3072be5110..000000000000
--- a/security/pam_ssh_agent_auth/files/patch-openbsd
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -ur openbsd-compat/base64.h openbsd-compat/base64.h
---- openbsd-compat/base64.h 2013-02-19 17:52:53.000000000 +0400
-+++ openbsd-compat/base64.h 2013-02-19 17:49:44.000000000 +0400
-@@ -54,6 +54,7 @@
- # endif /* !HAVE_B64_NTOP */
- # define pamsshagentauth___b64_ntop(a,b,c,d) b64_ntop(a,b,c,d)
- #endif /* HAVE___B64_NTOP */
-+#define pamsshagentauth___b64_ntop(a,b,c,d) __b64_ntop(a,b,c,d)
-
- #ifndef HAVE___B64_PTON
- # ifndef HAVE_B64_PTON
-@@ -61,5 +62,6 @@
- # endif /* !HAVE_B64_PTON */
- # define pamsshagentauth___b64_pton(a,b,c) b64_pton(a,b,c)
- #endif /* HAVE___B64_PTON */
-+#define pamsshagentauth___b64_pton(a,b,c) __b64_pton(a,b,c)
-
- #endif /* _BSD_BASE64_H */
-diff -ur openbsd-compat/bsd-arc4random.c openbsd-compat/bsd-arc4random.c
---- openbsd-compat/bsd-arc4random.c 2012-06-28 05:47:49.000000000 +0400
-+++ openbsd-compat/bsd-arc4random.c 2013-02-19 18:02:38.000000000 +0400
-@@ -82,4 +82,17 @@
-
- rc4_ready = REKEY_BYTES;
- }
-+#else /* HAVE_ARC4RANDOM */
-+
-+unsigned int
-+pamsshagentauth_arc4random(void)
-+{
-+ return arc4random();
-+}
-+
-+void
-+pamsshagentauth_arc4random_stir(void)
-+{
-+ arc4random_stir();
-+}
- #endif /* !HAVE_ARC4RANDOM */
-diff -ur openbsd-compat/strlcat.c openbsd-compat/strlcat.c
---- openbsd-compat/strlcat.c 2012-06-28 05:47:49.000000000 +0400
-+++ openbsd-compat/strlcat.c 2013-02-19 18:03:34.000000000 +0400
-@@ -59,4 +59,10 @@
- return(dlen + (s - src)); /* count does not include NUL */
- }
-
-+#else /* HAVE_STRLCAT */
-+size_t
-+pamsshagentauth_strlcat(char *dst, const char *src, size_t siz)
-+{
-+ return strlcat(dst, src, siz);
-+}
- #endif /* !HAVE_STRLCAT */
-diff -ur openbsd-compat/strlcpy.c openbsd-compat/strlcpy.c
---- openbsd-compat/strlcpy.c 2012-06-28 05:47:49.000000000 +0400
-+++ openbsd-compat/strlcpy.c 2013-02-19 18:04:18.000000000 +0400
-@@ -55,4 +55,10 @@
- return(s - src - 1); /* count does not include NUL */
- }
-
-+#else /* HAVE_STRLCPY */
-+size_t
-+pamsshagentauth_strlcpy(char *dst, const char *src, size_t siz)
-+{
-+ return strlcpy(dst, src, siz);
-+}
- #endif /* !HAVE_STRLCPY */
-diff -ur openbsd-compat/strtonum.c openbsd-compat/strtonum.c
---- openbsd-compat/strtonum.c 2012-06-28 05:47:49.000000000 +0400
-+++ openbsd-compat/strtonum.c 2013-02-19 18:05:16.000000000 +0400
-@@ -69,4 +69,11 @@
- return (ll);
- }
-
--#endif /* HAVE_STRTONUM */
-+#else /* HAVE_STRTONUM */
-+long long
-+pamsshagentauth_strtonum(const char *numstr, long long minval, long long maxval,
-+ const char **errstrp)
-+{
-+ return strtonum(numstr, minval, maxval, errstrp);
-+}
-+#endif /* i!HAVE_STRTONUM */
-
-