aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-02-05 17:55:35 +0800
committermaho <maho@FreeBSD.org>2006-02-05 17:55:35 +0800
commit9dc093123955a63d81469391b31f1c9515f21520 (patch)
treee1b08732f85d0c3eb2138da22dfc9c2b5109b6a0
parent82e0f46c15e93234c81b8bc37e663b730f3758d5 (diff)
downloadfreebsd-ports-gnome-9dc093123955a63d81469391b31f1c9515f21520.tar.gz
freebsd-ports-gnome-9dc093123955a63d81469391b31f1c9515f21520.tar.zst
freebsd-ports-gnome-9dc093123955a63d81469391b31f1c9515f21520.zip
The fpkg is Package Tool Wrapper for FreeBSD.
It makes convenient in administration of package, like yum, apt-get, and dpkg. * Display a list of files in package (list) * Display a package information (info) * Install package from ftp server (install) * Fetching package list (update) * Package name search on package list (search) * All text search on package list (allsearch) WWW: http://www.shimazu.org/fpkg/ Submitted by: Yuki SHIMAZU <y.shimazu@nifty.com> via mixi
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fpkg/Makefile33
-rw-r--r--sysutils/fpkg/distinfo2
-rw-r--r--sysutils/fpkg/pkg-descr12
-rw-r--r--sysutils/fpkg/pkg-plist1
5 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 33e011e4f47c..69d2266b123b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -162,6 +162,7 @@
SUBDIR += fonteditfs
SUBDIR += foremost
SUBDIR += fortunelock
+ SUBDIR += fpkg
SUBDIR += freebsd-sha1
SUBDIR += freebsd-sha256
SUBDIR += freebsd-snapshot
diff --git a/sysutils/fpkg/Makefile b/sysutils/fpkg/Makefile
new file mode 100644
index 000000000000..006d5db8ac77
--- /dev/null
+++ b/sysutils/fpkg/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fpkg
+# Date created: 28 January 2006
+# Whom: Yuki SHIMAZU <y.shimazu@nifty.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpkg
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://www.shimazu.org/fpkg/
+EXTRACT_SUFX=
+
+MAINTAINER= y.shimazu@nifty.com
+COMMENT= Package Tool Wrapper for FreeBSD
+
+USE_PERL5= YES
+NO_WRKSUBDIR= YES
+NO_BUILD= YES
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= .
+PLIST_SUB= INSTALL_BASE=${INSTALL_BASE}
+
+INSTALL_BASE= bin
+INSTALL_DIR= ${PREFIX}/${INSTALL_BASE}
+
+do-install:
+ ${MKDIR} ${INSTALL_DIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${INSTALL_DIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/fpkg/distinfo b/sysutils/fpkg/distinfo
new file mode 100644
index 000000000000..04dc425e4631
--- /dev/null
+++ b/sysutils/fpkg/distinfo
@@ -0,0 +1,2 @@
+MD5 (fpkg-0.2) = 402f51b918b430103ee6b3780a8ee217
+SIZE (fpkg-0.2) = 4152
diff --git a/sysutils/fpkg/pkg-descr b/sysutils/fpkg/pkg-descr
new file mode 100644
index 000000000000..eaa08425dea0
--- /dev/null
+++ b/sysutils/fpkg/pkg-descr
@@ -0,0 +1,12 @@
+The fpkg is Package Tool Wrapper for FreeBSD.
+It makes convenient in administration of package,
+like yum, apt-get, and dpkg.
+
+* Display a list of files in package (list)
+* Display a package information (info)
+* Install package from ftp server (install)
+* Fetching package list (update)
+* Package name search on package list (search)
+* All text search on package list (allsearch)
+
+WWW: http://www.shimazu.org/fpkg/
diff --git a/sysutils/fpkg/pkg-plist b/sysutils/fpkg/pkg-plist
new file mode 100644
index 000000000000..748781ac193a
--- /dev/null
+++ b/sysutils/fpkg/pkg-plist
@@ -0,0 +1 @@
+bin/fpkg