aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-29 15:27:31 +0800
committerwen <wen@FreeBSD.org>2010-03-29 15:27:31 +0800
commit9dd966ebe6b90c95aa430e96049be34f431bd84b (patch)
tree54df5b88122546a0c84771d1e2afefee9142acb9
parent064cc94ae55ebd5dbc514c188f626d2fea64a02a (diff)
downloadfreebsd-ports-gnome-9dd966ebe6b90c95aa430e96049be34f431bd84b.tar.gz
freebsd-ports-gnome-9dd966ebe6b90c95aa430e96049be34f431bd84b.tar.zst
freebsd-ports-gnome-9dd966ebe6b90c95aa430e96049be34f431bd84b.zip
paragrep is a paragraph grep utility. It searches for a series of
regular expressions in a text file (or several text files) and prints out the paragraphs containing those expressions. WWW: http://bmc.github.com/paragrep/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-paragrep/Makefile31
-rw-r--r--textproc/py-paragrep/distinfo3
-rw-r--r--textproc/py-paragrep/files/patch-setup.py22
-rw-r--r--textproc/py-paragrep/pkg-descr5
-rw-r--r--textproc/py-paragrep/pkg-plist17
6 files changed, 79 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 451ac09a8859..56d01303eb68 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -963,6 +963,7 @@
SUBDIR += py-mako
SUBDIR += py-markdown
SUBDIR += py-markdown2
+ SUBDIR += py-paragrep
SUBDIR += py-pygments
SUBDIR += py-pyx12
SUBDIR += py-qt4-xml
diff --git a/textproc/py-paragrep/Makefile b/textproc/py-paragrep/Makefile
new file mode 100644
index 000000000000..266211b743fb
--- /dev/null
+++ b/textproc/py-paragrep/Makefile
@@ -0,0 +1,31 @@
+# Ports collection Makefile for: py-paragrep
+# Date created: Mar 29, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= paragrep
+PORTVERSION= 3.0.5
+CATEGORIES= textproc python
+MASTER_SITES= http://github.com/bmc/paragrep/zipball/release-3.0.5/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= bmc-${PORTNAME}-48708ef
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Paragraph Grep Utility
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}grizzled>=0.8.1:${PORTSDIR}/devel/py-grizzled
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FETCH_ARGS=
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+MAN1= paragrep.1
+
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/man/paragrep.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/textproc/py-paragrep/distinfo b/textproc/py-paragrep/distinfo
new file mode 100644
index 000000000000..65b96fe3e10b
--- /dev/null
+++ b/textproc/py-paragrep/distinfo
@@ -0,0 +1,3 @@
+MD5 (bmc-paragrep-48708ef.zip) = c387542258604c9be2114630e4dbc04b
+SHA256 (bmc-paragrep-48708ef.zip) = f86ed36d8168c68beff3a82fd3e61b6b0afbefb3eac82540429d98e120caa86e
+SIZE (bmc-paragrep-48708ef.zip) = 24068
diff --git a/textproc/py-paragrep/files/patch-setup.py b/textproc/py-paragrep/files/patch-setup.py
new file mode 100644
index 000000000000..6ba55d34ca08
--- /dev/null
+++ b/textproc/py-paragrep/files/patch-setup.py
@@ -0,0 +1,22 @@
+--- setup.py.orig 2010-03-28 18:26:24.000000000 +0800
++++ setup.py 2010-03-29 15:07:17.000000000 +0800
+@@ -9,8 +9,8 @@
+ import os
+ sys.path += [os.getcwd()]
+
+-import ez_setup
+-ez_setup.use_setuptools(download_delay=2)
++#import ez_setup
++#ez_setup.use_setuptools(download_delay=2)
+ from setuptools import setup, find_packages
+ import re
+ import imp
+@@ -54,7 +54,7 @@
+ author_email = info['__email__'],
+ entry_points = {'console_scripts' : 'paragrep=paragrep:main'},
+ install_requires = ['grizzled>=0.8.1', ],
+- data_files = [('man', ['man/paragrep.1'])],
++# data_files = [('man', ['man/paragrep.1'])],
+ classifiers = [
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
diff --git a/textproc/py-paragrep/pkg-descr b/textproc/py-paragrep/pkg-descr
new file mode 100644
index 000000000000..3f28718fa6bb
--- /dev/null
+++ b/textproc/py-paragrep/pkg-descr
@@ -0,0 +1,5 @@
+paragrep is a paragraph grep utility. It searches for a series of
+regular expressions in a text file (or several text files) and prints
+out the paragraphs containing those expressions.
+
+WWW: http://bmc.github.com/paragrep/
diff --git a/textproc/py-paragrep/pkg-plist b/textproc/py-paragrep/pkg-plist
new file mode 100644
index 000000000000..5736f3d5085e
--- /dev/null
+++ b/textproc/py-paragrep/pkg-plist
@@ -0,0 +1,17 @@
+bin/paragrep
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/ez_setup.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/ez_setup.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/ez_setup.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/paragrep/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/paragrep/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/paragrep/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/paragrep
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%