aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-07 11:54:43 +0800
committerswills <swills@FreeBSD.org>2011-08-07 11:54:43 +0800
commit9ee137ea722114661cfd3535530a28a977939e69 (patch)
tree067d96719e11afbde99d2aad41f6de66db9058cb
parent32e24f7ad18c29c46bcd21fe535db164f70f845b (diff)
downloadfreebsd-ports-gnome-9ee137ea722114661cfd3535530a28a977939e69.tar.gz
freebsd-ports-gnome-9ee137ea722114661cfd3535530a28a977939e69.tar.zst
freebsd-ports-gnome-9ee137ea722114661cfd3535530a28a977939e69.zip
- Make use of CPAN:USER macro
- Add LICENSE - Use versioned checks for (BUILD|RUN)_DEPENDS - Add installing examples output PR: ports/159567 Submitted by: Jase Thew <freebsd@beardz.net> (maintainer)
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
index a193d5d0e08a..a00a5fb57145 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
@@ -9,17 +9,19 @@ PORTNAME= POE-Component-IRC-Plugin-Blowfish
PORTVERSION= 0.01
CATEGORIES= irc perl5 devel
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PLU
PKGNAMEPREFIX= p5-
MAINTAINER= freebsd@beardz.net
COMMENT= A POE::Component::IRC plugin tthat provides blowfish encryption
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
- ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
- ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-POE>=0.37:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-IRC>=5.07:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-Crypt-Blowfish_PP>=1.12:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
PERL_CONFIGURE= yes
@@ -28,6 +30,7 @@ MAN3= POE::Component::IRC::Plugin::Blowfish.3
post-install:
.ifndef(NOPORTEXAMPLES)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif