aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-04-07 12:03:10 +0800
committerclsung <clsung@FreeBSD.org>2007-04-07 12:03:10 +0800
commit9fdb23916cf4753043d92c3d8161ba136af732ea (patch)
tree3f891c0f62fa840b681f98553a5d6591c11c4c1a
parent820a1e6f10bfcc8678209623dc511450e1f4da0a (diff)
downloadfreebsd-ports-gnome-9fdb23916cf4753043d92c3d8161ba136af732ea.tar.gz
freebsd-ports-gnome-9fdb23916cf4753043d92c3d8161ba136af732ea.tar.zst
freebsd-ports-gnome-9fdb23916cf4753043d92c3d8161ba136af732ea.zip
This module will provide a coherent API to bring together
the various JSON modules currently on CPAN. This module will allow you to code to any JSON API and have it work regardless of which JSON module is actually installed. WWW: http://search.cpan.org/dist/JSON-Any/
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-JSON-Any/Makefile21
-rw-r--r--converters/p5-JSON-Any/distinfo3
-rw-r--r--converters/p5-JSON-Any/pkg-descr6
-rw-r--r--converters/p5-JSON-Any/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 6f89d8982edc..02a2b706c73a 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -57,6 +57,7 @@
SUBDIR += p5-Encode-JIS2K
SUBDIR += p5-Encode-compat
SUBDIR += p5-JSON
+ SUBDIR += p5-JSON-Any
SUBDIR += p5-JSON-DWIW
SUBDIR += p5-JSON-XS
SUBDIR += p5-MIME-Base32
diff --git a/converters/p5-JSON-Any/Makefile b/converters/p5-JSON-Any/Makefile
new file mode 100644
index 000000000000..54ea61c3c700
--- /dev/null
+++ b/converters/p5-JSON-Any/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: JSON-Any
+# Date created: 7 Apr 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-Any
+PORTVERSION= 1.03
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CT/CTHOM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl Wrapper Class for the various JSON classes
+
+PERL_CONFIGURE= yes
+MAN3= JSON::Any.3
+
+.include <bsd.port.mk>
diff --git a/converters/p5-JSON-Any/distinfo b/converters/p5-JSON-Any/distinfo
new file mode 100644
index 000000000000..582ae6857f05
--- /dev/null
+++ b/converters/p5-JSON-Any/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-Any-1.03.tar.gz) = f9c48f6fad31d03867cba531e2e9d93f
+SHA256 (JSON-Any-1.03.tar.gz) = 99647f6815b4ffdd6d755e730dea571d3d5a7274bac97a7d26ab5977be3c71f9
+SIZE (JSON-Any-1.03.tar.gz) = 4700
diff --git a/converters/p5-JSON-Any/pkg-descr b/converters/p5-JSON-Any/pkg-descr
new file mode 100644
index 000000000000..173ca7754bce
--- /dev/null
+++ b/converters/p5-JSON-Any/pkg-descr
@@ -0,0 +1,6 @@
+This module will provide a coherent API to bring together
+the various JSON modules currently on CPAN. This module will
+allow you to code to any JSON API and have it work regardless
+of which JSON module is actually installed.
+
+WWW: http://search.cpan.org/dist/JSON-Any/
diff --git a/converters/p5-JSON-Any/pkg-plist b/converters/p5-JSON-Any/pkg-plist
new file mode 100644
index 000000000000..004fd146018a
--- /dev/null
+++ b/converters/p5-JSON-Any/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/JSON/Any.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Any/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Any
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON
+@dirrm %%SITE_PERL%%/JSON/Any
+@dirrmtry %%SITE_PERL%%/JSON