aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-08-21 17:23:54 +0800
committerclsung <clsung@FreeBSD.org>2007-08-21 17:23:54 +0800
commita0d398310301908df96f2d34779fc23f1779ee36 (patch)
tree3fc39248166601136eb5e6dc02ea913073420c6b
parentf432e58087aa23fb5847438cc5048a8c4e817785 (diff)
downloadfreebsd-ports-gnome-a0d398310301908df96f2d34779fc23f1779ee36.tar.gz
freebsd-ports-gnome-a0d398310301908df96f2d34779fc23f1779ee36.tar.zst
freebsd-ports-gnome-a0d398310301908df96f2d34779fc23f1779ee36.zip
YASA is a simple implementation of Suffix Array for counting
frequency of given text/string. This module provides a Perl interface to YASA via REST. WWW: http://search.cpan.org/dist/Net-YASA/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Net-YASA/Makefile24
-rw-r--r--textproc/p5-Net-YASA/distinfo3
-rw-r--r--textproc/p5-Net-YASA/pkg-descr6
-rw-r--r--textproc/p5-Net-YASA/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 681699c725ed..4804caac5ac8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -417,6 +417,7 @@
SUBDIR += p5-MKDoc-XML
SUBDIR += p5-Makefile-Parser
SUBDIR += p5-MathML-Entities
+ SUBDIR += p5-Net-YASA
SUBDIR += p5-NetAddr-IP-Find
SUBDIR += p5-Number-Format
SUBDIR += p5-Number-Spell
diff --git a/textproc/p5-Net-YASA/Makefile b/textproc/p5-Net-YASA/Makefile
new file mode 100644
index 000000000000..6bcfcbfafd1a
--- /dev/null
+++ b/textproc/p5-Net-YASA/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: textproc/p5-Net-YASA
+# Date created: 21 Aug 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-YASA
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl interface to YASA (Yet Another Suffix Array)
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Net::YASA.3 Net::YASA::ConfigData.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Net-YASA/distinfo b/textproc/p5-Net-YASA/distinfo
new file mode 100644
index 000000000000..bd9740ab82a9
--- /dev/null
+++ b/textproc/p5-Net-YASA/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-YASA-0.02.tar.gz) = 48ad68043cf0a7b6eada7cd28d1f0890
+SHA256 (Net-YASA-0.02.tar.gz) = a32bb9bc9995bf812e4a99825ddd44e537f4b526831328c7704028f696a9858b
+SIZE (Net-YASA-0.02.tar.gz) = 4007
diff --git a/textproc/p5-Net-YASA/pkg-descr b/textproc/p5-Net-YASA/pkg-descr
new file mode 100644
index 000000000000..7f875d1ae1c4
--- /dev/null
+++ b/textproc/p5-Net-YASA/pkg-descr
@@ -0,0 +1,6 @@
+YASA is a simple implementation of Suffix Array for counting
+frequency of given text/string.
+
+This module provides a Perl interface to YASA via REST.
+
+WWW: http://search.cpan.org/dist/Net-YASA/
diff --git a/textproc/p5-Net-YASA/pkg-plist b/textproc/p5-Net-YASA/pkg-plist
new file mode 100644
index 000000000000..e340ef5bc41e
--- /dev/null
+++ b/textproc/p5-Net-YASA/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Net/YASA.pm
+%%SITE_PERL%%/Net/YASA/ConfigData.pm
+@dirrmtry %%SITE_PERL%%/Net/YASA
+@dirrmtry %%SITE_PERL%%/Net