aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2004-05-07 19:54:55 +0800
committernetchild <netchild@FreeBSD.org>2004-05-07 19:54:55 +0800
commita3e8d45c1e43e49ef74e00b54034a1409c84034a (patch)
tree0ed1096641973e8c467f76c1bfa65a35fc12644b
parent1aeeb98ac5d2f7e00404ba845f793da934e9efe4 (diff)
downloadfreebsd-ports-gnome-a3e8d45c1e43e49ef74e00b54034a1409c84034a.tar.gz
freebsd-ports-gnome-a3e8d45c1e43e49ef74e00b54034a1409c84034a.tar.zst
freebsd-ports-gnome-a3e8d45c1e43e49ef74e00b54034a1409c84034a.zip
icc 8.0.066 now adds "-m elf_i386" in some circumstances. Remove this part
of the command line in the ld wrapper. Noticed by: Morten Rodal <morten@rodal.no>
-rw-r--r--lang/icc/Makefile1
-rw-r--r--lang/icc/files/ld.c4
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index ea9557e1e9bd..5a8df6113e98 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 8.0.066
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION:C/\.p.+$//}
diff --git a/lang/icc/files/ld.c b/lang/icc/files/ld.c
index 66420cebfeae..2f135697e1d5 100644
--- a/lang/icc/files/ld.c
+++ b/lang/icc/files/ld.c
@@ -184,7 +184,9 @@ main(int argc, char *argv[], char *envp[])
for (i = 0; i < argc; i++) {
if (ARGCMP(i, "-CPLUSPLUS") || ARGCMP(i, "-MT") ||
- ARGCMP(i, "-PIC"))
+ ARGCMP(i, "-PIC") ||
+ (ARGCMP(i, "-m") && i<argc-1 && ARGCMP(i+1, "elf_i386")) ||
+ (ARGCMP(i, "elf_i386") && i != 0 && ARGCMP(i-1, "-m")))
continue;
/* prepend "-melf_i386" to the commandline */