aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2013-02-06 21:09:28 +0800
committertobez <tobez@FreeBSD.org>2013-02-06 21:09:28 +0800
commita6491d5d1fd1c6b0d5d240497731968f5270c737 (patch)
treebf63f4e1ec232f5351a376a85c4146ad7cb0416a
parent6eed2bb80646b07065c27658e4ae4f2cfc37ec7d (diff)
downloadfreebsd-ports-gnome-a6491d5d1fd1c6b0d5d240497731968f5270c737.tar.gz
freebsd-ports-gnome-a6491d5d1fd1c6b0d5d240497731968f5270c737.tar.zst
freebsd-ports-gnome-a6491d5d1fd1c6b0d5d240497731968f5270c737.zip
Add devel/p5-Path-Tiny 0.004, a Perl module for working with
file paths.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Path-Tiny/Makefile23
-rw-r--r--devel/p5-Path-Tiny/distinfo2
-rw-r--r--devel/p5-Path-Tiny/pkg-descr5
-rw-r--r--devel/p5-Path-Tiny/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a991673f7e99..8cccb8d2dc06 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2461,6 +2461,7 @@
SUBDIR += p5-Path-Dispatcher
SUBDIR += p5-Path-Dispatcher-Declarative
SUBDIR += p5-Path-Resource
+ SUBDIR += p5-Path-Tiny
SUBDIR += p5-PathTools
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
diff --git a/devel/p5-Path-Tiny/Makefile b/devel/p5-Path-Tiny/Makefile
new file mode 100644
index 000000000000..de5120d52695
--- /dev/null
+++ b/devel/p5-Path-Tiny/Makefile
@@ -0,0 +1,23 @@
+# Created by: Anton Berezin <tobez@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Path-Tiny
+PORTVERSION= 0.004
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= File path utility
+
+BUILD_DEPENDS= p5-PathTools>=3.4000:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
+
+MAN3= Path::Tiny.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Path-Tiny/distinfo b/devel/p5-Path-Tiny/distinfo
new file mode 100644
index 000000000000..08205e072cc0
--- /dev/null
+++ b/devel/p5-Path-Tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Path-Tiny-0.004.tar.gz) = 0da8951d3b97cc5183b0432e8c69ab46ee9652ae6ed74621e75a9b46d1b38c68
+SIZE (Path-Tiny-0.004.tar.gz) = 27956
diff --git a/devel/p5-Path-Tiny/pkg-descr b/devel/p5-Path-Tiny/pkg-descr
new file mode 100644
index 000000000000..dede9c790c81
--- /dev/null
+++ b/devel/p5-Path-Tiny/pkg-descr
@@ -0,0 +1,5 @@
+This module attempts to provide a small, fast utility for working with
+file paths. It is friendlier to use than File::Spec and provides
+easy access to functions from several other core file handling modules.
+
+WWW: http://search.cpan.org/dist/Path-Tiny/
diff --git a/devel/p5-Path-Tiny/pkg-plist b/devel/p5-Path-Tiny/pkg-plist
new file mode 100644
index 000000000000..8f89be42110b
--- /dev/null
+++ b/devel/p5-Path-Tiny/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Path/Tiny.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Tiny/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path
+@dirrmtry %%SITE_PERL%%/Path