aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-09-10 02:47:42 +0800
committerknu <knu@FreeBSD.org>2002-09-10 02:47:42 +0800
commita702d4f445eb7d06ed958c82bb67f711b2559662 (patch)
tree608231700809c0b6c2acc0d248887c43692927af
parent67b07544c337de571c4fc9a323bf8083c16da3a5 (diff)
downloadfreebsd-ports-gnome-a702d4f445eb7d06ed958c82bb67f711b2559662.tar.gz
freebsd-ports-gnome-a702d4f445eb7d06ed958c82bb67f711b2559662.tar.zst
freebsd-ports-gnome-a702d4f445eb7d06ed958c82bb67f711b2559662.zip
Add gauche, a scheme script interpreter with multibyte character
handling.
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gauche/Makefile46
-rw-r--r--lang/gauche/distinfo1
-rw-r--r--lang/gauche/files/patch-doc-Makefile.in63
-rw-r--r--lang/gauche/files/patch-doc-gauche-refe.texi13
-rw-r--r--lang/gauche/files/patch-doc-gauche-refj.texi13
-rw-r--r--lang/gauche/pkg-comment1
-rw-r--r--lang/gauche/pkg-descr7
-rw-r--r--lang/gauche/pkg-plist186
9 files changed, 331 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 69c92f3ea373..2ba19d7d42be 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -46,6 +46,7 @@
SUBDIR += fesi
SUBDIR += forth
SUBDIR += fpc
+ SUBDIR += gauche
SUBDIR += gawk
SUBDIR += gcc27
SUBDIR += gcc28
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
new file mode 100644
index 000000000000..e234999d7fa1
--- /dev/null
+++ b/lang/gauche/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gauche
+# Date created: 9 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gauche
+PORTVERSION= 0.6.2
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Gauche-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= knu@FreeBSD.org
+
+# Choices are: "pthreads" and "no", but it seems that FreeBSD does not
+# yet fully support threads with Boehm GC.
+GAUCHE_THREADS?= no
+# Choices are: "utf-8", "euc-jp", "shift-jis" and "no"
+GAUCHE_ENCODING?= utf-8
+
+INFOSECTION= The Algorithmic Language Scheme
+
+MAN1= gosh.1 \
+ gauche-config.1
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-threads=${GAUCHE_THREADS} \
+ --enable-multibyte=${GAUCHE_ENCODING}
+INSTALL_TARGET= install-rpm
+PLIST_SUB= VERSION="${PORTVERSION}" \
+ TARGET="${CONFIGURE_TARGET}" \
+ INFOSECTION="${INFOSECTION}"
+
+post-install:
+ -${PREFIX}/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1/
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.info ${PREFIX}/info/
+.for info in gauche-refe.info gauche-refj.info
+ install-info --section="${INFOSECTION}" ${WRKSRC}/doc/${info} ${PREFIX}/info/dir
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/gauche/distinfo b/lang/gauche/distinfo
new file mode 100644
index 000000000000..bb5698158a44
--- /dev/null
+++ b/lang/gauche/distinfo
@@ -0,0 +1 @@
+MD5 (Gauche-0.6.2.tgz) = 2d0778497ecab8be68b3c1926432b3b3
diff --git a/lang/gauche/files/patch-doc-Makefile.in b/lang/gauche/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..1086a1715b14
--- /dev/null
+++ b/lang/gauche/files/patch-doc-Makefile.in
@@ -0,0 +1,63 @@
+--- doc/Makefile.in.orig Fri Jul 19 14:47:53 2002
++++ doc/Makefile.in Mon Sep 9 23:36:04 2002
+@@ -11,8 +11,8 @@
+ # make mandir=wherever
+ prefix = @prefix@
+ datadir = @datadir@
+-mandir = $(datadir)/man/man1
+-infodir = $(datadir)/info
++mandir = $(prefix)/man/man1
++infodir = $(prefix)/info
+
+ all: info
+
+@@ -22,8 +22,8 @@
+ $(INSTALL) -m 444 $$m $(mandir)/; \
+ done
+ if test ! -d $(infodir); then $(INSTALL) -d $(infodir); fi
+- if test -f gauche-refe.info.gz -o -f gauche-refj.info.gz; then \
+- for info in *.info*; do \
++ if test -f gauche-refe.info -o -f gauche-refj.info; then \
++ for info in *.info; do \
+ $(INSTALL) -m 444 $$info $(infodir)/; \
+ done; \
+ fi
+@@ -48,7 +48,7 @@
+
+ pdf : gauche-refe.pdf
+
+-info : gauche-refe.info.gz gauche-refj.info.gz
++info : gauche-refe.info gauche-refj.info
+
+ gauche-refe.html : gauche-refe.texi
+ texi2html -number gauche-refe.texi
+@@ -65,11 +65,9 @@
+ gauche-refe.texi : gauche-ref.texi extract
+ gosh ./extract -en -o gauche-refe.texi gauche-ref.texi
+
+-gauche-refe.info.gz : gauche-refe.texi
+- if test X$(MAKEINFO) != X -a X$(GZIP) != X; then \
+- $(MAKEINFO) --no-warn gauche-refe.texi; \
+- rm -rf gauche-refe.info*.gz; \
+- $(GZIP) gauche-refe.info gauche-refe.info-[0-9]*; \
++gauche-refe.info : gauche-refe.texi
++ if test X$(MAKEINFO) != X; then \
++ $(MAKEINFO) --no-split --no-warn gauche-refe.texi; \
+ fi
+
+ gauche-refj.html : gauche-refj.texi
+@@ -87,11 +85,9 @@
+ gauche-refj.texi : gauche-ref.texi extract
+ gosh ./extract -jp -o gauche-refj.texi gauche-ref.texi
+
+-gauche-refj.info.gz : gauche-refj.texi
+- if test X$(MAKEINFO) != X -a X$(GZIP) != X; then \
+- $(MAKEINFO) --no-warn gauche-refj.texi; \
+- rm -rf gauche-refj.info*.gz; \
+- $(GZIP) gauche-refj.info gauche-refj.info-[0-9]*; \
++gauche-refj.info : gauche-refj.texi
++ if test X$(MAKEINFO) != X; then \
++ $(MAKEINFO) --no-split --no-warn gauche-refj.texi; \
+ fi
+
+ clean:
diff --git a/lang/gauche/files/patch-doc-gauche-refe.texi b/lang/gauche/files/patch-doc-gauche-refe.texi
new file mode 100644
index 000000000000..071be8553da6
--- /dev/null
+++ b/lang/gauche/files/patch-doc-gauche-refe.texi
@@ -0,0 +1,13 @@
+--- doc/gauche-refe.texi.orig Tue Sep 3 09:36:37 2002
++++ doc/gauche-refe.texi Tue Sep 10 01:08:58 2002
+@@ -8,2 +8,10 @@
+
++@ifinfo
++@format
++START-INFO-DIR-ENTRY
++* Gauche-en: (gauche-refe). The Gauche Reference Manual [en]
++END-INFO-DIR-ENTRY
++@end format
++@end ifinfo
++
+ @c module and class index
diff --git a/lang/gauche/files/patch-doc-gauche-refj.texi b/lang/gauche/files/patch-doc-gauche-refj.texi
new file mode 100644
index 000000000000..494d7a5ff7da
--- /dev/null
+++ b/lang/gauche/files/patch-doc-gauche-refj.texi
@@ -0,0 +1,13 @@
+--- doc/gauche-refj.texi.orig Tue Sep 3 09:36:47 2002
++++ doc/gauche-refj.texi Tue Sep 10 01:08:59 2002
+@@ -8,2 +8,10 @@
+
++@ifinfo
++@format
++START-INFO-DIR-ENTRY
++* Gauche-ja: (gauche-refj). The Gauche Reference Manual [ja]
++END-INFO-DIR-ENTRY
++@end format
++@end ifinfo
++
+ @c module and class index
diff --git a/lang/gauche/pkg-comment b/lang/gauche/pkg-comment
new file mode 100644
index 000000000000..24fc0aca9896
--- /dev/null
+++ b/lang/gauche/pkg-comment
@@ -0,0 +1 @@
+Scheme script interpreter with multibyte character handling
diff --git a/lang/gauche/pkg-descr b/lang/gauche/pkg-descr
new file mode 100644
index 000000000000..34a6064bd7fe
--- /dev/null
+++ b/lang/gauche/pkg-descr
@@ -0,0 +1,7 @@
+Gauche is a Scheme interpreter conforming Revised^5 Report on
+Algorithmic Language Scheme. It is designed for rapid development
+of daily tools like system management and text processing.
+It can handle multibyte character strings natively.
+
+Author: Shiro Kawai <shiro@acm.org>
+WWW: http://www.shiro.dreamhost.com/scheme/gauche/index.html
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
new file mode 100644
index 000000000000..55a9f964b181
--- /dev/null
+++ b/lang/gauche/pkg-plist
@@ -0,0 +1,186 @@
+bin/gosh
+bin/gauche-config
+lib/gauche/%%VERSION%%/%%TARGET%%/auxsys.so
+lib/gauche/%%VERSION%%/%%TARGET%%/fcntl.so
+lib/gauche/%%VERSION%%/%%TARGET%%/gauche-config
+lib/gauche/%%VERSION%%/%%TARGET%%/gosh
+lib/gauche/%%VERSION%%/%%TARGET%%/libcharconv.so
+lib/gauche/%%VERSION%%/%%TARGET%%/libgauche.a
+lib/gauche/%%VERSION%%/%%TARGET%%/libgauche.so
+lib/gauche/%%VERSION%%/%%TARGET%%/libnet.so
+lib/gauche/%%VERSION%%/%%TARGET%%/libuvector.so
+lib/gauche/%%VERSION%%/%%TARGET%%/mt-random.so
+lib/gauche/%%VERSION%%/%%TARGET%%/ndbm.so
+lib/gauche/%%VERSION%%/%%TARGET%%/termios.so
+lib/gauche/%%VERSION%%/%%TARGET%%/threads.so
+lib/gauche/%%VERSION%%/include/gauche.h
+lib/gauche/%%VERSION%%/include/gauche/char_euc_jp.h
+lib/gauche/%%VERSION%%/include/gauche/char_none.h
+lib/gauche/%%VERSION%%/include/gauche/char_sjis.h
+lib/gauche/%%VERSION%%/include/gauche/char_utf_8.h
+lib/gauche/%%VERSION%%/include/gauche/class.h
+lib/gauche/%%VERSION%%/include/gauche/config.h
+lib/gauche/%%VERSION%%/include/gauche/exception.h
+lib/gauche/%%VERSION%%/include/gauche/extend.h
+lib/gauche/%%VERSION%%/include/gauche/fcntl.h
+lib/gauche/%%VERSION%%/include/gauche/net.h
+lib/gauche/%%VERSION%%/include/gauche/netconfig.h
+lib/gauche/%%VERSION%%/include/gauche/predef-syms.h
+lib/gauche/%%VERSION%%/include/gauche/pthread.h
+lib/gauche/%%VERSION%%/include/gauche/termconfig.h
+lib/gauche/%%VERSION%%/include/gauche/termios.h
+lib/gauche/%%VERSION%%/include/gauche/uthread.h
+lib/gauche/%%VERSION%%/include/gauche/uvector.h
+lib/gauche/%%VERSION%%/include/gauche/vm.h
+lib/gauche/%%VERSION%%/include/gauche/vminsn.h
+lib/gauche/%%VERSION%%/include/gc.h
+lib/gauche/%%VERSION%%/include/gc_pthread_redirects.h
+lib/gauche/site/%%VERSION%%/%%TARGET%%/example.so
+@dirrm lib/gauche/site/%%VERSION%%/%%TARGET%%
+@dirrm lib/gauche/site/%%VERSION%%
+@dirrm lib/gauche/site
+@dirrm lib/gauche/%%VERSION%%/include/gauche
+@dirrm lib/gauche/%%VERSION%%/include
+@dirrm lib/gauche/%%VERSION%%/%%TARGET%%
+@dirrm lib/gauche/%%VERSION%%
+@dirrm lib/gauche
+share/gauche/%%VERSION%%/aclocal.m4
+share/gauche/%%VERSION%%/lib/dbm.scm
+share/gauche/%%VERSION%%/lib/dbm/ndbm.scm
+share/gauche/%%VERSION%%/lib/file/filter.scm
+share/gauche/%%VERSION%%/lib/file/util.scm
+share/gauche/%%VERSION%%/lib/gauche-init.scm
+share/gauche/%%VERSION%%/lib/gauche/array.scm
+share/gauche/%%VERSION%%/lib/gauche/auxsys.scm
+share/gauche/%%VERSION%%/lib/gauche/charconv.scm
+share/gauche/%%VERSION%%/lib/gauche/collection.scm
+share/gauche/%%VERSION%%/lib/gauche/common-macros.scm
+share/gauche/%%VERSION%%/lib/gauche/defvalues.scm
+share/gauche/%%VERSION%%/lib/gauche/fcntl.scm
+share/gauche/%%VERSION%%/lib/gauche/interactive.scm
+share/gauche/%%VERSION%%/lib/gauche/interactive/info.scm
+share/gauche/%%VERSION%%/lib/gauche/interpolate.scm
+share/gauche/%%VERSION%%/lib/gauche/let-opt.scm
+share/gauche/%%VERSION%%/lib/gauche/logger.scm
+share/gauche/%%VERSION%%/lib/gauche/logical.scm
+share/gauche/%%VERSION%%/lib/gauche/macroutil.scm
+share/gauche/%%VERSION%%/lib/gauche/mop/instance-pool.scm
+share/gauche/%%VERSION%%/lib/gauche/net.scm
+share/gauche/%%VERSION%%/lib/gauche/numerical.scm
+share/gauche/%%VERSION%%/lib/gauche/object.scm
+share/gauche/%%VERSION%%/lib/gauche/parameter.scm
+share/gauche/%%VERSION%%/lib/gauche/parseopt.scm
+share/gauche/%%VERSION%%/lib/gauche/port.scm
+share/gauche/%%VERSION%%/lib/gauche/procedure.scm
+share/gauche/%%VERSION%%/lib/gauche/process.scm
+share/gauche/%%VERSION%%/lib/gauche/regexp.scm
+share/gauche/%%VERSION%%/lib/gauche/selector.scm
+share/gauche/%%VERSION%%/lib/gauche/sequence.scm
+share/gauche/%%VERSION%%/lib/gauche/serializer.scm
+share/gauche/%%VERSION%%/lib/gauche/serializer/aserializer.scm
+share/gauche/%%VERSION%%/lib/gauche/signal.scm
+share/gauche/%%VERSION%%/lib/gauche/singleton.scm
+share/gauche/%%VERSION%%/lib/gauche/termios.scm
+share/gauche/%%VERSION%%/lib/gauche/test.scm
+share/gauche/%%VERSION%%/lib/gauche/threads.scm
+share/gauche/%%VERSION%%/lib/gauche/uvector.scm
+share/gauche/%%VERSION%%/lib/gauche/validator.scm
+share/gauche/%%VERSION%%/lib/gauche/version.scm
+share/gauche/%%VERSION%%/lib/gauche/vm/debugger.scm
+share/gauche/%%VERSION%%/lib/gauche/vm/disasm.scm
+share/gauche/%%VERSION%%/lib/gauche/with.scm
+share/gauche/%%VERSION%%/lib/genstub
+share/gauche/%%VERSION%%/lib/japanize-euc.scm
+share/gauche/%%VERSION%%/lib/math/const.scm
+share/gauche/%%VERSION%%/lib/math/mt-random.scm
+share/gauche/%%VERSION%%/lib/port/jfilter.scm
+share/gauche/%%VERSION%%/lib/port/stk.scm
+share/gauche/%%VERSION%%/lib/rfc/822.scm
+share/gauche/%%VERSION%%/lib/rfc/base64.scm
+share/gauche/%%VERSION%%/lib/rfc/cookie.scm
+share/gauche/%%VERSION%%/lib/rfc/quoted-printable.scm
+share/gauche/%%VERSION%%/lib/rfc/uri.scm
+share/gauche/%%VERSION%%/lib/slib.scm
+share/gauche/%%VERSION%%/lib/srfi-0.scm
+share/gauche/%%VERSION%%/lib/srfi-1.scm
+share/gauche/%%VERSION%%/lib/srfi-1/cat.scm
+share/gauche/%%VERSION%%/lib/srfi-1/filter.scm
+share/gauche/%%VERSION%%/lib/srfi-1/finder.scm
+share/gauche/%%VERSION%%/lib/srfi-1/folder.scm
+share/gauche/%%VERSION%%/lib/srfi-1/generator.scm
+share/gauche/%%VERSION%%/lib/srfi-1/mapper.scm
+share/gauche/%%VERSION%%/lib/srfi-1/nary.scm
+share/gauche/%%VERSION%%/lib/srfi-1/nth.scm
+share/gauche/%%VERSION%%/lib/srfi-1/pred.scm
+share/gauche/%%VERSION%%/lib/srfi-1/selector.scm
+share/gauche/%%VERSION%%/lib/srfi-1/set.scm
+share/gauche/%%VERSION%%/lib/srfi-1/zipper.scm
+share/gauche/%%VERSION%%/lib/srfi-11.scm
+share/gauche/%%VERSION%%/lib/srfi-13.scm
+share/gauche/%%VERSION%%/lib/srfi-13/casemap.scm
+share/gauche/%%VERSION%%/lib/srfi-13/comparer.scm
+share/gauche/%%VERSION%%/lib/srfi-13/filter.scm
+share/gauche/%%VERSION%%/lib/srfi-13/folder.scm
+share/gauche/%%VERSION%%/lib/srfi-13/generator.scm
+share/gauche/%%VERSION%%/lib/srfi-13/hash.scm
+share/gauche/%%VERSION%%/lib/srfi-13/internal.scm
+share/gauche/%%VERSION%%/lib/srfi-13/kmp.scm
+share/gauche/%%VERSION%%/lib/srfi-13/misc.scm
+share/gauche/%%VERSION%%/lib/srfi-13/pred.scm
+share/gauche/%%VERSION%%/lib/srfi-13/prefix.scm
+share/gauche/%%VERSION%%/lib/srfi-13/revapp.scm
+share/gauche/%%VERSION%%/lib/srfi-13/rotator.scm
+share/gauche/%%VERSION%%/lib/srfi-13/searcher.scm
+share/gauche/%%VERSION%%/lib/srfi-13/selector.scm
+share/gauche/%%VERSION%%/lib/srfi-14.scm
+share/gauche/%%VERSION%%/lib/srfi-14/query.scm
+share/gauche/%%VERSION%%/lib/srfi-14/set.scm
+share/gauche/%%VERSION%%/lib/srfi-19.scm
+share/gauche/%%VERSION%%/lib/srfi-19/format.scm
+share/gauche/%%VERSION%%/lib/srfi-19/read-tai.scm
+share/gauche/%%VERSION%%/lib/srfi-2.scm
+share/gauche/%%VERSION%%/lib/srfi-26.scm
+share/gauche/%%VERSION%%/lib/srfi-27.scm
+share/gauche/%%VERSION%%/lib/srfi-4.scm
+share/gauche/%%VERSION%%/lib/srfi-9.scm
+share/gauche/%%VERSION%%/lib/text/csv.scm
+share/gauche/%%VERSION%%/lib/text/html-lite.scm
+share/gauche/%%VERSION%%/lib/text/info.scm
+share/gauche/%%VERSION%%/lib/text/parse.scm
+share/gauche/%%VERSION%%/lib/text/tr.scm
+share/gauche/%%VERSION%%/lib/text/tree.scm
+share/gauche/%%VERSION%%/lib/util/isomorph.scm
+share/gauche/%%VERSION%%/lib/util/queue.scm
+share/gauche/%%VERSION%%/lib/util/toposort.scm
+share/gauche/%%VERSION%%/lib/util/tree.scm
+share/gauche/%%VERSION%%/lib/www/cgi.scm
+share/gauche/site/lib/example.scm
+@dirrm share/gauche/site/lib
+@dirrm share/gauche/site
+@dirrm share/gauche/%%VERSION%%/lib/www
+@dirrm share/gauche/%%VERSION%%/lib/util
+@dirrm share/gauche/%%VERSION%%/lib/text
+@dirrm share/gauche/%%VERSION%%/lib/srfi-19
+@dirrm share/gauche/%%VERSION%%/lib/srfi-14
+@dirrm share/gauche/%%VERSION%%/lib/srfi-13
+@dirrm share/gauche/%%VERSION%%/lib/srfi-1
+@dirrm share/gauche/%%VERSION%%/lib/rfc
+@dirrm share/gauche/%%VERSION%%/lib/port
+@dirrm share/gauche/%%VERSION%%/lib/math
+@dirrm share/gauche/%%VERSION%%/lib/gauche/vm
+@dirrm share/gauche/%%VERSION%%/lib/gauche/serializer
+@dirrm share/gauche/%%VERSION%%/lib/gauche/mop
+@dirrm share/gauche/%%VERSION%%/lib/gauche/interactive
+@dirrm share/gauche/%%VERSION%%/lib/gauche
+@dirrm share/gauche/%%VERSION%%/lib/file
+@dirrm share/gauche/%%VERSION%%/lib/dbm
+@dirrm share/gauche/%%VERSION%%/lib
+@dirrm share/gauche/%%VERSION%%
+@dirrm share/gauche
+@exec %D/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1 || true
+%%PORTDOCS%%@unexec install-info --delete --section="%%INFOSECTION%%" %D/info/info/gauche-refe.info %D/info/dir
+%%PORTDOCS%%@unexec install-info --delete --section="%%INFOSECTION%%" %D/info/info/gauche-refj.info %D/info/dir
+%%PORTDOCS%%info/gauche-refe.info
+%%PORTDOCS%%info/gauche-refj.info
+%%PORTDOCS%%@exec install-info --section="%%INFOSECTION%%" %D/info/info/gauche-refe.info %D/info/dir
+%%PORTDOCS%%@exec install-info --section="%%INFOSECTION%%" %D/info/info/gauche-refj.info %D/info/dir