aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2003-10-15 20:15:12 +0800
committerlev <lev@FreeBSD.org>2003-10-15 20:15:12 +0800
commita82882e2fdbf4470793de8863af635f09180e9a0 (patch)
treed8e6d50788833e666920d33a7c0e3ae571c81757
parentd051df0611191f6997445233af19d8c3bfe64521 (diff)
downloadfreebsd-ports-gnome-a82882e2fdbf4470793de8863af635f09180e9a0.tar.gz
freebsd-ports-gnome-a82882e2fdbf4470793de8863af635f09180e9a0.tar.zst
freebsd-ports-gnome-a82882e2fdbf4470793de8863af635f09180e9a0.zip
Install pkgconfig's `neon.pc' file into proper place (libdata)
PR: ports/57836, with small change.
-rw-r--r--www/neon/Makefile3
-rw-r--r--www/neon/pkg-plist4
-rw-r--r--www/neon26/Makefile3
-rw-r--r--www/neon26/pkg-plist4
-rw-r--r--www/neon28/Makefile3
-rw-r--r--www/neon28/pkg-plist4
-rw-r--r--www/neon29/Makefile3
-rw-r--r--www/neon29/pkg-plist4
8 files changed, 16 insertions, 12 deletions
diff --git a/www/neon/Makefile b/www/neon/Makefile
index b4a0c53b427d..34b1a10fd62b 100644
--- a/www/neon/Makefile
+++ b/www/neon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= neon
PORTVERSION= 0.24.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/neon/
@@ -21,13 +22,13 @@ INSTALLS_SHLIB= yes
USE_OPENSSL= yes
.endif
+USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl \
--enable-xml \
--enable-shared \
--with-expat \
--with-libs=${PREFIX}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_destroy.3 ne_addr_error.3 \
diff --git a/www/neon/pkg-plist b/www/neon/pkg-plist
index cd2645af517f..3f6ca50c1dd6 100644
--- a/www/neon/pkg-plist
+++ b/www/neon/pkg-plist
@@ -24,7 +24,7 @@ include/neon/ne_xml.h
lib/libneon.so.24
lib/libneon.so
lib/libneon.a
-lib/pkgconfig/neon.pc
+libdata/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/html/apas01.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas02.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas03.html
@@ -80,5 +80,5 @@ lib/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/using-neon.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rmdir %D/lib/pkgconfig > /dev/null 2>&1 || true
+@unexec rmdir %D/libdata/pkgconfig > /dev/null 2>&1 || true
@dirrm include/neon
diff --git a/www/neon26/Makefile b/www/neon26/Makefile
index b4a0c53b427d..34b1a10fd62b 100644
--- a/www/neon26/Makefile
+++ b/www/neon26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= neon
PORTVERSION= 0.24.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/neon/
@@ -21,13 +22,13 @@ INSTALLS_SHLIB= yes
USE_OPENSSL= yes
.endif
+USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl \
--enable-xml \
--enable-shared \
--with-expat \
--with-libs=${PREFIX}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_destroy.3 ne_addr_error.3 \
diff --git a/www/neon26/pkg-plist b/www/neon26/pkg-plist
index cd2645af517f..3f6ca50c1dd6 100644
--- a/www/neon26/pkg-plist
+++ b/www/neon26/pkg-plist
@@ -24,7 +24,7 @@ include/neon/ne_xml.h
lib/libneon.so.24
lib/libneon.so
lib/libneon.a
-lib/pkgconfig/neon.pc
+libdata/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/html/apas01.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas02.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas03.html
@@ -80,5 +80,5 @@ lib/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/using-neon.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rmdir %D/lib/pkgconfig > /dev/null 2>&1 || true
+@unexec rmdir %D/libdata/pkgconfig > /dev/null 2>&1 || true
@dirrm include/neon
diff --git a/www/neon28/Makefile b/www/neon28/Makefile
index b4a0c53b427d..34b1a10fd62b 100644
--- a/www/neon28/Makefile
+++ b/www/neon28/Makefile
@@ -7,6 +7,7 @@
PORTNAME= neon
PORTVERSION= 0.24.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/neon/
@@ -21,13 +22,13 @@ INSTALLS_SHLIB= yes
USE_OPENSSL= yes
.endif
+USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl \
--enable-xml \
--enable-shared \
--with-expat \
--with-libs=${PREFIX}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_destroy.3 ne_addr_error.3 \
diff --git a/www/neon28/pkg-plist b/www/neon28/pkg-plist
index cd2645af517f..3f6ca50c1dd6 100644
--- a/www/neon28/pkg-plist
+++ b/www/neon28/pkg-plist
@@ -24,7 +24,7 @@ include/neon/ne_xml.h
lib/libneon.so.24
lib/libneon.so
lib/libneon.a
-lib/pkgconfig/neon.pc
+libdata/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/html/apas01.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas02.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas03.html
@@ -80,5 +80,5 @@ lib/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/using-neon.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rmdir %D/lib/pkgconfig > /dev/null 2>&1 || true
+@unexec rmdir %D/libdata/pkgconfig > /dev/null 2>&1 || true
@dirrm include/neon
diff --git a/www/neon29/Makefile b/www/neon29/Makefile
index b4a0c53b427d..34b1a10fd62b 100644
--- a/www/neon29/Makefile
+++ b/www/neon29/Makefile
@@ -7,6 +7,7 @@
PORTNAME= neon
PORTVERSION= 0.24.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/neon/
@@ -21,13 +22,13 @@ INSTALLS_SHLIB= yes
USE_OPENSSL= yes
.endif
+USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl \
--enable-xml \
--enable-shared \
--with-expat \
--with-libs=${PREFIX}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_destroy.3 ne_addr_error.3 \
diff --git a/www/neon29/pkg-plist b/www/neon29/pkg-plist
index cd2645af517f..3f6ca50c1dd6 100644
--- a/www/neon29/pkg-plist
+++ b/www/neon29/pkg-plist
@@ -24,7 +24,7 @@ include/neon/ne_xml.h
lib/libneon.so.24
lib/libneon.so
lib/libneon.a
-lib/pkgconfig/neon.pc
+libdata/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/html/apas01.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas02.html
%%PORTDOCS%%%%DOCSDIR%%/html/apas03.html
@@ -80,5 +80,5 @@ lib/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/using-neon.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rmdir %D/lib/pkgconfig > /dev/null 2>&1 || true
+@unexec rmdir %D/libdata/pkgconfig > /dev/null 2>&1 || true
@dirrm include/neon