aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-02 14:20:09 +0800
committerbapt <bapt@FreeBSD.org>2013-09-02 14:20:09 +0800
commita9ecc5ea2761aabc014ae9ae2e13eab7c7849da5 (patch)
tree26ac7c916579a07ef93f69c8c8d8e397604d14aa
parentf4176bb1801acde1e76e5b5987ed06f1b77c9b29 (diff)
downloadfreebsd-ports-gnome-a9ecc5ea2761aabc014ae9ae2e13eab7c7849da5.tar.gz
freebsd-ports-gnome-a9ecc5ea2761aabc014ae9ae2e13eab7c7849da5.tar.zst
freebsd-ports-gnome-a9ecc5ea2761aabc014ae9ae2e13eab7c7849da5.zip
Add an expicit dependency on pkgconf
-rw-r--r--astro/nova/Makefile1
-rw-r--r--devel/xmltooling/Makefile2
-rw-r--r--games/asc/Makefile2
-rw-r--r--multimedia/schroedinger/Makefile1
-rw-r--r--security/opensaml2/Makefile2
-rw-r--r--x11-toolkits/gtkmm20/Makefile4
-rw-r--r--x11-toolkits/paragui-devel/Makefile1
7 files changed, 8 insertions, 5 deletions
diff --git a/astro/nova/Makefile b/astro/nova/Makefile
index acc79a155237..731a0e711c56 100644
--- a/astro/nova/Makefile
+++ b/astro/nova/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
nova:${PORTSDIR}/astro/libnova
RUN_DEPENDS= ${LOCALBASE}/share/nova/catalogs/sky2000.ncd:${PORTSDIR}/astro/sky2000
+USES= pkgconfig
USE_AUTOTOOLS= libtool
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/xmltooling/Makefile b/devel/xmltooling/Makefile
index 70a2b78c3cb2..a5d72781f07f 100644
--- a/devel/xmltooling/Makefile
+++ b/devel/xmltooling/Makefile
@@ -19,8 +19,8 @@ BUILD_DEPENDS= boost-libs>=0:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-log4shib=${LOCALBASE} --with-openssl=${OPENSSLBASE} --with-curl=${LOCALBASE} --disable-doxygen-doc
+USES= gmake pkgconfig
USE_GCC= any
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 93e48bf51f3b..cee2dc128cbb 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= MUSIC XVID
MUSIC_DESC= Install extra music files
-USES= perl5
+USES= perl5 pkgconfig
USE_BZIP2= yes
USE_SDL= image mixer sound sdl
USE_WX= 2.4+
diff --git a/multimedia/schroedinger/Makefile b/multimedia/schroedinger/Makefile
index 0ab521da4980..45f7ef9c6b59 100644
--- a/multimedia/schroedinger/Makefile
+++ b/multimedia/schroedinger/Makefile
@@ -19,6 +19,7 @@ LICENSE_FILE_MPL= ${WRKSRC}/COPYING.MPL
LIB_DEPENDS= orc-0.4:${PORTSDIR}/devel/orc
BUILD_DEPENDS= orc>=0.4.16:${PORTSDIR}/devel/orc
+USES= pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/opensaml2/Makefile b/security/opensaml2/Makefile
index b932bc711551..682b0798a2cc 100644
--- a/security/opensaml2/Makefile
+++ b/security/opensaml2/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= boost-libs>=0:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-log4shib=${LOCALBASE} --with-openssl=${OPENSSLBASE} \
--with-xmltooling=${LOCALBASE} --disable-doxygen-doc
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_LDCONFIG= yes
post-patch:
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index bd4a384b0c8c..6be737e30473 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -21,10 +21,10 @@ LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
+USES= pathfix gmake pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack lthack gtk20
+USE_GNOME= lthack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--with-sigc-prefix=${LOCALBASE}
diff --git a/x11-toolkits/paragui-devel/Makefile b/x11-toolkits/paragui-devel/Makefile
index 3efe1741c48d..be56515f1874 100644
--- a/x11-toolkits/paragui-devel/Makefile
+++ b/x11-toolkits/paragui-devel/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
CONFLICTS= paragui-[0-9]*
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_SDL= sdl image ttf
LIBTOOLFLAGS= --disable-ltlibs --release-ignore