aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-04-17 06:34:11 +0800
committermakc <makc@FreeBSD.org>2012-04-17 06:34:11 +0800
commitaa1923aba3eb008ec5717227e13ef932791cae01 (patch)
tree50a688af2a771ab98c4e11771814d018b335451c
parent45894d72194d6cd252b8ab18b6ce39f1f0550cbe (diff)
downloadfreebsd-ports-gnome-aa1923aba3eb008ec5717227e13ef932791cae01.tar.gz
freebsd-ports-gnome-aa1923aba3eb008ec5717227e13ef932791cae01.tar.zst
freebsd-ports-gnome-aa1923aba3eb008ec5717227e13ef932791cae01.zip
Fix build with upcoming Qt 4.8
-rw-r--r--math/qtiplot/Makefile1
-rw-r--r--math/qtiplot/files/build.conf2
-rw-r--r--math/qtiplot/files/patch-3rdparty__qwtplot3d__include__qwt3d_openglhelper.h10
-rw-r--r--math/qtiplot/files/patch-qtiplot__src__plot3D__Cone3D.cpp10
-rw-r--r--math/qwtplot3d-qt4/Makefile1
-rw-r--r--math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h10
-rw-r--r--math/qwtplot3d-qt4/files/patch-qwtplot3d.pro14
7 files changed, 44 insertions, 4 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 4720e0940a45..c146e496eed3 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -24,6 +24,7 @@ USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui opengl svg qt3support network assistantclient \
moc_build qmake_build rcc_build
+USE_GL= glu
HAS_CONFIGURE= yes
QMAKE_ARGS+= -recursive PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
PYTHON_CMD=${PYTHON_CMD}
diff --git a/math/qtiplot/files/build.conf b/math/qtiplot/files/build.conf
index 526c23e3b00b..2fec427440b3 100644
--- a/math/qtiplot/files/build.conf
+++ b/math/qtiplot/files/build.conf
@@ -3,7 +3,7 @@ isEmpty( QTI_ROOT ) {
}
SYS_INCLUDEPATH = $$LOCALBASE/include
-SYS_LIBS = -L$$LOCALBASE/lib
+SYS_LIBS = -L$$LOCALBASE/lib -lGLU
MUPARSER_INCLUDEPATH =
MUPARSER_LIBS = -lmuparser
diff --git a/math/qtiplot/files/patch-3rdparty__qwtplot3d__include__qwt3d_openglhelper.h b/math/qtiplot/files/patch-3rdparty__qwtplot3d__include__qwt3d_openglhelper.h
new file mode 100644
index 000000000000..32d586863596
--- /dev/null
+++ b/math/qtiplot/files/patch-3rdparty__qwtplot3d__include__qwt3d_openglhelper.h
@@ -0,0 +1,10 @@
+--- ./3rdparty/qwtplot3d/include/qwt3d_openglhelper.h.orig 2011-08-24 10:25:09.000000000 +0000
++++ ./3rdparty/qwtplot3d/include/qwt3d_openglhelper.h 2012-04-16 20:17:06.461052631 +0000
+@@ -6,6 +6,7 @@
+ #include <qgl.h>
+ #else
+ #include <QtOpenGL/qgl.h>
++#include <GL/glu.h>
+ #endif
+
+ namespace Qwt3D
diff --git a/math/qtiplot/files/patch-qtiplot__src__plot3D__Cone3D.cpp b/math/qtiplot/files/patch-qtiplot__src__plot3D__Cone3D.cpp
new file mode 100644
index 000000000000..daaf3f4404a1
--- /dev/null
+++ b/math/qtiplot/files/patch-qtiplot__src__plot3D__Cone3D.cpp
@@ -0,0 +1,10 @@
+--- ./qtiplot/src/plot3D/Cone3D.cpp.orig 2010-09-27 07:12:48.000000000 +0000
++++ ./qtiplot/src/plot3D/Cone3D.cpp 2012-04-16 21:30:38.879058155 +0000
+@@ -31,6 +31,7 @@
+ #include "qwt3d_plot.h"
+ #include <qwt3d_curve.h>
+ #include "Cone3D.h"
++#include "GL/glu.h"
+
+ using namespace Qwt3D;
+
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index 7e3bf0821f14..5cef16ebdbf3 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -18,6 +18,7 @@ COMMENT= 3D plotting widgets for scientific data and math expressions
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build qmake_build opengl
+USE_GL= glu
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
USE_DOS2UNIX= yes
diff --git a/math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h b/math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h
new file mode 100644
index 000000000000..d24e1eca0ac4
--- /dev/null
+++ b/math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h
@@ -0,0 +1,10 @@
+--- ./include/qwt3d_openglhelper.h.orig 2012-04-16 21:57:23.639051666 +0000
++++ ./include/qwt3d_openglhelper.h 2012-04-16 21:57:23.713053060 +0000
+@@ -6,6 +6,7 @@
+ #include <qgl.h>
+ #else
+ #include <QtOpenGL/qgl.h>
++#include <GL/glu.h>
+ #endif
+
+ namespace Qwt3D
diff --git a/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro b/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
index e2ef214a117b..6c363a30330c 100644
--- a/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
+++ b/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
@@ -1,5 +1,5 @@
---- ./qwtplot3d.pro.orig Tue Jun 26 18:34:05 2007
-+++ ./qwtplot3d.pro Tue Jun 26 18:34:57 2007
+--- ./qwtplot3d.pro.orig 2012-04-16 21:57:23.562053805 +0000
++++ ./qwtplot3d.pro 2012-04-16 21:58:00.311051941 +0000
@@ -1,9 +1,9 @@
# pro file for building the makefile for qwtplot3d
#
@@ -12,7 +12,15 @@
MOC_DIR = tmp
OBJECTS_DIR = tmp
INCLUDEPATH = include
-@@ -21,7 +21,7 @@
+@@ -11,6 +11,7 @@
+ DESTDIR = lib
+ #DESTDIR = ../../../lib
+ QT += opengl
++unix:LIBS += -lGLU
+
+ win32:TEMPLATE = vclib
+ win32:CONFIG += dll exceptions
+@@ -21,7 +22,7 @@
win32:CONFIG -= zlib
linux-g++:TMAKE_CXXFLAGS += -fno-exceptions