aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbz <sbz@FreeBSD.org>2014-06-15 22:48:40 +0800
committersbz <sbz@FreeBSD.org>2014-06-15 22:48:40 +0800
commitabe6fce73535fdbe724ea933a38d64b29c3778e1 (patch)
treef67648894112c30a4045d812848d5bdc93869faa
parent5454d5ffad0c50f56740ab91396c90bfbc2f36e6 (diff)
downloadfreebsd-ports-gnome-abe6fce73535fdbe724ea933a38d64b29c3778e1.tar.gz
freebsd-ports-gnome-abe6fce73535fdbe724ea933a38d64b29c3778e1.tar.zst
freebsd-ports-gnome-abe6fce73535fdbe724ea933a38d64b29c3778e1.zip
- Support STAGEDIR
-rw-r--r--security/sinfp/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/sinfp/Makefile b/security/sinfp/Makefile
index e5e8fe2507eb..00884ff22874 100644
--- a/security/sinfp/Makefile
+++ b/security/sinfp/Makefile
@@ -7,6 +7,8 @@ PORTREVISION= ${DBDATE}
MAINTAINER= sbz@FreeBSD.org
COMMENT= Full operating system stack fingerprinting suite
+LICENSE= ART10
+
BUILD_DEPENDS= p5-Net-SinFP>=2.02:${PORTSDIR}/security/p5-Net-SinFP
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -18,17 +20,19 @@ NO_BUILD= yes
MASTERDIR= ${.CURDIR}/../p5-Net-SinFP
DBDATE= 20110125
-NO_STAGE= yes
+USES= shebangfix
+SHEBANG_FILES= bin/${PORTNAME}.pl
+
post-patch:
@${REINPLACE_CMD} -e 's!$$Bin/../db/!${DATADIR}/!' ${WRKSRC}/bin/${PORTNAME}.pl
do-install:
- @${INSTALL} -d ${DATADIR}/
- @${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL} -d ${STAGEDIR}${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.ifdef DBDATE
- @${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}-${DBDATE}.db ${DATADIR}/${PORTNAME}.db
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}-${DBDATE}.db ${STAGEDIR}${DATADIR}/${PORTNAME}.db
.else
- @${INSTALL_DATA} ${WRKSRC}/bin/${PORTNAME}.db ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/bin/${PORTNAME}.db ${STAGEDIR}${DATADIR}/
.endif
.include "${MASTERDIR}/Makefile"