aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-07-22 12:20:46 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-07-22 12:20:46 +0800
commitadc3e16ddb0c620afc94c188d6b446ed58a889b1 (patch)
tree03710aef7335030ed20da86699603a985f1928d4
parent0a6afd80de67db73ccb3b88364b6d0a6adc70960 (diff)
downloadfreebsd-ports-gnome-adc3e16ddb0c620afc94c188d6b446ed58a889b1.tar.gz
freebsd-ports-gnome-adc3e16ddb0c620afc94c188d6b446ed58a889b1.tar.zst
freebsd-ports-gnome-adc3e16ddb0c620afc94c188d6b446ed58a889b1.zip
Update to version 1.10.1
PR: 12702 Submitted by: Don Croyle <croyle@gelemna.ft-wayne.in.us>, maintainer
-rw-r--r--devel/astyle/Makefile21
-rw-r--r--devel/astyle/distinfo2
-rw-r--r--devel/astyle/files/patch-aa26
3 files changed, 21 insertions, 28 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index de06cfc10efa..0f2ae5ca0d17 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -1,25 +1,30 @@
# New ports collection makefile for: astyle
-# Version required: 1.6.0
+# Version required: 1.10.1
# Date created: 31 Jan 1999
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/04/03 01:26:17 steve Exp $
#
-DISTNAME= astyle_1.6.0
-PKGNAME= astyle-1.6.0
+DISTNAME= astyle_1.10.1_src
+PKGNAME= astyle-1.10.1
CATEGORIES= devel textproc
-MASTER_SITES= http://www.bigfoot.com/~davidsont/astyle/stable/src/ \
+MASTER_SITES= http://gene.md.huji.ac.il/~tald/astyle/stable/src/ \
http://www.infonex.com/~dacroyle/freebsd/
EXTRACT_SUFX= .tgz
MAINTAINER= croyle@gelemna.ft-wayne.in.us
-BUILD_DEPENDS= eg++:${PORTSDIR}/lang/egcs
-
-WRKSRC= ${WRKDIR}/astyle-src
+WRKSRC= ${WRKDIR}/astyle_1.10.1
ALL_TARGET= astyle
+post-extract:
+ perl -pi -e 's/\r//' ${WRKSRC}/*
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
+ ${CP} -p ${FILESDIR}/Makefile ${WRKSRC}/
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/astyle ${PREFIX}/bin/
diff --git a/devel/astyle/distinfo b/devel/astyle/distinfo
index a8fed199e891..1615bbc1c191 100644
--- a/devel/astyle/distinfo
+++ b/devel/astyle/distinfo
@@ -1 +1 @@
-MD5 (astyle_1.6.0.tgz) = e42fee292faf73e0277e40dc01f81a0e
+MD5 (astyle_1.10.1_src.tgz) = f682d3ce6ba0611384a5319816826607
diff --git a/devel/astyle/files/patch-aa b/devel/astyle/files/patch-aa
index 6b6316e5badb..a860747604f8 100644
--- a/devel/astyle/files/patch-aa
+++ b/devel/astyle/files/patch-aa
@@ -1,19 +1,7 @@
---- Makefile.orig Sun Jan 3 11:43:25 1999
-+++ Makefile Sun Jan 31 22:34:12 1999
-@@ -1,13 +1,13 @@
- # "Artistic Style" Makefile
-
--CPPFLAGS = -O2 -W
-+CPPFLAGS ?= -O2 -W
- OBJS = ASResource.o ASBeautifier.o ASFormatter.o astyle_main.o
-
- astyle: $(OBJS)
-- g++ $(CPPFLAGS) -o astyle $(OBJS)
-+ eg++ $(CPPFLAGS) -o astyle $(OBJS)
-
- .cpp.o:
-- g++ $(CPPFLAGS) -c $<
-+ eg++ $(CPPFLAGS) -c $<
- .SUFFIXES: .cpp .c .o
-
- clean:
+--- compiler_defines.h.orig Thu Mar 18 15:39:49 1999
++++ compiler_defines.h Sun Apr 11 10:04:35 1999
+@@ -29,3 +29,3 @@
+ * comment out the line below if your compiler does NOT understand NAMESPACES
+- */
+ #define USES_NAMESPACE
++ */