aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2007-12-29 06:11:54 +0800
committerbrooks <brooks@FreeBSD.org>2007-12-29 06:11:54 +0800
commitae071e1d51fac612609800f91a866e4470406b56 (patch)
treeb9e8ec8b590ebfd2fc3dda689ecc3cd872df8a77
parent2889ddda1ee8429e5e7ba8e5d097cb57667be636 (diff)
downloadfreebsd-ports-gnome-ae071e1d51fac612609800f91a866e4470406b56.tar.gz
freebsd-ports-gnome-ae071e1d51fac612609800f91a866e4470406b56.tar.zst
freebsd-ports-gnome-ae071e1d51fac612609800f91a866e4470406b56.zip
When call tzset() before openlog so we log in local time instead of UTC.
This matches the behavior of /usr/libexec/tftpd. Submitted by: Hiroshi Fujishima <hirobo at tonteki dot org> PR: ports/116455
-rw-r--r--ftp/tftp-hpa/Makefile1
-rw-r--r--ftp/tftp-hpa/files/patch-tftpd_tftpd.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/ftp/tftp-hpa/Makefile b/ftp/tftp-hpa/Makefile
index 701875c9d78b..25d3430c9696 100644
--- a/ftp/tftp-hpa/Makefile
+++ b/ftp/tftp-hpa/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tftp-hpa
PORTVERSION= 0.48
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.kernel.org/pub/software/network/tftp/
diff --git a/ftp/tftp-hpa/files/patch-tftpd_tftpd.c b/ftp/tftp-hpa/files/patch-tftpd_tftpd.c
new file mode 100644
index 000000000000..bf0cbf4218c4
--- /dev/null
+++ b/ftp/tftp-hpa/files/patch-tftpd_tftpd.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- tftpd/tftpd.c.orig
++++ tftpd/tftpd.c
+@@ -302,6 +302,9 @@
+
+ p = strrchr(argv[0], '/');
+ __progname = (p && p[1]) ? p+1 : argv[0];
++
++ /* syslog in localtime */
++ tzset();
+
+ openlog(__progname, LOG_PID|LOG_NDELAY, LOG_DAEMON);
+