aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-03-06 13:11:59 +0800
committerfjoe <fjoe@FreeBSD.org>2010-03-06 13:11:59 +0800
commitae61830d26db1e20d752a3c97ea20163baafc57d (patch)
tree1ce3e3f3f5ca3e5efdea6072ffa75b199d1f0afb
parent26a50e5c5b3d3e9428fb92f4a8916ace334ab658 (diff)
downloadfreebsd-ports-gnome-ae61830d26db1e20d752a3c97ea20163baafc57d.tar.gz
freebsd-ports-gnome-ae61830d26db1e20d752a3c97ea20163baafc57d.tar.zst
freebsd-ports-gnome-ae61830d26db1e20d752a3c97ea20163baafc57d.zip
Add ${LOCALBASE}/lib/dahdi to the KLD search path, so that autoloading
of echo cancellation modules or Octasic firmware modules works as expected. Feature safe: yes
-rw-r--r--misc/dahdi-kmod/Makefile2
-rw-r--r--misc/dahdi-kmod/files/dahdi.in3
-rw-r--r--misc/dahdi/Makefile2
-rw-r--r--misc/dahdi/files/dahdi.in3
4 files changed, 6 insertions, 4 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index bde17b751bb6..1179a73b8765 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
diff --git a/misc/dahdi-kmod/files/dahdi.in b/misc/dahdi-kmod/files/dahdi.in
index 15f6d43e741c..7bbcece0f891 100644
--- a/misc/dahdi-kmod/files/dahdi.in
+++ b/misc/dahdi-kmod/files/dahdi.in
@@ -39,8 +39,9 @@ dahdi_start()
{
echo -n " ${name}"
+ kldconfig -mf ${kmod_dir}
for m in ${dahdi_modules}; do
- kldload ${kmod_dir}/$m.ko || exit 1
+ kldload $m || exit 1
done
%%PREFIX%%/sbin/dahdi_cfg
}
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index bde17b751bb6..1179a73b8765 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
diff --git a/misc/dahdi/files/dahdi.in b/misc/dahdi/files/dahdi.in
index 15f6d43e741c..7bbcece0f891 100644
--- a/misc/dahdi/files/dahdi.in
+++ b/misc/dahdi/files/dahdi.in
@@ -39,8 +39,9 @@ dahdi_start()
{
echo -n " ${name}"
+ kldconfig -mf ${kmod_dir}
for m in ${dahdi_modules}; do
- kldload ${kmod_dir}/$m.ko || exit 1
+ kldload $m || exit 1
done
%%PREFIX%%/sbin/dahdi_cfg
}