aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2008-01-07 02:00:46 +0800
committermi <mi@FreeBSD.org>2008-01-07 02:00:46 +0800
commitaeba9642341943f0497f9049d435219eda37823f (patch)
tree43dcfb05415785d43246f6bcb1187a44c4a20bf4
parent5122b9f5afce199882950eb4220bb4365e07bc74 (diff)
downloadfreebsd-ports-gnome-aeba9642341943f0497f9049d435219eda37823f.tar.gz
freebsd-ports-gnome-aeba9642341943f0497f9049d435219eda37823f.tar.zst
freebsd-ports-gnome-aeba9642341943f0497f9049d435219eda37823f.zip
Patch the vendor's configure to properly detect amd64 (rather than
x86_64). This should unbreak the port for amd64 on all releases. Also affects: PR: ports/117077 Approved by: maintainer (Rene Ladan) Approved by: last committer (lwhsu)
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile2
-rw-r--r--astro/boinc-setiathome-enhanced/files/patch-amd649
2 files changed, 10 insertions, 1 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index fdf6598b704c..56c051ed7ea4 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -89,7 +89,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= Does not compile
+#BROKEN= Does not compile
.endif
.include <bsd.port.post.mk>
diff --git a/astro/boinc-setiathome-enhanced/files/patch-amd64 b/astro/boinc-setiathome-enhanced/files/patch-amd64
new file mode 100644
index 000000000000..82643534f984
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/patch-amd64
@@ -0,0 +1,9 @@
+--- configure 2007-09-01 04:00:21.000000000 -0400
++++ configure 2008-01-06 11:24:56.000000000 -0500
+@@ -41958,5 +41958,5 @@
+ fi
+
+- if test -n "`echo ${target} | grep 'x86_64'`"; then
++ if test -n "`echo ${target} | egrep 'x86_64|amd64'`"; then
+ X86_64_TRUE=
+ X86_64_FALSE='#'