aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjpaetzel <jpaetzel@FreeBSD.org>2010-07-17 01:29:05 +0800
committerjpaetzel <jpaetzel@FreeBSD.org>2010-07-17 01:29:05 +0800
commitaecf16cbfdc92218c0c691324b630f085330603d (patch)
tree7b9cf8125a7d7098306cf082c6296767910addbd
parentc01a099415346b62ffba0b1873123dde71681645 (diff)
downloadfreebsd-ports-gnome-aecf16cbfdc92218c0c691324b630f085330603d.tar.gz
freebsd-ports-gnome-aecf16cbfdc92218c0c691324b630f085330603d.tar.zst
freebsd-ports-gnome-aecf16cbfdc92218c0c691324b630f085330603d.zip
Move check for OSVERSION to a better place in the Makefile
-rw-r--r--net/freeswitch-core/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/freeswitch-core/Makefile b/net/freeswitch-core/Makefile
index 467537721c7d..a05a176a2b8a 100644
--- a/net/freeswitch-core/Makefile
+++ b/net/freeswitch-core/Makefile
@@ -64,6 +64,10 @@ CONFIGURE_ENV+= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
USE_LDCONFIG= yes
CPPFLAGS+= -I${PREFIX}/include
+.if ${OSVERSION} < 700000
+IGNORE= freeswitch is only supported on FreeBSD 7 or newer
+.endif
+
FREESWITCH_USER= freeswitch
FREESWITCH_GROUP= ${FREESWITCH_USER}
@@ -268,11 +272,6 @@ post-install:
@${CHOWN} -R ${FREESWITCH_USER}:${FREESWITCH_GROUP} ${VARBASE}/spool/${PORTNAME}
@for i in $$(${FIND} ${PREFIX}/etc/${PORTNAME}/conf/ -type f -name '*.sample'); do if [ ! -f $${i%.sample} ]; then ${CP} -p $$i $${i%.sample}; fi; done
@${CAT} ${PKGMESSAGE}
-
-.if ${OSVERSION} < 700000
-IGNORE= freeswitch is only supported on FreeBSD 7 or newer
-.endif
-
@${ECHO_MSG} "This port chown -R various directories ${FREESWITCH_USER}:${FREESWITCH_GROUP} "
@${ECHO_MSG} "this is for port security . in the event something should stop working."
@${ECHO_MSG} "Please take the time to check chownership of the dir's"