aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-06-24 02:33:57 +0800
committerkwm <kwm@FreeBSD.org>2011-06-24 02:33:57 +0800
commitb013bd18d6b9c94e3c2d03d4932c908e27132915 (patch)
treea5978bb1fa38fbd20dc9f50efffd2e5b1203594b
parent33335b34d43520504854e04f4e994e12985b8384 (diff)
downloadfreebsd-ports-gnome-b013bd18d6b9c94e3c2d03d4932c908e27132915.tar.gz
freebsd-ports-gnome-b013bd18d6b9c94e3c2d03d4932c908e27132915.tar.zst
freebsd-ports-gnome-b013bd18d6b9c94e3c2d03d4932c908e27132915.zip
Update to 1.10.16.
Switch to xz distfile.
-rw-r--r--math/gnumeric/Makefile8
-rw-r--r--math/gnumeric/distinfo4
-rw-r--r--math/gnumeric/files/patch-src_session.c10
-rw-r--r--math/gnumeric/files/patch-src_sheet.c12
-rw-r--r--math/gnumeric/pkg-plist13
5 files changed, 29 insertions, 18 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 315e28786438..5a314ec8725d 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -8,7 +8,7 @@
# When updating, remember to update pkg-plist of gchemutils.
PORTNAME= gnumeric
-PORTVERSION= 1.10.15
+PORTVERSION= 1.10.16
CATEGORIES= math gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -23,7 +23,7 @@ RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_BZIP2= yes
+USE_XZ= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier pygtk2 \
@@ -36,7 +36,7 @@ USE_CSTD= gnu89
WANT_PERL= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gnome
+CONFIGURE_ARGS= --with-gnome --disable-silent-rules
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
python_prog=${PYTHON_VERSION}
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
@@ -48,7 +48,7 @@ GLIB_SCHEMAS= org.gnome.gnumeric.dialogs.gschema.xml \
MAN1= gnumeric.1 ssconvert.1 ssindex.1 ssgrep.1
-PLIST_SUB= VERSION=${PORTVERSION} GOFFICE=0.8.15
+PLIST_SUB= VERSION=${PORTVERSION} GOFFICE=0.8.16
OPTIONS= PERL "Enable Perl as extension language" on
#GNOMEDB "Enable libgnomedb support" off
diff --git a/math/gnumeric/distinfo b/math/gnumeric/distinfo
index 6891424874dc..b631224a6baa 100644
--- a/math/gnumeric/distinfo
+++ b/math/gnumeric/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/gnumeric-1.10.15.tar.bz2) = 4343a8e72bd19380d83ab5d4937388b2327e0dbb6187296e66dc7ca2d2b9025a
-SIZE (gnome2/gnumeric-1.10.15.tar.bz2) = 18577516
+SHA256 (gnome2/gnumeric-1.10.16.tar.xz) = 1d3d66bdb32b767a6db833d94a6ab2012eb4a39109140f6bc571334afac567fc
+SIZE (gnome2/gnumeric-1.10.16.tar.xz) = 14275616
diff --git a/math/gnumeric/files/patch-src_session.c b/math/gnumeric/files/patch-src_session.c
new file mode 100644
index 000000000000..28e0f23070cb
--- /dev/null
+++ b/math/gnumeric/files/patch-src_session.c
@@ -0,0 +1,10 @@
+--- src/session.c.orig 2011-06-23 17:48:23.000000000 +0200
++++ src/session.c 2011-06-23 17:49:21.000000000 +0200
+@@ -27,6 +27,7 @@
+ #include "session.h"
+ #include "application.h"
+ #include <workbook.h>
++#include <workbook-priv.h>
+ #include <workbook-view.h>
+ #include <wbc-gtk.h>
+ #include <gui-file.h>
diff --git a/math/gnumeric/files/patch-src_sheet.c b/math/gnumeric/files/patch-src_sheet.c
deleted file mode 100644
index f16176f35805..000000000000
--- a/math/gnumeric/files/patch-src_sheet.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/sheet.c.orig 2011-06-11 15:07:26.380716192 -0500
-+++ src/sheet.c 2011-06-11 15:07:10.273212703 -0500
-@@ -701,7 +701,8 @@ gnm_sheet_constructed (GObject *obj)
-
- sheet_scale_changed (sheet, TRUE, TRUE);
-
-- parent_class->constructed (obj);
-+ if (parent_class->constructed)
-+ parent_class->constructed (obj);
- }
-
- static guint
diff --git a/math/gnumeric/pkg-plist b/math/gnumeric/pkg-plist
index 1a14de89d86c..d0bd5d2942e2 100644
--- a/math/gnumeric/pkg-plist
+++ b/math/gnumeric/pkg-plist
@@ -500,7 +500,16 @@ share/gnome/help/gnumeric/C/figures/analysistools-moving-average-formula-spencer
share/gnome/help/gnumeric/C/figures/analysistools-moving-average-formula-weighted.png
share/gnome/help/gnumeric/C/figures/analysistools-moving-average-options.png
share/gnome/help/gnumeric/C/figures/analysistools-moving-average.png
+share/gnome/help/gnumeric/C/figures/analysistools-normality-ex1.png
+share/gnome/help/gnumeric/C/figures/analysistools-normality-ex2.png
+share/gnome/help/gnumeric/C/figures/analysistools-normality-ex3.png
+share/gnome/help/gnumeric/C/figures/analysistools-normality-ex4.png
+share/gnome/help/gnumeric/C/figures/analysistools-normality-testspec.png
+share/gnome/help/gnumeric/C/figures/analysistools-normality.png
share/gnome/help/gnumeric/C/figures/analysistools-outputoptions.png
+share/gnome/help/gnumeric/C/figures/analysistools-pcanalysis-ex1.png
+share/gnome/help/gnumeric/C/figures/analysistools-pcanalysis-ex2.png
+share/gnome/help/gnumeric/C/figures/analysistools-pcanalysis.png
share/gnome/help/gnumeric/C/figures/analysistools-random-ex1.png
share/gnome/help/gnumeric/C/figures/analysistools-random-ex2.png
share/gnome/help/gnumeric/C/figures/analysistools-random.png
@@ -515,6 +524,10 @@ share/gnome/help/gnumeric/C/figures/analysistools-regression.png
share/gnome/help/gnumeric/C/figures/analysistools-sampling-ex1.png
share/gnome/help/gnumeric/C/figures/analysistools-sampling-ex2.png
share/gnome/help/gnumeric/C/figures/analysistools-sampling.png
+share/gnome/help/gnumeric/C/figures/analysistools-signtest-ex1.png
+share/gnome/help/gnumeric/C/figures/analysistools-signtest-ex2.png
+share/gnome/help/gnumeric/C/figures/analysistools-signtest-ex3.png
+share/gnome/help/gnumeric/C/figures/analysistools-signtest.png
share/gnome/help/gnumeric/C/figures/analysistools-smoothing-ex1.png
share/gnome/help/gnumeric/C/figures/analysistools-smoothing-ex2.png
share/gnome/help/gnumeric/C/figures/analysistools-smoothing-ex3.png