aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-04 00:06:20 +0800
committermiwi <miwi@FreeBSD.org>2007-01-04 00:06:20 +0800
commitb0ed619295b79e33cd804fb9aea667cf599290bf (patch)
tree2ce06fc1adc0647664fc87c885ddaa55af2bd2b8
parenta37d37af23a901906c0b3921800eeb24eb5648e3 (diff)
downloadfreebsd-ports-gnome-b0ed619295b79e33cd804fb9aea667cf599290bf.tar.gz
freebsd-ports-gnome-b0ed619295b79e33cd804fb9aea667cf599290bf.tar.zst
freebsd-ports-gnome-b0ed619295b79e33cd804fb9aea667cf599290bf.zip
The [[TracNav]] macro implements fully customizable navigation bar for the Trac
wiki engine. The contents of the navigation bar is a wiki page itself and can be edited like any other wiki page. The navigation bar supports hierarchical ordering of topics. WWW: http://trac-hacks.org/wiki/TracNav PR: ports/107462 Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-nav/Makefile30
-rw-r--r--www/trac-nav/distinfo3
-rw-r--r--www/trac-nav/pkg-descr6
-rw-r--r--www/trac-nav/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6ba808b97afc..e28e71f9ffb5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1055,6 +1055,7 @@
SUBDIR += trac-addcomment
SUBDIR += trac-ctxtnavadd
SUBDIR += trac-gantt
+ SUBDIR += trac-nav
SUBDIR += trac-pagetopdf
SUBDIR += trac-tags
SUBDIR += trac-webadmin
diff --git a/www/trac-nav/Makefile b/www/trac-nav/Makefile
new file mode 100644
index 000000000000..851ed80329e3
--- /dev/null
+++ b/www/trac-nav/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: trac-nav
+# Date created: January 03 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nav
+PORTVERSION= 3.92p6
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/downloads/trac-hacks/
+PKGNAMEPREFIX= trac-
+DISTNAME= TracNav-${PORTVERSION:S/p/pre/}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= A fully customizable navigation bar for Trac
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools \
+ tracd:${PORTSDIR}/www/trac
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+USE_ZIP= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION:S/p/pre/} PYTHONVERSION=${_PYTHON_VERSION}
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-nav/distinfo b/www/trac-nav/distinfo
new file mode 100644
index 000000000000..c5680b565edb
--- /dev/null
+++ b/www/trac-nav/distinfo
@@ -0,0 +1,3 @@
+MD5 (TracNav-3.92pre6.zip) = 96d56563518088709906a175e92e257b
+SHA256 (TracNav-3.92pre6.zip) = 97059471822ff066b988d858cf572d089e95d545176c808ab107d796028dcbcb
+SIZE (TracNav-3.92pre6.zip) = 15680
diff --git a/www/trac-nav/pkg-descr b/www/trac-nav/pkg-descr
new file mode 100644
index 000000000000..6175851c26aa
--- /dev/null
+++ b/www/trac-nav/pkg-descr
@@ -0,0 +1,6 @@
+The [[TracNav]] macro implements fully customizable navigation bar for the Trac
+wiki engine. The contents of the navigation bar is a wiki page itself and can
+be edited like any other wiki page. The navigation bar supports hierarchical
+ordering of topics.
+
+WWW: http://trac-hacks.org/wiki/TracNav
diff --git a/www/trac-nav/pkg-plist b/www/trac-nav/pkg-plist
new file mode 100644
index 000000000000..02facd52a8d7
--- /dev/null
+++ b/www/trac-nav/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracNav-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg