aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-15 21:38:36 +0800
committermarino <marino@FreeBSD.org>2014-06-15 21:38:36 +0800
commitb430da2b14245b80004f166950a81450591296bf (patch)
treea8dfc414807026e65ff63cfb726fc6f7d45c6be2
parent00c1b6ca8f29e160cb742154d59a91a30d4f2c25 (diff)
downloadfreebsd-ports-gnome-b430da2b14245b80004f166950a81450591296bf.tar.gz
freebsd-ports-gnome-b430da2b14245b80004f166950a81450591296bf.tar.zst
freebsd-ports-gnome-b430da2b14245b80004f166950a81450591296bf.zip
graphics/geos: Fix PHP option, reset mainatainer
The PHP option was hardcoded to lang/php5, but it reportedly works on other versions of PHP. It also installs a PHP module, so it should have had a run depends on PHP as well as a build depends (hence the revump) Also: * Remove USE_LDCONFIG, I don't see why it's here * convert USE_BZIP2 * Reset maintainer due to history of timeouts and non-responsiveness to this PR * respect 80 columns PR: 178431 Submitted by: mcdouga9 (egr.msu.edu) Fixes by: marino
-rw-r--r--graphics/geos/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index f2f25eba36de..3cfa7e3e8b78 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -3,22 +3,20 @@
PORTNAME= geos
PORTVERSION= 3.4.2
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/
-MAINTAINER= konstantin@saurbier.net
+MAINTAINER= ports@FreeBSD.org
COMMENT= GEOS implements all the OpenGIS "Simple Features for SQL"
LICENSE= LGPL21
USE_AUTOTOOLS= libtool
-USE_BZIP2= yes
-USE_LDCONFIG= yes
-USES= gmake
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
OPTIONS_DEFINE= PHP PYTHON RUBY
-
OPTIONS_SUB= yes
.include <bsd.port.options.mk>
@@ -33,7 +31,8 @@ CONFIGURE_ARGS+= --enable-python
.endif
.if ${PORT_OPTIONS:MPHP}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/php-config:${PORTSDIR}/lang/php5
+USE_PHP= yes
+USE_PHP_BUILD= yes
CONFIGURE_ARGS+= --enable-php
.endif
@@ -44,6 +43,7 @@ CONFIGURE_ENV+= RUBY="${RUBY}"
.endif
post-install:
- @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libgeos.so.0
+ @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so \
+ ${STAGEDIR}${PREFIX}/lib/libgeos.so.0
.include <bsd.port.mk>