aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornik <nik@FreeBSD.org>2004-12-22 05:24:55 +0800
committernik <nik@FreeBSD.org>2004-12-22 05:24:55 +0800
commitb4a84fe7267abd875c022603ad23da4ceb57c7ba (patch)
tree300f5d301186542d8c3d4aa0c9ae6f3956f018c6
parent2df2d3d093c86556cb3116a491270d4cda213341 (diff)
downloadfreebsd-ports-gnome-b4a84fe7267abd875c022603ad23da4ceb57c7ba.tar.gz
freebsd-ports-gnome-b4a84fe7267abd875c022603ad23da4ceb57c7ba.tar.zst
freebsd-ports-gnome-b4a84fe7267abd875c022603ad23da4ceb57c7ba.zip
Add libtap, a C implementation of the Test Anything Protocol, written
by yours truly.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libtap/Makefile29
-rw-r--r--devel/libtap/distinfo2
-rw-r--r--devel/libtap/pkg-descr6
-rw-r--r--devel/libtap/pkg-message8
-rw-r--r--devel/libtap/pkg-plist4
6 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3583e1706da2..30dfe2a9c6bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -467,6 +467,7 @@
SUBDIR += libstrfunc
SUBDIR += libstroke
SUBDIR += libtai
+ SUBDIR += libtap
SUBDIR += libtar
SUBDIR += libtecla
SUBDIR += libticalcs
diff --git a/devel/libtap/Makefile b/devel/libtap/Makefile
new file mode 100644
index 000000000000..842d8895afc2
--- /dev/null
+++ b/devel/libtap/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libtap
+# Date created: 21 December 2004
+# Whom: Nik Clayton <nik@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtap
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+DISTNAME= tap-${PORTVERSION}
+
+MAINTAINER= nik@FreeBSD.org
+COMMENT= Library implementing the Test Anything Protocol
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+MAN3= tap.3
+
+post-build:
+ ${CAT} pkg-message
+
+check:
+ (cd ${WRKSRC}; ${MAKE} check)
+
+.include <bsd.port.mk>
diff --git a/devel/libtap/distinfo b/devel/libtap/distinfo
new file mode 100644
index 000000000000..3c2869726b1a
--- /dev/null
+++ b/devel/libtap/distinfo
@@ -0,0 +1,2 @@
+MD5 (tap-1.0.tar.gz) = 1b1afbc63f110a73792a9c3ada11072f
+SIZE (tap-1.0.tar.gz) = 311852
diff --git a/devel/libtap/pkg-descr b/devel/libtap/pkg-descr
new file mode 100644
index 000000000000..38e1e13ca8c6
--- /dev/null
+++ b/devel/libtap/pkg-descr
@@ -0,0 +1,6 @@
+Library implementing the Test Anything Protocol. Will be / is used by
+src/tools/regression, and anything else that wants an easy-to-implement
+test suite.
+
+-Nik
+nik@FreeBSD.org
diff --git a/devel/libtap/pkg-message b/devel/libtap/pkg-message
new file mode 100644
index 000000000000..3247a2b3bf1f
--- /dev/null
+++ b/devel/libtap/pkg-message
@@ -0,0 +1,8 @@
+If you have Perl and Test::Harness installed you can run the test suite
+for libtap by running
+
+ make check
+
+or
+
+ prove -r
diff --git a/devel/libtap/pkg-plist b/devel/libtap/pkg-plist
new file mode 100644
index 000000000000..6153298f525e
--- /dev/null
+++ b/devel/libtap/pkg-plist
@@ -0,0 +1,4 @@
+include/tap.h
+lib/libtap.a
+lib/libtap.so.0
+lib/libtap.so