aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-06-10 06:20:34 +0800
committermarino <marino@FreeBSD.org>2016-06-10 06:20:34 +0800
commitb57311a2bbefdb4ddee1e6ec551af7d206e2fb02 (patch)
treee1b97f443b39a0539d73a840bbf63003d321dd63
parent4b0971b6b5bd9f993c97153b959397bea49e87e9 (diff)
downloadfreebsd-ports-gnome-b57311a2bbefdb4ddee1e6ec551af7d206e2fb02.tar.gz
freebsd-ports-gnome-b57311a2bbefdb4ddee1e6ec551af7d206e2fb02.tar.zst
freebsd-ports-gnome-b57311a2bbefdb4ddee1e6ec551af7d206e2fb02.zip
devel/gprbuild: Upgrade version 20150506 => 20160609
GPRBuild build is now hosted on github, so we can move away from the yearly releases and update more frequently. Unfortunately the docs makefile is currently broken so docs are disabled currently. When they come back, only txt and html docs will be supported. This new version detected a missing reference in the template-parser port so that port has been fixed and the downstream ports bumped accordingly. It also discovered an interface specification issue in a designer example of qtada. I spent a few minutes trying to fix/workaround it, but ultimately marked it broken. I will also deprecate the port because it no development has occurred since the port was created, and it's not even based on a real release. We'll see if anybody cares (3 month deprecation).
-rw-r--r--devel/gprbuild/Makefile34
-rw-r--r--devel/gprbuild/distinfo5
-rw-r--r--devel/gprbuild/files/Makefile.BSD161
-rw-r--r--devel/gprbuild/files/patch-gnat_targparm302
-rw-r--r--devel/gprbuild/files/patch-src_gpr__version.adb18
-rw-r--r--devel/gprbuild/pkg-plist3
-rw-r--r--devel/gps/Makefile2
-rw-r--r--textproc/templates_parser/Makefile3
-rw-r--r--www/aws-demos/Makefile2
-rw-r--r--www/aws/Makefile2
-rw-r--r--x11-toolkits/qtada/Makefile7
11 files changed, 106 insertions, 433 deletions
diff --git a/devel/gprbuild/Makefile b/devel/gprbuild/Makefile
index 1f13e16a10c3..fbe0c07cd765 100644
--- a/devel/gprbuild/Makefile
+++ b/devel/gprbuild/Makefile
@@ -3,10 +3,7 @@
PORTNAME= gprbuild
PORTVERSION= ${SNAPSHOT}
-PORTREVISION= 3
CATEGORIES= devel
-MASTER_SITES= http://downloads.dragonlace.net/src/
-DISTNAME= gprbuild-gpl-${YEAR}-src
MAINTAINER= marino@FreeBSD.org
COMMENT= Adacore multi-language software build tool
@@ -15,26 +12,29 @@ LICENSE= GPLv3
BUILD_DEPENDS= xmlada>=4.4:textproc/xmlada
-YEAR= 2015
-SNAPSHOT= 20150506
+SNAPSHOT= 20160609
USES= ada
+USE_GITHUB= yes
+GH_ACCOUNT= AdaCore
+GH_PROJECT= gprbuild
+GH_TAGNAME= 376670f
+
+PORTDOCS= *
MAKE_ARGS= PROCESSORS=${MAKE_JOBS_NUMBER}
-PORTDOCS= html txt pdf
-CONHOST= ${CONFIGURE_TARGET}
+BUILD_WRKSRC= ${WRKSRC}/construction
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
INSTALL_TARGET= install
-OPTIONS_DEFINE= DOCS
-DOCS_INSTALL_TARGET= install-docs
-
-.include <bsd.port.options.mk>
+#OPTIONS_DEFINE= DOCS
+#DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
+#DOCS_ALL_TARGET= gen-docs
+#DOCS_INSTALL_TARGET= install-docs
post-patch:
- ${CP} ${FILESDIR}/Makefile.BSD ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -i "" -e "s,@AUXPREFIX@,${PREFIX}/gcc5-aux," \
+ ${MKDIR} ${WRKDIR}/trash ${BUILD_WRKSRC}
+ ${CP} ${FILESDIR}/Makefile.BSD ${WRKSRC}/construction/Makefile
+ @${REINPLACE_CMD} -i "" -e "s,@AUXPREFIX@,${PREFIX}/${ADAXX}-aux," \
${WRKSRC}/share/gprconfig/compilers.xml
- ${SED} -e 's|@host@|${CONHOST}|' \
- ${WRKSRC}/src/gprconfig-sdefault.ads.in > \
- ${WRKSRC}/src/gprconfig-sdefault.ads
- ${MV} ${WRKSRC}/share/gprconfig/*.orig ${WRKSRC}/obj-cov
+ ${MV} ${WRKSRC}/share/gprconfig/*.orig ${WRKDIR}/trash
.include <bsd.port.mk>
diff --git a/devel/gprbuild/distinfo b/devel/gprbuild/distinfo
index 3890f12281d2..0557ba24010b 100644
--- a/devel/gprbuild/distinfo
+++ b/devel/gprbuild/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gprbuild-gpl-2015-src.tar.gz) = 5d5bbc8c57075250c264e2f15d9949383450ac696eb8a90803c2a36b55ecd0e2
-SIZE (gprbuild-gpl-2015-src.tar.gz) = 3424715
+TIMESTAMP = 1465501253
+SHA256 (AdaCore-gprbuild-20160609-376670f_GH0.tar.gz) = c595767f69cca960d5f0f7bfa5f7bdcfb2fcba11822432e87f1eef52cfb68fab
+SIZE (AdaCore-gprbuild-20160609-376670f_GH0.tar.gz) = 958175
diff --git a/devel/gprbuild/files/Makefile.BSD b/devel/gprbuild/files/Makefile.BSD
index 1f650f947346..cc359e7f8caf 100644
--- a/devel/gprbuild/files/Makefile.BSD
+++ b/devel/gprbuild/files/Makefile.BSD
@@ -1,97 +1,80 @@
-.PHONY: all
-.PHONY: generate_sources
-
-AFLAGS= -gnat12 -gnaty -gnatQ -O2 -gnatpn -gnatws -g1 -j${PROCESSORS}
-
-COBJS= obj/link.o obj/gprbuild_dummies.o
-
-LOOK= -aI${.CURDIR}/gnat -aI${.CURDIR}/gen_src \
- -aL${PREFIX}/lib/xmlada/static -aI${PREFIX}/include/xmlada
-LARGS= -largs ${.CURDIR}/obj/link.o \
- -largs ${.CURDIR}/obj/gprbuild_dummies.o \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_dom.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_input_sources.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_sax.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_schema.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_unicode.a
-
-GENDIR= gen_src
-GEN_SRCS= ${GENDIR}/snames.adb ${GENDIR}/snames.ads
-DOCSDIR= ${PREFIX}/share/doc/gprbuild
-
-all: gprbuild
+.PATH: ../src
+.PATH: ../gpr/src
+
+STATIC_FLAGS= -gnat12 -gnaty -gnatQ -O2 -gnatpn -gnatws -g1
+
+PREFIX?= /usr/local
+GPRLIB_INC= -I${PREFIX}/include/xmlada -I../gpr/src
+LOOK= -aL${PREFIX}/lib/xmlada/static -aI${PREFIX}/include/xmlada
+
+libgpr_csrc= gprbuild_dummies.c \
+ gpr_imports.c
+
+LARGS= ${libgpr_csrc:S/^/-largs /:.c=.o} \
+ -largs ${PREFIX}/lib/xmlada/static/libxmlada_dom.a \
+ -largs ${PREFIX}/lib/xmlada/static/libxmlada_input_sources.a \
+ -largs ${PREFIX}/lib/xmlada/static/libxmlada_sax.a \
+ -largs ${PREFIX}/lib/xmlada/static/libxmlada_schema.a \
+ -largs ${PREFIX}/lib/xmlada/static/libxmlada_unicode.a
+
+APPS= gprclean/gprclean-main.adb \
+ gprconfig/gprconfig-main.adb \
+ gprbuild/gprbuild-main.adb \
+ gprbind/gprbind.adb \
+ gprlib/gprlib.adb \
+ gprinstall/gprinstall-main.adb \
+ gprslave/gprslave.adb \
+ gprname/gprname-main.adb \
+ gprls/gprls-main.adb
+
+all: ${APPS:H}
+
+gprclean: gprclean-main.adb ${libgpr_csrc:.c=.o}
+ gnatmake -o ${.TARGET} -j${PROCESSORS} \
+ ${STATIC_FLAGS} ${GPRLIB_INC} ${LOOK} \
+ ${.ALLSRC:M*adb} ${LARGS}
+
+.for app in ${APPS:Ngprclean*}
+${app:H}: gprclean ${app:T} ${libgpr_csrc:.c=.o}
+ gnatmake -o ${.TARGET} ${STATIC_FLAGS} ${GPRLIB_INC} ${LOOK} \
+ ${.ALLSRC:M*adb} ${LARGS}
+.endfor
+
+clean:
+ rm -f *.o *.ali b~* ${APP:H}
+
+gen-docs:
+ ${MAKE} -e -C ${.CURDIR:H}/doc html txt
install:
mkdir -p ${DESTDIR}${PREFIX}/bin \
${DESTDIR}${PREFIX}/libexec/gprbuild \
${DESTDIR}${PREFIX}/share/gpr \
${DESTDIR}${PREFIX}/share/gprconfig
- ${BSD_INSTALL_PROGRAM} ${.CURDIR}/obj/gprclean \
- ${.CURDIR}/obj/gprinstall \
- ${.CURDIR}/obj/gprconfig \
- ${.CURDIR}/obj/gprslave \
- ${.CURDIR}/obj/gprbuild ${DESTDIR}${PREFIX}/bin
- ${BSD_INSTALL_PROGRAM} ${.CURDIR}/obj/gprbind \
- ${.CURDIR}/obj/gprlib ${DESTDIR}${PREFIX}/libexec/gprbuild
- ${BSD_INSTALL_DATA} ${.CURDIR}/share/_default.gpr \
- ${DESTDIR}${PREFIX}/share/gpr
- ${BSD_INSTALL_DATA} ${.CURDIR}/share/gprconfig/* \
- ${DESTDIR}${PREFIX}/share/gprconfig
+ ${BSD_INSTALL_PROGRAM} \
+ ${.CURDIR}/gprclean \
+ ${.CURDIR}/gprinstall \
+ ${.CURDIR}/gprconfig \
+ ${.CURDIR}/gprslave \
+ ${.CURDIR}/gprls \
+ ${.CURDIR}/gprname \
+ ${.CURDIR}/gprbuild \
+ ${DESTDIR}${PREFIX}/bin
+ ${BSD_INSTALL_PROGRAM} \
+ ${.CURDIR}/gprbind \
+ ${.CURDIR}/gprlib \
+ ${DESTDIR}${PREFIX}/libexec/gprbuild
+ ${BSD_INSTALL_DATA} \
+ ${.CURDIR}/../share/_default.gpr \
+ ${DESTDIR}${PREFIX}/share/gpr
+ ${BSD_INSTALL_DATA} \
+ ${.CURDIR}/../share/gprconfig/*.x[sm][dl] \
+ ${DESTDIR}${PREFIX}/share/gprconfig
install-docs:
- mkdir -p ${DESTDIR}${DOCSDIR}/html ${DESTDIR}${DOCSDIR}/txt \
- ${DESTDIR}${DOCSDIR}/pdf
- ${BSD_INSTALL_DATA} ${.CURDIR}/doc/txt/gprbuild_ug.txt \
- ${DESTDIR}${DOCSDIR}/txt
- ${BSD_INSTALL_DATA} ${.CURDIR}/doc/pdf/gprbuild_ug.pdf \
- ${DESTDIR}${DOCSDIR}/pdf
- cp -r ${.CURDIR}/doc/html/* ${DESTDIR}${DOCSDIR}/html
- rm -rf ${DESTDIR}${DOCSDIR}/html/_sources
- ${BSD_INSTALL_DATA} ${.CURDIR}/doc/*.png \
- ${DESTDIR}${DOCSDIR}/html
-
-gprclean: src/gprclean-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprclean-main.adb ${LARGS}
-
-gprbind: gprclean src/gprslave.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprbind.adb ${LARGS}
-
-gprlib: gprbind src/gprslave.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprlib.adb ${LARGS}
-
-gprslave: gprlib src/gprslave.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprslave.adb ${LARGS}
-
-gprinstall: gprslave src/gprinstall-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprinstall-main.adb ${LARGS}
-
-gprconfig: gprinstall src/gprconfig-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprconfig-main.adb ${LARGS}
-
-gprbuild: gprconfig src/gprbuild-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o ${.TARGET} ${AFLAGS} ${LOOK} \
- ${.CURDIR}/src/gprbuild-main.adb ${LARGS}
-
-obj/link.o: gnat/link.c
- gcc -c -o ${.CURDIR}/${.TARGET} ${.ALLSRC}
-
-obj/gprbuild_dummies.o: src/gprbuild_dummies.c
- gcc -c -o ${.CURDIR}/${.TARGET} ${.ALLSRC}
-
-generate_sources:
- mkdir -p ${.CURDIR}/${GENDIR}
- (cd ${.CURDIR}/gnat && cp xsnamest.adb xutil.* snames.adb-tmpl \
- snames.ads-tmpl snames.h-tmpl ../${GENDIR})
- (cd ${.CURDIR}/${GENDIR} && \
- gnatmake -gnatf -gnatwae -gnatyg -gnatyS xsnamest && \
- ./xsnamest && \
- mv snames.ns snames.ads && \
- mv snames.nb snames.adb)
-
-${GEN_SRCS}: generate_sources
+ mkdir -p ${DESTDIR}${PREFIX}/share/doc/gprbuild/txt
+ ${BSD_INSTALL_DATA} ${.CURDIR}/../doc/txt/gprbuild_ug.txt \
+ ${DESTDIR}${PREFIX}/share/doc/gprbuild/txt
+ rm -rf ${.CURDIR}/../doc/html/_sources
+ rm -f ${.CURDIR}/../doc/html/.buildinfo
+ cp -a ${.CURDIR}/../doc/html ${DESTDIR}${PREFIX}/share/doc/gprbuild
diff --git a/devel/gprbuild/files/patch-gnat_targparm b/devel/gprbuild/files/patch-gnat_targparm
deleted file mode 100644
index b52527689a96..000000000000
--- a/devel/gprbuild/files/patch-gnat_targparm
+++ /dev/null
@@ -1,302 +0,0 @@
-These restriction pragmas are not yet supported on FSF GNAT 5:
- No_Specification_Of_Aspect
- No_Use_Of_Attribute
- No_Use_Of_Pragma
-
---- gnat/targparm.ads.orig 2015-05-06 11:08:38 UTC
-+++ gnat/targparm.ads
-@@ -615,53 +615,28 @@ package Targparm is
- -- selected component with Sloc value System_Location and given Prefix
- -- (Pre) and Selector (Sel) values.
-
-- type Set_NOD_Type is access procedure (Unit : Node_Id);
-+ type Set_RND_Type is access procedure (Unit : Node_Id);
- -- Parameter type for Get_Target_Parameters that records a Restriction
- -- No_Dependence for the given unit (identifier or selected component).
-
-- type Set_NSA_Type is access procedure (Asp : Name_Id; OK : out Boolean);
-- -- Parameter type for Get_Target_Parameters that records a Restriction
-- -- No_Specification_Of_Aspect. Asp is the aspect name. OK is set True
-- -- if this is an OK aspect name, and False if it is not an aspect name.
--
-- type Set_NUA_Type is access procedure (Attr : Name_Id; OK : out Boolean);
-- -- Parameter type for Get_Target_Parameters that records a Restriction
-- -- No_Use_Of_Attribute. Attr is the attribute name. OK is set True if
-- -- this is an OK attribute name, and False if it is not an attribute name.
--
-- type Set_NUP_Type is access procedure (Prag : Name_Id; OK : out Boolean);
-- -- Parameter type for Get_Target_Parameters that records a Restriction
-- -- No_Use_Of_Pragma. Prag is the pragma name. OK is set True if this is
-- -- an OK pragma name, and False if it is not a recognized pragma name.
--
- procedure Get_Target_Parameters
- (System_Text : Source_Buffer_Ptr;
- Source_First : Source_Ptr;
- Source_Last : Source_Ptr;
- Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null);
-- -- Called at the start of execution to obtain target parameters from the
-- -- source of package System. The parameters provide the source text to be
-- -- scanned (in System_Text (Source_First .. Source_Last)). If the three
-- -- subprograms Make_Id, Make_SC, and Set_NOD are left at their default
-- -- value of null, Get_Target_Parameters will ignore pragma Restrictions
-- -- (No_Dependence) lines; otherwise it will use these three subprograms to
-- -- record them. Similarly, if Set_NUP is left at its default value of null,
-- -- then any occurrences of pragma Restrictions (No_Use_Of_Pragma => XXX)
-- -- will be ignored; otherwise it will use this procedure to record the
-- -- pragma. Similarly for the NSA and NUA cases.
-+ Set_RND : Set_RND_Type := null);
-+ -- Called at the start of execution to obtain target parameters from
-+ -- the source of package System. The parameters provide the source
-+ -- text to be scanned (in System_Text (Source_First .. Source_Last)).
-+ -- if the three subprograms are left at their default value of null,
-+ -- Get_Target_Parameters will ignore pragma Restrictions No_Dependence
-+ -- lines, otherwise it will use these three subprograms to record them.
-
- procedure Get_Target_Parameters
- (Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null);
-+ Set_RND : Set_RND_Type := null);
- -- This version reads in system.ads using Osint. The idea is that the
- -- caller uses the first version if they have to read system.ads anyway
- -- (e.g. the compiler) and uses this simpler interface if system.ads is
---- gnat/targparm.adb.orig 2015-05-06 11:08:38 UTC
-+++ gnat/targparm.adb
-@@ -154,10 +154,7 @@ package body Targparm is
- procedure Get_Target_Parameters
- (Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null)
-+ Set_RND : Set_RND_Type := null)
- is
- Text : Source_Buffer_Ptr;
- Hi : Source_Ptr;
-@@ -184,10 +181,7 @@ package body Targparm is
- Source_Last => Hi,
- Make_Id => Make_Id,
- Make_SC => Make_SC,
-- Set_NOD => Set_NOD,
-- Set_NSA => Set_NSA,
-- Set_NUA => Set_NUA,
-- Set_NUP => Set_NUP);
-+ Set_RND => Set_RND);
- end Get_Target_Parameters;
-
- -- Version where caller supplies system.ads text
-@@ -198,10 +192,7 @@ package body Targparm is
- Source_Last : Source_Ptr;
- Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null)
-+ Set_RND : Set_RND_Type := null)
- is
- P : Source_Ptr;
- -- Scans source buffer containing source of system.ads
-@@ -212,48 +203,6 @@ package body Targparm is
- Result : Boolean;
- -- Records boolean from system line
-
-- OK : Boolean;
-- -- Status result from Set_NUP/NSA/NUA call
--
-- PR_Start : Source_Ptr;
-- -- Pointer to ( following pragma Restrictions
--
-- procedure Collect_Name;
-- -- Scan a name starting at System_Text (P), and put Name in Name_Buffer,
-- -- with Name_Len being length, folded to lower case. On return, P points
-- -- just past the last character (which should be a right paren).
--
-- ------------------
-- -- Collect_Name --
-- ------------------
--
-- procedure Collect_Name is
-- begin
-- Name_Len := 0;
-- loop
-- if System_Text (P) in 'a' .. 'z'
-- or else
-- System_Text (P) = '_'
-- or else
-- System_Text (P) in '0' .. '9'
-- then
-- Name_Buffer (Name_Len + 1) := System_Text (P);
--
-- elsif System_Text (P) in 'A' .. 'Z' then
-- Name_Buffer (Name_Len + 1) :=
-- Character'Val (Character'Pos (System_Text (P)) + 32);
--
-- else
-- exit;
-- end if;
--
-- P := P + 1;
-- Name_Len := Name_Len + 1;
-- end loop;
-- end Collect_Name;
--
-- -- Start of processing for Get_Target_Parameters
--
- begin
- if Parameters_Obtained then
- return;
-@@ -312,9 +261,6 @@ package body Targparm is
-
- elsif System_Text (P .. P + 20) = "pragma Restrictions (" then
- P := P + 21;
-- PR_Start := P - 1;
--
-- -- Boolean restrictions
-
- Rloop : for K in All_Boolean_Restrictions loop
- declare
-@@ -339,9 +285,7 @@ package body Targparm is
- null;
- end loop Rloop;
-
-- -- Restrictions taking integer parameter
--
-- Ploop : for K in Integer_Parameter_Restrictions loop
-+ Ploop : for K in All_Parameter_Restrictions loop
- declare
- Rname : constant String :=
- All_Parameter_Restrictions'Image (K);
-@@ -456,119 +400,23 @@ package body Targparm is
- P := P + 1;
- end loop;
-
-- Set_NOD (Unit);
-+ Set_RND (Unit);
- goto Line_Loop_Continue;
- end;
--
-- -- No_Specification_Of_Aspect case
--
-- elsif System_Text (P .. P + 29) = "No_Specification_Of_Aspect => "
-- then
-- P := P + 30;
--
-- -- Skip this processing (and simply ignore the pragma), if
-- -- caller did not supply the subprogram we need to process
-- -- such lines.
--
-- if Set_NSA = null then
-- goto Line_Loop_Continue;
-- end if;
--
-- -- We have scanned
-- -- "pragma Restrictions (No_Specification_Of_Aspect =>"
--
-- Collect_Name;
--
-- if System_Text (P) /= ')' then
-- goto Bad_Restrictions_Pragma;
--
-- else
-- Set_NSA (Name_Find, OK);
--
-- if OK then
-- goto Line_Loop_Continue;
-- else
-- goto Bad_Restrictions_Pragma;
-- end if;
-- end if;
--
-- -- No_Use_Of_Attribute case
--
-- elsif System_Text (P .. P + 22) = "No_Use_Of_Attribute => " then
-- P := P + 23;
--
-- -- Skip this processing (and simply ignore No_Use_Of_Attribute
-- -- lines) if caller did not supply the subprogram we need to
-- -- process such lines.
--
-- if Set_NUA = null then
-- goto Line_Loop_Continue;
-- end if;
--
-- -- We have scanned
-- -- "pragma Restrictions (No_Use_Of_Attribute =>"
--
-- Collect_Name;
--
-- if System_Text (P) /= ')' then
-- goto Bad_Restrictions_Pragma;
--
-- else
-- Set_NUA (Name_Find, OK);
--
-- if OK then
-- goto Line_Loop_Continue;
-- else
-- goto Bad_Restrictions_Pragma;
-- end if;
-- end if;
--
-- -- No_Use_Of_Pragma case
--
-- elsif System_Text (P .. P + 19) = "No_Use_Of_Pragma => " then
-- P := P + 20;
--
-- -- Skip this processing (and simply ignore No_Use_Of_Pragma
-- -- lines) if caller did not supply the subprogram we need to
-- -- process such lines.
--
-- if Set_NUP = null then
-- goto Line_Loop_Continue;
-- end if;
--
-- -- We have scanned
-- -- "pragma Restrictions (No_Use_Of_Pragma =>"
--
-- Collect_Name;
--
-- if System_Text (P) /= ')' then
-- goto Bad_Restrictions_Pragma;
--
-- else
-- Set_NUP (Name_Find, OK);
--
-- if OK then
-- goto Line_Loop_Continue;
-- else
-- goto Bad_Restrictions_Pragma;
-- end if;
-- end if;
- end if;
-
- -- Here if unrecognizable restrictions pragma form
-
-- <<Bad_Restrictions_Pragma>>
--
- Set_Standard_Error;
- Write_Line
- ("fatal error: system.ads is incorrectly formatted");
- Write_Str ("unrecognized or incorrect restrictions pragma: ");
-
-- P := PR_Start;
-+ while System_Text (P) /= ')'
-+ and then
-+ System_Text (P) /= ASCII.LF
- loop
-- exit when System_Text (P) = ASCII.LF;
- Write_Char (System_Text (P));
-- exit when System_Text (P) = ')';
- P := P + 1;
- end loop;
-
diff --git a/devel/gprbuild/files/patch-src_gpr__version.adb b/devel/gprbuild/files/patch-src_gpr__version.adb
deleted file mode 100644
index 2e1bd58c7e5c..000000000000
--- a/devel/gprbuild/files/patch-src_gpr__version.adb
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/gpr_version.adb.orig 2015-05-06 11:08:38 UTC
-+++ src/gpr_version.adb
-@@ -65,14 +65,7 @@ package body GPR_Version is
- end if;
- end loop Last_Loop;
-
-- case Build_Type is
-- when Gnatpro =>
-- return "Pro " & Gpr_Version & " " & Date & Host;
-- when GPL =>
-- return "GPL " & Gpr_Version & " " & Date & Host;
-- when FSF =>
-- return Gpr_Version & " " & Date & Host;
-- end case;
-+ return Gpr_Version & " " & Date & Host;
- end Gpr_Version_String;
-
- end GPR_Version;
diff --git a/devel/gprbuild/pkg-plist b/devel/gprbuild/pkg-plist
index 0c7a4020ee68..1ec5d5e08a34 100644
--- a/devel/gprbuild/pkg-plist
+++ b/devel/gprbuild/pkg-plist
@@ -2,6 +2,8 @@ bin/gprbuild
bin/gprclean
bin/gprconfig
bin/gprinstall
+bin/gprls
+bin/gprname
bin/gprslave
libexec/gprbuild/gprbind
libexec/gprbuild/gprlib
@@ -14,7 +16,6 @@ share/gprconfig/cpp.xml
share/gprconfig/cross.xml
share/gprconfig/fortran.xml
share/gprconfig/gnat.xml
-share/gprconfig/gnat_runtime.mapping
share/gprconfig/gprconfig.xsd
share/gprconfig/linker.xml
share/gprconfig/nocompiler.xml
diff --git a/devel/gps/Makefile b/devel/gps/Makefile
index d4058d8cfe32..3313652e1d63 100644
--- a/devel/gps/Makefile
+++ b/devel/gps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gps
PORTVERSION= 6.1.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= gps-6.1.1-src
diff --git a/textproc/templates_parser/Makefile b/textproc/templates_parser/Makefile
index c06aa557b113..b976c9fa8d4e 100644
--- a/textproc/templates_parser/Makefile
+++ b/textproc/templates_parser/Makefile
@@ -18,11 +18,12 @@ RUN_DEPENDS= xmlada>=4.4:textproc/xmlada
USES= ada gmake tar:bzip2
DESTINC= ${STAGEDIR}${PREFIX}/include/templates_parser
-PLIST_SUB= LIBVER=11.10.0w
+PLIST_SUB= LIBVER=${PORTVERSION:R}
MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER} \
ENABLE_SHARED=true \
HOST=${CONFIGURE_TARGET} \
TARGET=${CONFIGURE_TARGET} \
+ VERSION=${PORTVERSION:R} \
prefix=${PREFIX}
PORTDOCS= html
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index b8b3ccfdcaa4..095491ae1d6a 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aws
PORTVERSION= 3.3.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/
PKGNAMESUFFIX= -demos
diff --git a/www/aws/Makefile b/www/aws/Makefile
index 57378a321631..251eedb60205 100644
--- a/www/aws/Makefile
+++ b/www/aws/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aws
PORTVERSION= 3.3.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/
diff --git a/x11-toolkits/qtada/Makefile b/x11-toolkits/qtada/Makefile
index 8e8c1658042a..4833feacccca 100644
--- a/x11-toolkits/qtada/Makefile
+++ b/x11-toolkits/qtada/Makefile
@@ -13,6 +13,13 @@ COMMENT= Ada2005 language bindings to Qt4 framework
LICENSE= GPLv2
+# Error: In library project "Examples_Designer_Custom_Widget_Plugin"
+# Unit "Analog_Clock_Plugin" is not in the interface set
+# but it is needed by the spec of "Analog_Clock_Plugin.moc"
+BROKEN= New gprbuild detected interface issue with designer example
+DEPRECATED= No development since 2012, usefulness unclear
+EXPIRATION_DATE= 2016-09-09
+
BUILD_DEPENDS= gprbuild>=20120510:devel/gprbuild \
asis>=2011:lang/asis