aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-05-02 13:05:51 +0800
committeralepulver <alepulver@FreeBSD.org>2007-05-02 13:05:51 +0800
commitb701f2cc7d066809dc143f968c25fd84ce041faf (patch)
tree14bdf0c6cc2c13b8ec7fd835aa1a6f8db4ebbe56
parent8752be71ecb4204e22c2cb34347bbd3f8e82b0ca (diff)
downloadfreebsd-ports-gnome-b701f2cc7d066809dc143f968c25fd84ce041faf.tar.gz
freebsd-ports-gnome-b701f2cc7d066809dc143f968c25fd84ce041faf.tar.zst
freebsd-ports-gnome-b701f2cc7d066809dc143f968c25fd84ce041faf.zip
GiGi (aka GG) is a GUI library for OpenGL. It is platform-independent (it runs
at least on Linux and Windows, and probably more), compiler-independent (it compiles under at GCC 3.2 or higher and MSVC++ 7.1 or higher, and probably more), and driver-independent. A reference driver for SDL is provided, and it is straightforward to write one for yourself should you decide to do so. Features: * True modularity. You provide the initialized OpenGL environment and user input, and GG provides the GUI behavior. A reference SDL input driver is provided. * Independence of platform, compiler, and input driver/application framework. * Applicability to multiple types of frame-based apps. Any frame-based app can use GG, from FPS to TBS games. Documentation. I am the documentation-Nazi you've been hoping for. Ve haf vays of makink you understand our code. WWW: http://gigi.sourceforge.net/
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/gigi/Makefile61
-rw-r--r--x11-toolkits/gigi/distinfo3
-rw-r--r--x11-toolkits/gigi/files/patch-GiGiSDL.pc.in11
-rw-r--r--x11-toolkits/gigi/files/patch-SConstruct25
-rw-r--r--x11-toolkits/gigi/pkg-descr18
-rw-r--r--x11-toolkits/gigi/pkg-plist74
7 files changed, 193 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 977ac9c5e5af..615858f84432 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -41,6 +41,7 @@
SUBDIR += gal2-reference
SUBDIR += gauche-gtk
SUBDIR += gdl
+ SUBDIR += gigi
SUBDIR += gnocl
SUBDIR += gnome-sharp20
SUBDIR += gnomemm
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
new file mode 100644
index 000000000000..6305917260b0
--- /dev/null
+++ b/x11-toolkits/gigi/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: gigi
+# Date created: 2007-04-29
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= gigi
+PORTVERSION= 0.6.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alepulver
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= OpenGL Graphic User Interface Library
+
+LIB_DEPENDS= IL.1:${PORTSDIR}/graphics/devil \
+ boost_filesystem.3:${PORTSDIR}/devel/boost \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+USE_SCONS= yes
+SCONS_ARGS= prefix=""
+USE_SDL= sdl
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/GG
+
+SHLIB_VER= 0
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+
+post-build:
+.for f in GiGi GiGiNet GiGiSDL
+ @cd ${WRKSRC} && ${SED} -e \
+ 's|%(prefix)s|${PREFIX}|; s|%(libdir)s|${PREFIX}/lib|; \
+ s|%(incdir)s|${PREFIX}/include|; \
+ s|%(version)s|${PORTVERSION}|; s|%(gigi_libs)s||; \
+ s|%(boost_include)s||; s|%(gigi_net_libs)s||; \
+ s|%(gigi_sdl_libs)s||; s|%(sdl_include)s||' \
+ ${f}.pc.in > ${f}.pc
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/GG
+ ${CP} -R ${WRKSRC}/GG/* ${PREFIX}/include/GG
+.for lib in GiGi GiGiNet GiGiSDL
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib${lib}.so \
+ ${PREFIX}/lib/lib${lib}.so.${SHLIB_VER}
+ cd ${PREFIX}/lib && ${LN} -sf lib${lib}.so.${SHLIB_VER} lib${lib}.so
+ ${INSTALL_DATA} ${WRKSRC}/${lib}.pc ${PREFIX}/libdata/pkgconfig
+.endfor
+
+maint-gen-distfile:
+ @if [ -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
+ ${ECHO_CMD} "ERROR: the distfile already exists."; \
+ ${FALSE}; \
+ fi
+ svn export https://svn.sourceforge.net/svnroot/${PORTNAME}/trunk ${PORTNAME}
+ tar cjf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}
+ ${RM} -rf ${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gigi/distinfo b/x11-toolkits/gigi/distinfo
new file mode 100644
index 000000000000..ec55290484bf
--- /dev/null
+++ b/x11-toolkits/gigi/distinfo
@@ -0,0 +1,3 @@
+MD5 (gigi-0.6.0.tar.bz2) = ffe4667bf8b17841fdb1929491b37cb7
+SHA256 (gigi-0.6.0.tar.bz2) = f8008ce089c099b85ff3874df8677a1d9bcba60f21fb7f33e1def6dd7c4fb074
+SIZE (gigi-0.6.0.tar.bz2) = 586265
diff --git a/x11-toolkits/gigi/files/patch-GiGiSDL.pc.in b/x11-toolkits/gigi/files/patch-GiGiSDL.pc.in
new file mode 100644
index 000000000000..a6a934a87804
--- /dev/null
+++ b/x11-toolkits/gigi/files/patch-GiGiSDL.pc.in
@@ -0,0 +1,11 @@
+--- ./GiGiSDL.pc.in.orig Sun Jan 15 16:32:32 2006
++++ ./GiGiSDL.pc.in Tue May 1 15:59:09 2007
+@@ -4,7 +4,7 @@
+
+ Name: GiGiSDL
+ Description: An SDL-based input driver and application framework for use with libGiGi.
+-Requires: GiGi = ${version}, GiGiNet = ${version}
++Requires: GiGi = ${version}, GiGiNet = ${version}, sdl
+ Version: ${version}
+ Libs: -lGiGiSDL %(gigi_sdl_libs)s
+ Cflags: %(sdl_include)s
diff --git a/x11-toolkits/gigi/files/patch-SConstruct b/x11-toolkits/gigi/files/patch-SConstruct
new file mode 100644
index 000000000000..48ed759e102a
--- /dev/null
+++ b/x11-toolkits/gigi/files/patch-SConstruct
@@ -0,0 +1,25 @@
+--- ./SConstruct.orig Tue Aug 22 23:22:16 2006
++++ ./SConstruct Tue May 1 16:01:52 2007
+@@ -53,6 +53,11 @@
+ options.Add('with_devil', 'Root directory of DevIL installation')
+ options.Add('with_devil_include', 'Specify exact include dir for DevIL headers')
+ options.Add('with_devil_libdir', 'Specify exact library dir for DevIL library')
++options.Add('CC', 'C compiler')
++options.Add('CXX', 'C++ compiler')
++options.Add('CCFLAGS', 'C compiler flags', Split(''))
++options.Add('CPPPATH', 'Compiler include path', Split(''))
++options.Add('LIBPATH', 'Linker library path', Split(''))
+
+
+ ##################################################
+@@ -103,6 +108,10 @@
+ pass
+
+ options.Update(env)
++
++env['CCFLAGS'] = Split(env['CCFLAGS'])
++env['CPPPATH'] = Split(env['CPPPATH'])
++env['LIBPATH'] = Split(env['LIBPATH'])
+
+ if env.has_key('use_distcc') and env['use_distcc']:
+ env['CC'] = 'distcc %s' % env['CC']
diff --git a/x11-toolkits/gigi/pkg-descr b/x11-toolkits/gigi/pkg-descr
new file mode 100644
index 000000000000..86f5769c7e62
--- /dev/null
+++ b/x11-toolkits/gigi/pkg-descr
@@ -0,0 +1,18 @@
+GiGi (aka GG) is a GUI library for OpenGL. It is platform-independent (it runs
+at least on Linux and Windows, and probably more), compiler-independent (it
+compiles under at GCC 3.2 or higher and MSVC++ 7.1 or higher, and probably
+more), and driver-independent. A reference driver for SDL is provided, and it
+is straightforward to write one for yourself should you decide to do so.
+
+Features:
+* True modularity. You provide the initialized OpenGL environment and user
+ input, and GG provides the GUI behavior. A reference SDL input driver is
+ provided.
+* Independence of platform, compiler, and input driver/application framework.
+* Applicability to multiple types of frame-based apps. Any frame-based app can
+ use GG, from FPS to TBS games.
+
+Documentation. I am the documentation-Nazi you've been hoping for. Ve haf vays
+of makink you understand our code.
+
+WWW: http://gigi.sourceforge.net/
diff --git a/x11-toolkits/gigi/pkg-plist b/x11-toolkits/gigi/pkg-plist
new file mode 100644
index 000000000000..ab5e2451eced
--- /dev/null
+++ b/x11-toolkits/gigi/pkg-plist
@@ -0,0 +1,74 @@
+include/GG/Base.h
+include/GG/BrowseInfoWnd.h
+include/GG/Button.h
+include/GG/Clr.h
+include/GG/Config.h
+include/GG/Config.h.in
+include/GG/Control.h
+include/GG/DrawUtil.h
+include/GG/DropDownList.h
+include/GG/DynamicGraphic.h
+include/GG/Edit.h
+include/GG/Enum.h
+include/GG/EventPump.h
+include/GG/Exception.h
+include/GG/Font.h
+include/GG/GUI.h
+include/GG/Layout.h
+include/GG/ListBox.h
+include/GG/Menu.h
+include/GG/MultiEdit.h
+include/GG/OgreSDL/OgreSDLGUI.h
+include/GG/PluginInterface.h
+include/GG/PtRect.h
+include/GG/SDL/SDLGUI.h
+include/GG/Scroll.h
+include/GG/Signal0.h
+include/GG/Signal1.h
+include/GG/Signal2.h
+include/GG/Signal3.h
+include/GG/Signal4.h
+include/GG/Signal5.h
+include/GG/Signal6.h
+include/GG/Signal7.h
+include/GG/Signal8.h
+include/GG/SignalTemplate.h
+include/GG/SignalsAndSlots.h
+include/GG/Slider.h
+include/GG/Spin.h
+include/GG/StaticGraphic.h
+include/GG/StyleFactory.h
+include/GG/TabWnd.h
+include/GG/TextControl.h
+include/GG/Texture.h
+include/GG/Timer.h
+include/GG/Wnd.h
+include/GG/WndEditor.h
+include/GG/WndEvent.h
+include/GG/ZList.h
+include/GG/dialogs/ColorDlg.h
+include/GG/dialogs/FileDlg.h
+include/GG/dialogs/ThreeButtonDlg.h
+include/GG/gen_signals.py
+include/GG/ltdl.h
+include/GG/ltdl_config.h
+include/GG/net/SDL_net.h
+include/GG/net/SDLnetsys.h
+include/GG/net/fastevents.h
+include/GG/net/net2.h
+include/GG/net/queue.h
+include/GG/net/trace.h
+lib/libGiGi.so
+lib/libGiGi.so.%%SHLIB_VER%%
+lib/libGiGiNet.so
+lib/libGiGiNet.so.%%SHLIB_VER%%
+lib/libGiGiSDL.so
+lib/libGiGiSDL.so.%%SHLIB_VER%%
+libdata/pkgconfig/GiGi.pc
+libdata/pkgconfig/GiGiNet.pc
+libdata/pkgconfig/GiGiSDL.pc
+@dirrm include/GG/net
+@dirrm include/GG/dialogs
+@dirrm include/GG/SDL
+@dirrm include/GG/OgreSDL
+@dirrm include/GG