aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2001-07-29 14:45:21 +0800
committerroger <roger@FreeBSD.org>2001-07-29 14:45:21 +0800
commitb802fd4301590c05d228fd21fda79ef2aef0f7d5 (patch)
tree85c1f91236bcef8aaa7bdea28ca925cd532886ce
parente25d2b3df60c0fb709af2d435a87dd51a58fc150 (diff)
downloadfreebsd-ports-gnome-b802fd4301590c05d228fd21fda79ef2aef0f7d5.tar.gz
freebsd-ports-gnome-b802fd4301590c05d228fd21fda79ef2aef0f7d5.tar.zst
freebsd-ports-gnome-b802fd4301590c05d228fd21fda79ef2aef0f7d5.zip
Use the official pwlib and opwnh323 files instead of the
ones from the gnomemeeting site. This fixes several build problems. Eventually gnomemeeting will be updated to use the current release of openh323 and this port can be removed.
-rw-r--r--net/openh323_1.1/Makefile9
-rw-r--r--net/openh323_1.1/distinfo4
-rw-r--r--net/openh323_1.1/files/patch-aa27
3 files changed, 7 insertions, 33 deletions
diff --git a/net/openh323_1.1/Makefile b/net/openh323_1.1/Makefile
index 80b747ce889a..90d1f90ba65b 100644
--- a/net/openh323_1.1/Makefile
+++ b/net/openh323_1.1/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: openh323_1.1
-# Date created: July 25 2000
+# Date created: July 25 2001
# Whom: Roger Hardiman <roger@freebsd.org>
#
# $FreeBSD$
@@ -8,9 +8,10 @@
PORTNAME= openh323
PORTVERSION= 1.1
CATEGORIES= net
-MASTER_SITES= http://130.104.229.225/gnomemeeting/downloads/
-DISTFILES= openh323_1.1.tar.gz \
- pwlib_min_1.1pl18.tar.gz
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= roger
+DISTFILES= openh323_1.1pl1.tar.gz \
+ pwlib_min_1.1pl19.tar.gz
MAINTAINER= roger@freebsd.org
diff --git a/net/openh323_1.1/distinfo b/net/openh323_1.1/distinfo
index 7a6a56e421d9..d568f3cfc3f1 100644
--- a/net/openh323_1.1/distinfo
+++ b/net/openh323_1.1/distinfo
@@ -1,2 +1,2 @@
-MD5 (openh323_1.1.tar.gz) = 51fe78bc7a0da3422479263106b4d95a
-MD5 (pwlib_min_1.1pl18.tar.gz) = c4c88ce65cca72ce5d9cfea36205e7a4
+MD5 (openh323_1.1pl1.tar.gz) = 3b98bb7dcc875442b17421e348cfd64b
+MD5 (pwlib_min_1.1pl19.tar.gz) = 672b2e90bb7d16b1ab85ba8328a0d364
diff --git a/net/openh323_1.1/files/patch-aa b/net/openh323_1.1/files/patch-aa
index c9fda689fa09..9dfa880fdb46 100644
--- a/net/openh323_1.1/files/patch-aa
+++ b/net/openh323_1.1/files/patch-aa
@@ -1,32 +1,5 @@
*** ../pwlib/src/ptlib/unix/tlibthrd.cxx.orig Wed Jul 25 17:09:09 2001
--- ../pwlib/src/ptlib/unix/tlibthrd.cxx Thu Jul 26 13:21:40 2001
-*************** void PThread::PX_NewThread(BOOL startSus
-*** 386,391 ****
---- 386,409 ----
- // pthread_attr_t threadAttr;
- // pthread_attr_init(&threadAttr);
- PAssertOS(pthread_create(&PX_threadId, NULL, PX_ThreadStart, this) == 0);
-+
-+ #if defined(P_FREEBSD)
-+ // There is a potential race condition here which shows up with FreeBSD 4.2
-+ // and later, but really applies to all pthread libraries.
-+ // If a thread is started in suspend mode, we need to make sure
-+ // the thread (PX_ThreadStart) has had a chance to execute and block on the
-+ // sigwait() (blocking on the Resume Signal) before this function returns.
-+ // Otherwise the main program may issue a Resume Signal on the thread
-+ // by calling PThread::Resume() before the thread is ready for it.
-+ // If that happens the program will abort with an unhandled signal error.
-+ // A workaround (not 100% guaranteed) is to yield here, which gives
-+ // the newly created thread (PX_ThreadStart) a chance to execute.
-+
-+ if (startSuspended) {
-+ sched_yield();
-+ }
-+ #endif
-+
- }
-
-
*************** BOOL PSemaphore::Wait(const PTimeInterva
*** 767,773 ****
::gettimeofday(&finishTime, NULL);