aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-08 21:29:44 +0800
committeraz <az@FreeBSD.org>2013-09-08 21:29:44 +0800
commitb9e5d0150e2c6b53bebbacd0e5acc0d5c8b79143 (patch)
tree10f157894719947908820cd8628af5801d1b7534
parent0d896dc0eadb81e01f54b7f6f20b648a073d0198 (diff)
downloadfreebsd-ports-gnome-b9e5d0150e2c6b53bebbacd0e5acc0d5c8b79143.tar.gz
freebsd-ports-gnome-b9e5d0150e2c6b53bebbacd0e5acc0d5c8b79143.tar.zst
freebsd-ports-gnome-b9e5d0150e2c6b53bebbacd0e5acc0d5c8b79143.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
-rw-r--r--devel/p5-AnyEvent-DBI/Makefile9
-rw-r--r--devel/p5-App-Build/Makefile9
-rw-r--r--devel/p5-Class-Accessor-Complex/Makefile9
-rw-r--r--devel/p5-Config-Objective/Makefile9
-rw-r--r--devel/p5-Digest-TransformPath/Makefile9
-rw-r--r--devel/p5-File-BaseDir/Makefile9
-rw-r--r--devel/p5-Jonk/Makefile8
-rw-r--r--devel/p5-Log-Dispatch-Array/Makefile9
-rw-r--r--devel/p5-Module-Install-Repository/Makefile8
-rw-r--r--devel/p5-POEx-Types/Makefile8
-rw-r--r--devel/p5-Package-Constants/Makefile9
-rw-r--r--devel/p5-Pod-Coverage-TrustPod/Makefile9
-rw-r--r--devel/p5-Regexp-Shellish/Makefile8
-rw-r--r--devel/p5-Role-Identifiable/Makefile9
-rw-r--r--devel/p5-SVN-Dumpfile/Makefile9
-rw-r--r--devel/p5-Shape/Makefile9
-rw-r--r--devel/p5-Tee/Makefile9
-rw-r--r--devel/p5-Test-CheckDeps/Makefile3
-rw-r--r--devel/p5-Test-Singleton/Makefile9
19 files changed, 52 insertions, 109 deletions
diff --git a/devel/p5-AnyEvent-DBI/Makefile b/devel/p5-AnyEvent-DBI/Makefile
index e5a0229d238b..f6364391310f 100644
--- a/devel/p5-AnyEvent-DBI/Makefile
+++ b/devel/p5-AnyEvent-DBI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-AnyEvent-DBI
-# Date created: 19 Mar 2010
-# Whom: Denis Pokataev <catone@cpan.org>
-#
+# Created by: Denis Pokataev <catone@cpan.org>
# $FreeBSD$
-#
PORTNAME= AnyEvent-DBI
PORTVERSION= 2.2
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-AnyEvent>=4.15:${PORTSDIR}/devel/p5-AnyEvent \
p5-common-sense>=3.3:${PORTSDIR}/devel/p5-common-sense
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::DBI.3
diff --git a/devel/p5-App-Build/Makefile b/devel/p5-App-Build/Makefile
index 1db90e0dc947..b7ef7bf1cd6c 100644
--- a/devel/p5-App-Build/Makefile
+++ b/devel/p5-App-Build/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: App::Build
-# Date created: 03 Mar 2010
-# Whom: Alex Bakhtin <Alex.Bakhtin@gmail.com>
-#
+# Created by: Alex Bakhtin <Alex.Bakhtin@gmail.com>
# $FreeBSD$
-#
PORTNAME= App-Build
PORTVERSION= 0.74
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Test-Differences>=0.47:${PORTSDIR}/devel/p5-Test-Differences \
p5-App-Options>=0:${PORTSDIR}/devel/p5-App-Options \
p5-Module-Build>=0.28:${PORTSDIR}/devel/p5-Module-Build
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.if !defined(NOPORTDOCS)
diff --git a/devel/p5-Class-Accessor-Complex/Makefile b/devel/p5-Class-Accessor-Complex/Makefile
index dd426645dd74..60b208b799d5 100644
--- a/devel/p5-Class-Accessor-Complex/Makefile
+++ b/devel/p5-Class-Accessor-Complex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Class-Accessor-Complex
-# Date created: 2010-11-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Class-Accessor-Complex
PORTVERSION= 1.100880
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-Accessor-Installer>=0:${PORTSDIR}/devel/p5-Class-Accessor-Installer
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Accessor::Complex.3
diff --git a/devel/p5-Config-Objective/Makefile b/devel/p5-Config-Objective/Makefile
index ccbb15d53c13..d859847ca9d9 100644
--- a/devel/p5-Config-Objective/Makefile
+++ b/devel/p5-Config-Objective/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Config-Objective
-# Date created: Mon Feb 16 15:50:34 CST 2004
-# Whom: Jim Pirzyk <pirzyk@uiuc.edu>
-#
+# Created by: Jim Pirzyk <pirzyk@uiuc.edu>
# $FreeBSD$
-#
PORTNAME= Config-Objective
PORTVERSION= 0.9.1
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Parse-Yapp>=0:${PORTSDIR}/devel/p5-Parse-Yapp \
p5-ParseLex>=0:${PORTSDIR}/devel/p5-ParseLex
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Config::Objective::List.3 Config::Objective::Boolean.3 \
Config::Objective::Table.3 Config::Objective.3 \
diff --git a/devel/p5-Digest-TransformPath/Makefile b/devel/p5-Digest-TransformPath/Makefile
index 6f1bbc3cba6e..a04008c53daa 100644
--- a/devel/p5-Digest-TransformPath/Makefile
+++ b/devel/p5-Digest-TransformPath/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Digest-TransformPath
-# Date created: 08 September 2007
-# Whom: Cory R. King <coryking@mozimedia.com>
-#
+# Created by: Cory R. King <coryking@mozimedia.com>
# $FreeBSD$
-#
PORTNAME= Digest-TransformPath
PORTVERSION= 1.00
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= coryking@mozimedia.com
COMMENT= Implements the TransformPath concept
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::TransformPath.3
diff --git a/devel/p5-File-BaseDir/Makefile b/devel/p5-File-BaseDir/Makefile
index bc45d198524f..cf61f109fd73 100644
--- a/devel/p5-File-BaseDir/Makefile
+++ b/devel/p5-File-BaseDir/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-File-BaseDir
-# Date created: Aug 21 2004
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= File-BaseDir
PORTVERSION= 0.03
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= Use the freedesktop basedir spec
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= File::BaseDir.3
diff --git a/devel/p5-Jonk/Makefile b/devel/p5-Jonk/Makefile
index f567ba424358..4e753b6ef535 100644
--- a/devel/p5-Jonk/Makefile
+++ b/devel/p5-Jonk/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Jonk
-# Date created: 21 Dec 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Jonk
PORTVERSION= 0.05
@@ -20,7 +15,8 @@ RUN_DEPENDS= \
p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Jonk.3 \
Jonk::Client.3 \
diff --git a/devel/p5-Log-Dispatch-Array/Makefile b/devel/p5-Log-Dispatch-Array/Makefile
index 9e98dfc861b7..28523bb03989 100644
--- a/devel/p5-Log-Dispatch-Array/Makefile
+++ b/devel/p5-Log-Dispatch-Array/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Log-Dispatch-Array
-# Date created: 2011-09-19
-# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
-#
+# Created by: Geraud CONTINSOUZAS <geraud@gcu.info>
# $FreeBSD$
-#
PORTNAME= Log-Dispatch-Array
PORTVERSION= 1.001
@@ -22,7 +18,8 @@ RUN_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Dispatch::Array.3
diff --git a/devel/p5-Module-Install-Repository/Makefile b/devel/p5-Module-Install-Repository/Makefile
index d9e6253d1e20..5f60a0a91bc9 100644
--- a/devel/p5-Module-Install-Repository/Makefile
+++ b/devel/p5-Module-Install-Repository/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Module::Install::Repository
-# Date created: 08 Sep 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Module-Install-Repository
PORTVERSION= 0.06
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to set repository URL from svn/svk/Git checkout
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Module::Install::Repository.3
diff --git a/devel/p5-POEx-Types/Makefile b/devel/p5-POEx-Types/Makefile
index af97f5d875da..61d5d4498dea 100644
--- a/devel/p5-POEx-Types/Makefile
+++ b/devel/p5-POEx-Types/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: POEx::Types
-# Date created: 09 Oct 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= POEx-Types
PORTVERSION= 1.100910
@@ -22,7 +17,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POEx::Types.3
diff --git a/devel/p5-Package-Constants/Makefile b/devel/p5-Package-Constants/Makefile
index 2a537367ec1f..740e5c7f9f27 100644
--- a/devel/p5-Package-Constants/Makefile
+++ b/devel/p5-Package-Constants/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Package-Constants
-# Date created: 25 Jun 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Package-Constants
PORTVERSION= 0.02
@@ -16,6 +12,7 @@ COMMENT= List all constants declared in a package
MAN3= Package::Constants.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Pod-Coverage-TrustPod/Makefile b/devel/p5-Pod-Coverage-TrustPod/Makefile
index 04ba71e6c4d4..24e3761e2107 100644
--- a/devel/p5-Pod-Coverage-TrustPod/Makefile
+++ b/devel/p5-Pod-Coverage-TrustPod/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Pod-Coverage-TrustPod
-# Date created: 2011-02-16
-# Whom: milki <milki@rescomp.berkeley.edu>
-#
+# Created by: milki <milki@rescomp.berkeley.edu>
# $FreeBSD$
-#
PORTNAME= Pod-Coverage-TrustPod
PORTVERSION= 0.100002
@@ -25,7 +21,8 @@ RUN_DEPENDS= p5-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Pod-Coverage \
TEST_DEPENDS= p5-Test-Pod>=1.41:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Pod::Coverage::TrustPod.3
diff --git a/devel/p5-Regexp-Shellish/Makefile b/devel/p5-Regexp-Shellish/Makefile
index a2de15e6537f..2cdbefc0c4a4 100644
--- a/devel/p5-Regexp-Shellish/Makefile
+++ b/devel/p5-Regexp-Shellish/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Regexp::Shellish
-# Date created: 8 Jan 2004
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Regexp-Shellish
PORTVERSION= 0.93
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module for shell-like regular expressions
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Regexp::Shellish.3
diff --git a/devel/p5-Role-Identifiable/Makefile b/devel/p5-Role-Identifiable/Makefile
index e0ccaec4bc2b..61eb5f44d720 100644
--- a/devel/p5-Role-Identifiable/Makefile
+++ b/devel/p5-Role-Identifiable/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Role-Identifiable
-# Date created: 2011-09-19
-# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
-#
+# Created by: Geraud CONTINSOUZAS <geraud@gcu.info>
# $FreeBSD$
-#
PORTNAME= Role-Identifiable
PORTVERSION= 0.005
@@ -21,7 +17,8 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Role::Identifiable::HasIdent.3 \
Role::Identifiable::HasTags.3
diff --git a/devel/p5-SVN-Dumpfile/Makefile b/devel/p5-SVN-Dumpfile/Makefile
index 37dafcd5125d..a15f437d6077 100644
--- a/devel/p5-SVN-Dumpfile/Makefile
+++ b/devel/p5-SVN-Dumpfile/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SVN::Dumpfile
-# Date created: 2009-04-17
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= SVN-Dumpfile
PORTVERSION= 0.13.107
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Data-GUID>=0:${PORTSDIR}/devel/p5-Data-GUID \
p5-Readonly>=1.03:${PORTSDIR}/devel/p5-Readonly
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Dumpfile.3 \
SVN::Dumpfile::Node.3 \
diff --git a/devel/p5-Shape/Makefile b/devel/p5-Shape/Makefile
index 8efabd160c97..0641523ba49c 100644
--- a/devel/p5-Shape/Makefile
+++ b/devel/p5-Shape/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Shape
-# Date created: April 17th 2003
-# Whom: Leif Pedersen <pedersen@meridian-enviro.com>
-#
+# Created by: Leif Pedersen <pedersen@meridian-enviro.com>
# $FreeBSD$
-#
PORTNAME= Shape
PORTVERSION= 0.04
@@ -17,7 +13,8 @@ COMMENT= Perl5 module to read and write shapefiles via shapelib
LIB_DEPENDS= shp:${PORTSDIR}/devel/shapelib
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Shape.3
.include <bsd.port.mk>
diff --git a/devel/p5-Tee/Makefile b/devel/p5-Tee/Makefile
index ebe71997b923..4a83ac106368 100644
--- a/devel/p5-Tee/Makefile
+++ b/devel/p5-Tee/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tee
-# Date created: 2011-02-04
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Tee
PORTVERSION= 0.14
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-IO-CaptureOutput>0:${PORTSDIR}/devel/p5-IO-CaptureOutput \
p5-Probe-Perl>=0:${PORTSDIR}/sysutils/p5-Probe-Perl
RUN_DEPENDS= p5-IO-CaptureOutput>0:${PORTSDIR}/devel/p5-IO-CaptureOutput
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= ptee.1
MAN3= Tee::App.3 Tee.3
diff --git a/devel/p5-Test-CheckDeps/Makefile b/devel/p5-Test-CheckDeps/Makefile
index c48799d5fbb2..b644b5165722 100644
--- a/devel/p5-Test-CheckDeps/Makefile
+++ b/devel/p5-Test-CheckDeps/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-CPAN-Meta>=2.120920:${PORTSDIR}/devel/p5-CPAN-Meta \
p5-Module-Build-Tiny>=0.021:${PORTSDIR}/devel/p5-Module-Build-Tiny
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Test::CheckDeps.3
diff --git a/devel/p5-Test-Singleton/Makefile b/devel/p5-Test-Singleton/Makefile
index 63fd484a7a0b..1e15aafb067b 100644
--- a/devel/p5-Test-Singleton/Makefile
+++ b/devel/p5-Test-Singleton/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Singleton
-# Date created: 2006-07-15
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Test-Singleton
PORTVERSION= 1.03
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Singleton.3