aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradrian <adrian@FreeBSD.org>2010-03-26 18:35:51 +0800
committeradrian <adrian@FreeBSD.org>2010-03-26 18:35:51 +0800
commitb9f4aebe4449e9af4db147c6d4d2cb0a912420ad (patch)
tree08840067226a745a79c7c02e7682fd93b0eba8dc
parent753bcc91891f460728737b6455d498698ec44391 (diff)
downloadfreebsd-ports-gnome-b9f4aebe4449e9af4db147c6d4d2cb0a912420ad.tar.gz
freebsd-ports-gnome-b9f4aebe4449e9af4db147c6d4d2cb0a912420ad.tar.zst
freebsd-ports-gnome-b9f4aebe4449e9af4db147c6d4d2cb0a912420ad.zip
lusca-head port update:
* update port to r14499. * make kerberos helper conditional to build; and don't compile it by default - this unbreaks the default build under 8.0 for now.
-rw-r--r--www/lusca-head/Makefile11
-rw-r--r--www/lusca-head/distinfo6
-rw-r--r--www/lusca-head/files/patch-src-cf.data.pre20
3 files changed, 9 insertions, 28 deletions
diff --git a/www/lusca-head/Makefile b/www/lusca-head/Makefile
index abf4b65bebc7..038872932609 100644
--- a/www/lusca-head/Makefile
+++ b/www/lusca-head/Makefile
@@ -75,13 +75,13 @@
# Enable experimental multicast notification of cachemisses.
PORTNAME= lusca
-DISTVERSION= r14281
-PORTREVISION= 3
+DISTVERSION= r14499
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= lusca-cache
PKGNAMESUFFIX= -head
-DISTNAME= LUSCA_HEAD-r14281
+DISTNAME= LUSCA_HEAD-r14499
# EXTRACT_SUFX= .tar.gz
MAINTAINER= adrian@freebsd.org
@@ -104,6 +104,7 @@ SUB_LIST+= SQUID_UID=${SQUID_UID} SQUID_GID=${SQUID_GID}
OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_SASL_AUTH "Install SASL authentication helpers" off \
+ SQUID_KERBEROS_HELPER "Install Keberos authentication helper" off \
SQUID_DELAY_POOLS "Enable delay pools" on \
SQUID_SNMP "Enable SNMP support" on \
SQUID_CARP "Enable CARP support" on \
@@ -181,7 +182,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800037
+.if defined(SQUID_KERBEROS_HELPER) && ${OSVERSION} >= 800037
BROKEN= does not compile with Heimdal 1.1 in 8.0-CURRENT
.endif
@@ -223,7 +224,7 @@ CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-digest-auth-helpers="${digest_auth}" \
--enable-external-acl-helpers="${external_acl}" \
--enable-ntlm-auth-helpers="SMB"
-.if !defined(NO_KERBEROS) && !defined(WITHOUT_KERBEROS)
+.if defined(SQUID_KERBEROS_HELPER) && !defined(NO_KERBEROS) && !defined(WITHOUT_KERBEROS)
# XXX This currently only works with heimdal from the base system,
# see ${FILES_DIR}/patch-helpers_negotiate_auth-squid_kerb_auth_*
CONFIGURE_ARGS+= --enable-negotiate-auth-helpers="squid_kerb_auth"
diff --git a/www/lusca-head/distinfo b/www/lusca-head/distinfo
index 17e007b0db05..0a32e5ab07ef 100644
--- a/www/lusca-head/distinfo
+++ b/www/lusca-head/distinfo
@@ -1,3 +1,3 @@
-MD5 (LUSCA_HEAD-r14281.tar.gz) = 8b2fe411bf2082e0f2946c68154ef0e6
-SHA256 (LUSCA_HEAD-r14281.tar.gz) = fb44bab1f5e74998d7024c03ad5d66cf2d70667814abdd3e7e1df9f14f39794b
-SIZE (LUSCA_HEAD-r14281.tar.gz) = 2300869
+MD5 (LUSCA_HEAD-r14499.tar.gz) = 834f4eaa48176fe719d773b54aced334
+SHA256 (LUSCA_HEAD-r14499.tar.gz) = 8f5d0872253d4ae996818dd58ea8233057052607699330d39adb53e935d9cdab
+SIZE (LUSCA_HEAD-r14499.tar.gz) = 2254295
diff --git a/www/lusca-head/files/patch-src-cf.data.pre b/www/lusca-head/files/patch-src-cf.data.pre
index 8d1935980da3..72f515e4f8e8 100644
--- a/www/lusca-head/files/patch-src-cf.data.pre
+++ b/www/lusca-head/files/patch-src-cf.data.pre
@@ -1,25 +1,5 @@
--- src/cf.data.pre.orig 2009-07-27 04:46:32.000000000 +0000
+++ src/cf.data.pre 2009-12-06 10:15:24.000000000 +0000
-@@ -2024,7 +2024,7 @@
- NAME: cache_dir
- TYPE: cachedir
- DEFAULT: none
--DEFAULT_IF_NONE: ufs @DEFAULT_SWAP_DIR@ 100 16 256
-+DEFAULT_IF_NONE: aufs @DEFAULT_SWAP_DIR@ 100 16 256
- LOC: Config.cacheSwap
- DOC_START
- Usage:
-@@ -2549,6 +2549,10 @@
- LOC: Config.pidFilename
- DOC_START
- A filename to write the process-id to. To disable, enter "none".
-+
-+ Note: If you change this setting, you need to set squid_pidfile
-+ in /etc/rc.conf to reflect the new value. Please see
-+ %%PREFIX%%/etc/rc.d/squid for details.
- DOC_END
-
- NAME: debug_options
@@ -3975,12 +3979,12 @@
NAME: cache_effective_user