aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-05-24 15:07:01 +0800
committerpi <pi@FreeBSD.org>2016-05-24 15:07:01 +0800
commitba867c221aecc5d88347f4dfb7c09d0690911522 (patch)
tree36bce182d665b4f09525f538b101dcca27afec51
parent9ef8e2212b00e358cb945367fe401d36305ec379 (diff)
downloadfreebsd-ports-gnome-ba867c221aecc5d88347f4dfb7c09d0690911522.tar.gz
freebsd-ports-gnome-ba867c221aecc5d88347f4dfb7c09d0690911522.tar.zst
freebsd-ports-gnome-ba867c221aecc5d88347f4dfb7c09d0690911522.zip
sysutils/backuppc: fix fatal error with perl-5.22
- Using an array as a reference cause fatal error with Perl-5.22. PR: 209496 Submitted by: Alexander Moisseev <moiseev@mezonplus.ru> (maintainer)
-rw-r--r--sysutils/backuppc/Makefile2
-rw-r--r--sysutils/backuppc/files/patch-lib_BackupPC_CGI_Browse.pm11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/backuppc/Makefile b/sysutils/backuppc/Makefile
index 7aa70906bb29..0f07a143bf79 100644
--- a/sysutils/backuppc/Makefile
+++ b/sysutils/backuppc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= backuppc
PORTVERSION= 3.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF
DISTNAME= BackupPC-${PORTVERSION}
diff --git a/sysutils/backuppc/files/patch-lib_BackupPC_CGI_Browse.pm b/sysutils/backuppc/files/patch-lib_BackupPC_CGI_Browse.pm
new file mode 100644
index 000000000000..674c2d14502e
--- /dev/null
+++ b/sysutils/backuppc/files/patch-lib_BackupPC_CGI_Browse.pm
@@ -0,0 +1,11 @@
+--- lib/BackupPC/CGI/Browse.pm.orig 2016-05-14 07:28:52 UTC
++++ lib/BackupPC/CGI/Browse.pm
+@@ -65,7 +65,7 @@ sub action
+ #
+ # default to the newest backup
+ #
+- if ( !defined($In{num}) && defined(@Backups) && @Backups > 0 ) {
++ if ( !defined($In{num}) && @Backups > 0 ) {
+ $i = @Backups - 1;
+ $num = $Backups[$i]{num};
+ }