aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2008-04-09 10:02:24 +0800
committeralepulver <alepulver@FreeBSD.org>2008-04-09 10:02:24 +0800
commitbb041f8af0052989a9a88819f38ee385f3792bd2 (patch)
treeb657da1c6167ab58f4a412c4b19fe1e9d051dc7c
parent2dd8393f754c253089f3051a30ea2b04e1f0e106 (diff)
downloadfreebsd-ports-gnome-bb041f8af0052989a9a88819f38ee385f3792bd2.tar.gz
freebsd-ports-gnome-bb041f8af0052989a9a88819f38ee385f3792bd2.tar.zst
freebsd-ports-gnome-bb041f8af0052989a9a88819f38ee385f3792bd2.zip
- Update to version 0.2.b1.
-rw-r--r--emulators/qmc2/Makefile19
-rw-r--r--emulators/qmc2/distinfo6
-rw-r--r--emulators/qmc2/files/patch-Makefile14
-rw-r--r--emulators/qmc2/files/patch-arch__FreeBSD.cfg4
-rw-r--r--emulators/qmc2/files/patch-arch__default.cfg4
-rw-r--r--emulators/qmc2/pkg-plist137
6 files changed, 107 insertions, 77 deletions
diff --git a/emulators/qmc2/Makefile b/emulators/qmc2/Makefile
index 82dce43c820c..7fc4d1f006b2 100644
--- a/emulators/qmc2/Makefile
+++ b/emulators/qmc2/Makefile
@@ -6,12 +6,14 @@
#
PORTNAME= qmc2
-PORTVERSION= 0.1.b11
+PORTVERSION= 0.2.b1
CATEGORIES= emulators
MASTER_SITES= SF
MAINTAINER= alepulver@FreeBSD.org
-COMMENT= Qt 4 based UNIX MAME frontend supporting both XMAME and SDLMAME
+COMMENT= Qt 4 based UNIX MAME frontend supporting SDLMAME
+
+RUN_DEPENDS= sdlmame:${PORTSDIR}/emulators/sdlmame
USE_BZIP2= yes
USE_GMAKE= yes
@@ -19,20 +21,9 @@ USE_QT_VER= 4
MAKE_ENV= QTDIR="${QTDIR}" QMAKE="${QMAKE}" SYSCONFDIR="${PREFIX}/etc"
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= XMAME "Use XMAME (old) instead of SDLMAME (new) as emulator" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_XMAME)
-MAKE_ENV+= SDLMAME=0
-RUN_DEPENDS+= xmame:${PORTSDIR}/emulators/xmame
-.else
-RUN_DEPENDS+= sdlmame:${PORTSDIR}/emulators/sdlmame
-.endif
-
post-install:
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/qmc2/distinfo b/emulators/qmc2/distinfo
index b26ae5ec3147..6abc50a4f7e5 100644
--- a/emulators/qmc2/distinfo
+++ b/emulators/qmc2/distinfo
@@ -1,3 +1,3 @@
-MD5 (qmc2-0.1.b11.tar.bz2) = 0ffcb89b7f1ce450c36cf74ff238b996
-SHA256 (qmc2-0.1.b11.tar.bz2) = fe2a3001a5dc4f1546b18e99a3be914829fb6555f39ae879869b37313c23f190
-SIZE (qmc2-0.1.b11.tar.bz2) = 919164
+MD5 (qmc2-0.2.b1.tar.bz2) = 08f59255df6c57e0a376fccd161075d7
+SHA256 (qmc2-0.2.b1.tar.bz2) = 7b0ebc6c07c82ec71930f817605ad80efd3e5a360b7f2c9ec89b717a859dd169
+SIZE (qmc2-0.2.b1.tar.bz2) = 1080601
diff --git a/emulators/qmc2/files/patch-Makefile b/emulators/qmc2/files/patch-Makefile
index f0f64d854dcd..9ee3f1e20579 100644
--- a/emulators/qmc2/files/patch-Makefile
+++ b/emulators/qmc2/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Fri Dec 21 14:43:29 2007
-+++ Makefile Thu Jan 3 20:55:16 2008
+--- ./Makefile.orig 2008-03-26 07:34:12.000000000 -0300
++++ ./Makefile 2008-04-07 22:51:41.000000000 -0300
@@ -36,9 +36,6 @@
# you want to compile a specific OS's code branch or if the "uname"
# command doesn't tell the correct OS name of your system (see also OSREL and
@@ -23,13 +23,12 @@
endif
endif
ifeq '$(DISTCFG)' '1'
-@@ -211,16 +208,17 @@
+@@ -188,15 +185,16 @@
- install: bin lang
+ install: bin
@echo "Installing QMC2 v$(VERSION)"
- @$(MKDIR) $(DESTDIR)/$(PREFIX)/bin $(DESTDIR)/$(PREFIX)/share/$(PROJECT) $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)
- @$(RSYNC) --exclude '*svn*' ./$(PROJECT) $(DESTDIR)/$(PREFIX)/bin
-- @$(RSYNC) --exclude '*svn*' ./scripts/romalyzer.pl $(DESTDIR)/$(PREFIX)/bin
- @$(RSYNC) --exclude '*svn*' ./data/lng/*.qm $(DESTDIR)/$(DATADIR)/$(PROJECT)/lng/
- @$(RSYNC) --exclude '*svn*' ./data/opt $(DESTDIR)/$(DATADIR)/$(PROJECT)/
- @$(RSYNC) --exclude '*svn*' ./data/img $(DESTDIR)/$(DATADIR)/$(PROJECT)/
@@ -37,13 +36,12 @@
- @$(RSYNC) --exclude '*svn*' ./data/prv $(DESTDIR)/$(DATADIR)/$(PROJECT)/
- @$(RSYNC) --exclude '*svn*' ./data/fly $(DESTDIR)/$(DATADIR)/$(PROJECT)/
- @$(SED) -e "s_DATADIR_$(DATADIR)_g" < ./inst/$(PROJECT).ini.template > $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini
-+ @$(MKDIR) $(DESTDIR)/$(PREFIX)/bin $(DESTDIR)/$(PREFIX)/share/$(PROJECT) $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT) $(DESTDIR)/$(PREFIX)/share/$(PROJECT)/lng
++ @$(MKDIR) $(DESTDIR)/$(PREFIX)/bin $(DESTDIR)/$(PREFIX)/share/$(PROJECT) $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT) $(DESTDIR)/$(PREFIX)/share/$(PROJECT)/lng $(DESTDIR)/$(PREFIX)/share/doc/$(PROJECT)
+ @$(CP) -r ./$(PROJECT) $(DESTDIR)/$(PREFIX)/bin
-+ @$(CP) -r ./scripts/romalyzer.pl $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+ @$(CP) -r ./data/lng/*.qm $(DESTDIR)/$(DATADIR)/$(PROJECT)/lng/
+ @$(CP) -r ./data/opt $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+ @$(CP) -r ./data/img $(DESTDIR)/$(DATADIR)/$(PROJECT)/
-+ @$(CP) -r ./data/doc $(DESTDIR)/$(DATADIR)/$(PROJECT)/
++ @$(CP) -r ./data/doc/* $(DESTDIR)/$(PREFIX)/share/doc/$(PROJECT)/
+ @$(CP) -r ./data/prv $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+ @$(CP) -r ./data/fly $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+ @$(SED) -e "s_DATADIR_$(DATADIR)_" < ./inst/$(PROJECT).ini.template > $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini.sample
diff --git a/emulators/qmc2/files/patch-arch__FreeBSD.cfg b/emulators/qmc2/files/patch-arch__FreeBSD.cfg
index 16def65e7895..2e0d6537d76c 100644
--- a/emulators/qmc2/files/patch-arch__FreeBSD.cfg
+++ b/emulators/qmc2/files/patch-arch__FreeBSD.cfg
@@ -1,5 +1,5 @@
---- arch/FreeBSD.cfg.orig Thu May 31 17:07:34 2007
-+++ arch/FreeBSD.cfg Mon Jul 23 06:07:37 2007
+--- ./arch/FreeBSD.cfg.orig 2007-12-21 14:43:28.000000000 -0300
++++ ./arch/FreeBSD.cfg 2008-04-07 22:41:33.000000000 -0300
@@ -1,5 +1,5 @@
-QMAKE = $(QTDIR)/bin/qmake
+QMAKE ?= $(QTDIR)/bin/qmake
diff --git a/emulators/qmc2/files/patch-arch__default.cfg b/emulators/qmc2/files/patch-arch__default.cfg
index 4fad5ed211d6..94a406acc7bc 100644
--- a/emulators/qmc2/files/patch-arch__default.cfg
+++ b/emulators/qmc2/files/patch-arch__default.cfg
@@ -1,5 +1,5 @@
---- arch/default.cfg.orig Thu May 31 17:07:34 2007
-+++ arch/default.cfg Mon Jul 23 13:56:14 2007
+--- ./arch/default.cfg.orig 2007-12-21 14:43:28.000000000 -0300
++++ ./arch/default.cfg 2008-04-07 22:41:33.000000000 -0300
@@ -1,7 +1,5 @@
-QMAKE = qmake
LUPDATE = lupdate
diff --git a/emulators/qmc2/pkg-plist b/emulators/qmc2/pkg-plist
index 5c1a64d8c9a8..29a23a218430 100644
--- a/emulators/qmc2/pkg-plist
+++ b/emulators/qmc2/pkg-plist
@@ -2,46 +2,66 @@ bin/qmc2
@unexec cmp -s %D/etc/qmc2/qmc2.ini %D/etc/qmc2/qmc2.ini.sample && rm -f %D/etc/qmc2/qmc2.ini
etc/qmc2/qmc2.ini.sample
@exec test -f %D/etc/qmc2/qmc2.ini || cp %D/etc/qmc2/qmc2.ini.sample %D/etc/qmc2/qmc2.ini
-%%DATADIR%%/doc/html/de/changes.html
-%%DATADIR%%/doc/html/de/copying.html
-%%DATADIR%%/doc/html/de/credits.html
-%%DATADIR%%/doc/html/de/faq.html
-%%DATADIR%%/doc/html/de/img/ballou.png
-%%DATADIR%%/doc/html/de/img/jonas.png
-%%DATADIR%%/doc/html/de/img/rene.png
-%%DATADIR%%/doc/html/de/img/robert.png
-%%DATADIR%%/doc/html/de/img/sammy.png
-%%DATADIR%%/doc/html/de/img/sphere_blue.png
-%%DATADIR%%/doc/html/de/img/sphere_green.png
-%%DATADIR%%/doc/html/de/img/sphere_grey.png
-%%DATADIR%%/doc/html/de/img/sphere_red.png
-%%DATADIR%%/doc/html/de/img/sphere_yellowgreen.png
-%%DATADIR%%/doc/html/de/img/teddy.png
-%%DATADIR%%/doc/html/de/index.html
-%%DATADIR%%/doc/html/de/readme.html
-%%DATADIR%%/doc/html/de/todo.html
-%%DATADIR%%/doc/html/us/changes.html
-%%DATADIR%%/doc/html/us/copying.html
-%%DATADIR%%/doc/html/us/credits.html
-%%DATADIR%%/doc/html/us/faq.html
-%%DATADIR%%/doc/html/us/img/ballou.png
-%%DATADIR%%/doc/html/us/img/jonas.png
-%%DATADIR%%/doc/html/us/img/rene.png
-%%DATADIR%%/doc/html/us/img/robert.png
-%%DATADIR%%/doc/html/us/img/sammy.png
-%%DATADIR%%/doc/html/us/img/sphere_blue.png
-%%DATADIR%%/doc/html/us/img/sphere_green.png
-%%DATADIR%%/doc/html/us/img/sphere_grey.png
-%%DATADIR%%/doc/html/us/img/sphere_red.png
-%%DATADIR%%/doc/html/us/img/sphere_yellowgreen.png
-%%DATADIR%%/doc/html/us/img/teddy.png
-%%DATADIR%%/doc/html/us/index.html
-%%DATADIR%%/doc/html/us/readme.html
-%%DATADIR%%/doc/html/us/todo.html
+%%DOCSDIR%%/html/de/changes.html
+%%DOCSDIR%%/html/de/copying.html
+%%DOCSDIR%%/html/de/credits.html
+%%DOCSDIR%%/html/de/faq.html
+%%DOCSDIR%%/html/de/img/ballou.png
+%%DOCSDIR%%/html/de/img/jonas.png
+%%DOCSDIR%%/html/de/img/rene.png
+%%DOCSDIR%%/html/de/img/robert.png
+%%DOCSDIR%%/html/de/img/sammy.png
+%%DOCSDIR%%/html/de/img/sphere_blue.png
+%%DOCSDIR%%/html/de/img/sphere_green.png
+%%DOCSDIR%%/html/de/img/sphere_grey.png
+%%DOCSDIR%%/html/de/img/sphere_red.png
+%%DOCSDIR%%/html/de/img/sphere_yellowgreen.png
+%%DOCSDIR%%/html/de/img/teddy.png
+%%DOCSDIR%%/html/de/index.html
+%%DOCSDIR%%/html/de/readme.html
+%%DOCSDIR%%/html/de/todo.html
+%%DOCSDIR%%/html/pl/changes.html
+%%DOCSDIR%%/html/pl/copying.html
+%%DOCSDIR%%/html/pl/credits.html
+%%DOCSDIR%%/html/pl/faq.html
+%%DOCSDIR%%/html/pl/img/ballou.png
+%%DOCSDIR%%/html/pl/img/jonas.png
+%%DOCSDIR%%/html/pl/img/rene.png
+%%DOCSDIR%%/html/pl/img/robert.png
+%%DOCSDIR%%/html/pl/img/sammy.png
+%%DOCSDIR%%/html/pl/img/sphere_blue.png
+%%DOCSDIR%%/html/pl/img/sphere_green.png
+%%DOCSDIR%%/html/pl/img/sphere_grey.png
+%%DOCSDIR%%/html/pl/img/sphere_red.png
+%%DOCSDIR%%/html/pl/img/sphere_yellowgreen.png
+%%DOCSDIR%%/html/pl/img/teddy.png
+%%DOCSDIR%%/html/pl/index.html
+%%DOCSDIR%%/html/pl/readme.html
+%%DOCSDIR%%/html/pl/todo.html
+%%DOCSDIR%%/html/us/changes.html
+%%DOCSDIR%%/html/us/copying.html
+%%DOCSDIR%%/html/us/credits.html
+%%DOCSDIR%%/html/us/faq.html
+%%DOCSDIR%%/html/us/img/ballou.png
+%%DOCSDIR%%/html/us/img/jonas.png
+%%DOCSDIR%%/html/us/img/rene.png
+%%DOCSDIR%%/html/us/img/robert.png
+%%DOCSDIR%%/html/us/img/sammy.png
+%%DOCSDIR%%/html/us/img/sphere_blue.png
+%%DOCSDIR%%/html/us/img/sphere_green.png
+%%DOCSDIR%%/html/us/img/sphere_grey.png
+%%DOCSDIR%%/html/us/img/sphere_red.png
+%%DOCSDIR%%/html/us/img/sphere_yellowgreen.png
+%%DOCSDIR%%/html/us/img/teddy.png
+%%DOCSDIR%%/html/us/index.html
+%%DOCSDIR%%/html/us/readme.html
+%%DOCSDIR%%/html/us/todo.html
%%DATADIR%%/img/back.png
+%%DATADIR%%/img/calculator.png
%%DATADIR%%/img/camera.png
%%DATADIR%%/img/cd.png
%%DATADIR%%/img/classic/back.png
+%%DATADIR%%/img/classic/calculator.png
%%DATADIR%%/img/classic/camera.png
%%DATADIR%%/img/classic/cd.png
%%DATADIR%%/img/classic/clock.png
@@ -86,6 +106,8 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/classic/pencils.png
%%DATADIR%%/img/classic/previous-sail.png
%%DATADIR%%/img/classic/previous.png
+%%DATADIR%%/img/classic/qmc2_logo_big.png
+%%DATADIR%%/img/classic/qmc2_logo_small.png
%%DATADIR%%/img/classic/qt-logo.png
%%DATADIR%%/img/classic/redo.png
%%DATADIR%%/img/classic/reload.png
@@ -109,16 +131,20 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/classic/undo.png
%%DATADIR%%/img/classic/unlock.png
%%DATADIR%%/img/classic/up.png
+%%DATADIR%%/img/classic/view_detail.png
+%%DATADIR%%/img/classic/view_tree.png
%%DATADIR%%/img/classic/viewmag+.png
%%DATADIR%%/img/classic/viewmag-.png
%%DATADIR%%/img/classic/viewmagfit.png
%%DATADIR%%/img/classic/work.png
%%DATADIR%%/img/classic/yes.png
+%%DATADIR%%/img/classic/zip.png
%%DATADIR%%/img/clock.png
%%DATADIR%%/img/colors.png
%%DATADIR%%/img/configure.png
%%DATADIR%%/img/controller.png
%%DATADIR%%/img/crazy-black/back.png
+%%DATADIR%%/img/crazy-black/calculator.png
%%DATADIR%%/img/crazy-black/camera.png
%%DATADIR%%/img/crazy-black/cd.png
%%DATADIR%%/img/crazy-black/clock.png
@@ -163,6 +189,8 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/crazy-black/pencils.png
%%DATADIR%%/img/crazy-black/previous-sail.png
%%DATADIR%%/img/crazy-black/previous.png
+%%DATADIR%%/img/crazy-black/qmc2_logo_big.png
+%%DATADIR%%/img/crazy-black/qmc2_logo_small.png
%%DATADIR%%/img/crazy-black/qt-logo.png
%%DATADIR%%/img/crazy-black/redo.png
%%DATADIR%%/img/crazy-black/reload.png
@@ -186,12 +214,16 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/crazy-black/undo.png
%%DATADIR%%/img/crazy-black/unlock.png
%%DATADIR%%/img/crazy-black/up.png
+%%DATADIR%%/img/crazy-black/view_detail.png
+%%DATADIR%%/img/crazy-black/view_tree.png
%%DATADIR%%/img/crazy-black/viewmag+.png
%%DATADIR%%/img/crazy-black/viewmag-.png
%%DATADIR%%/img/crazy-black/viewmagfit.png
%%DATADIR%%/img/crazy-black/work.png
%%DATADIR%%/img/crazy-black/yes.png
+%%DATADIR%%/img/crazy-black/zip.png
%%DATADIR%%/img/crazy/back.png
+%%DATADIR%%/img/crazy/calculator.png
%%DATADIR%%/img/crazy/camera.png
%%DATADIR%%/img/crazy/cd.png
%%DATADIR%%/img/crazy/clock.png
@@ -236,6 +268,8 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/crazy/pencils.png
%%DATADIR%%/img/crazy/previous-sail.png
%%DATADIR%%/img/crazy/previous.png
+%%DATADIR%%/img/crazy/qmc2_logo_big.png
+%%DATADIR%%/img/crazy/qmc2_logo_small.png
%%DATADIR%%/img/crazy/qt-logo.png
%%DATADIR%%/img/crazy/redo.png
%%DATADIR%%/img/crazy/reload.png
@@ -259,11 +293,14 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/crazy/undo.png
%%DATADIR%%/img/crazy/unlock.png
%%DATADIR%%/img/crazy/up.png
+%%DATADIR%%/img/crazy/view_detail.png
+%%DATADIR%%/img/crazy/view_tree.png
%%DATADIR%%/img/crazy/viewmag+.png
%%DATADIR%%/img/crazy/viewmag-.png
%%DATADIR%%/img/crazy/viewmagfit.png
%%DATADIR%%/img/crazy/work.png
%%DATADIR%%/img/crazy/yes.png
+%%DATADIR%%/img/crazy/zip.png
%%DATADIR%%/img/down.png
%%DATADIR%%/img/edit.png
%%DATADIR%%/img/editcopy.png
@@ -302,6 +339,8 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/pencils.png
%%DATADIR%%/img/previous-sail.png
%%DATADIR%%/img/previous.png
+%%DATADIR%%/img/qmc2_logo_big.png
+%%DATADIR%%/img/qmc2_logo_small.png
%%DATADIR%%/img/qt-logo.png
%%DATADIR%%/img/redo.png
%%DATADIR%%/img/reload.png
@@ -325,22 +364,22 @@ etc/qmc2/qmc2.ini.sample
%%DATADIR%%/img/undo.png
%%DATADIR%%/img/unlock.png
%%DATADIR%%/img/up.png
+%%DATADIR%%/img/view_detail.png
+%%DATADIR%%/img/view_tree.png
%%DATADIR%%/img/viewmag+.png
%%DATADIR%%/img/viewmag-.png
%%DATADIR%%/img/viewmagfit.png
%%DATADIR%%/img/work.png
%%DATADIR%%/img/yes.png
+%%DATADIR%%/img/zip.png
%%DATADIR%%/lng/qmc2_de.qm
+%%DATADIR%%/lng/qmc2_pl.qm
+%%DATADIR%%/lng/qmc2_us.qm
%%DATADIR%%/lng/qt_de.qm
+%%DATADIR%%/lng/qt_pl.qm
%%DATADIR%%/opt/SDLMAME/template.xml
-%%DATADIR%%/opt/XMAME/template-SDL.xml
-%%DATADIR%%/opt/XMAME/template-X11-XV-OpenGL.xml
-%%DATADIR%%/opt/XMAME/template-all.xml
-%%DATADIR%%/opt/XMAME/template.xml
%%DATADIR%%/opt/template.xml
-%%DATADIR%%/romalyzer.pl
@dirrm %%DATADIR%%/prv
-@dirrm %%DATADIR%%/opt/XMAME
@dirrm %%DATADIR%%/opt/SDLMAME
@dirrm %%DATADIR%%/opt
@dirrm %%DATADIR%%/lng
@@ -349,11 +388,13 @@ etc/qmc2/qmc2.ini.sample
@dirrm %%DATADIR%%/img/classic
@dirrm %%DATADIR%%/img
@dirrm %%DATADIR%%/fly
-@dirrm %%DATADIR%%/doc/html/us/img
-@dirrm %%DATADIR%%/doc/html/us
-@dirrm %%DATADIR%%/doc/html/de/img
-@dirrm %%DATADIR%%/doc/html/de
-@dirrm %%DATADIR%%/doc/html
-@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/html/us/img
+@dirrm %%DOCSDIR%%/html/us
+@dirrm %%DOCSDIR%%/html/pl/img
+@dirrm %%DOCSDIR%%/html/pl
+@dirrm %%DOCSDIR%%/html/de/img
+@dirrm %%DOCSDIR%%/html/de
+@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
@dirrmtry etc/qmc2