aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2013-03-13 06:54:45 +0800
committerbeech <beech@FreeBSD.org>2013-03-13 06:54:45 +0800
commitbb962eaf385296e707aa3fc2390c3374d4e20ba5 (patch)
tree40de4a023108de83fd06ccd8cef511bc93a71710
parentd018746597b1d0acec61dc063cf3abb5246fd491 (diff)
downloadfreebsd-ports-gnome-bb962eaf385296e707aa3fc2390c3374d4e20ba5.tar.gz
freebsd-ports-gnome-bb962eaf385296e707aa3fc2390c3374d4e20ba5.tar.zst
freebsd-ports-gnome-bb962eaf385296e707aa3fc2390c3374d4e20ba5.zip
- Makefile tweaks
- Shorten Header - Bump portrevision - Pass maintainership to submitter PR: ports/176865 Submitted by: nemysis <nemysis@gmx.ch>
-rw-r--r--graphics/lcdtest/Makefile42
-rw-r--r--graphics/lcdtest/pkg-descr2
-rw-r--r--graphics/lcdtest/pkg-plist6
3 files changed, 33 insertions, 17 deletions
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
index ee1cd07f93bb..9ec974c93f38 100644
--- a/graphics/lcdtest/Makefile
+++ b/graphics/lcdtest/Makefile
@@ -1,20 +1,17 @@
-# New ports collection makefile for: lcdtest
-# Date created: 23 Mar 2007
-# Whom: Eric P. Scott <eps+pbug0703@ana.com>
-#
+# Created By: Eric P. Scott <eps+pbug0703@ana.com>
# $FreeBSD$
-#
PORTNAME= lcdtest
PORTVERSION= 1.18
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
-MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
- http://www.predatorlabs.net/dl/
+MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= LCD monitor test pattern generator
+LICENSE= GPLv3
+
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/Liberation/LiberationMono-Bold.ttf:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
USE_SDL= sdl image ttf
@@ -22,13 +19,22 @@ USE_SDL= sdl image ttf
CFLAGS+= -I${LOCALBASE}/include -DRELEASE=1.18
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lSDL -lSDL_image -lSDL_ttf
-PLIST_FILES= bin/lcdtest
PORTDOCS= README
MAN1= lcdtest.1
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_SUB+= PORTDOCS=""
+.else
+PLIST_SUB+= PORTDOCS="@comment "
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's|/usr/share/fonts/liberation/|${LOCALBASE}/lib/X11/fonts/Liberation/|' \
+ @${REINPLACE_CMD} -e 's|/usr/share/fonts/liberation/|${LOCALBASE}/lib/X11/fonts/Liberation/|' \
${WRKSRC}/src/lcdtest.c
do-build:
@@ -36,11 +42,15 @@ do-build:
(cd ${WRKSRC}/src && ${CC} ${LDFLAGS} -o lcdtest lcdtest.o)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/lcdtest ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/lcdtest.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN1} ${MAN1PREFIX}/man/man1/
+ ${INSTALL_DATA} ${WRKSRC}/desktop/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/desktop/${PORTNAME}.desktop ${PREFIX}/share/applications/
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/lcdtest/pkg-descr b/graphics/lcdtest/pkg-descr
index f986f9a6b34e..1c72ba67a35d 100644
--- a/graphics/lcdtest/pkg-descr
+++ b/graphics/lcdtest/pkg-descr
@@ -1,4 +1,4 @@
-lcdtest is a utility to display LCD monitor test patterns. It may be
+lcdtest is a utility to display LCD monitor test patterns. It may be
useful for adjusting the pixel clock frequency and phase on LCD
monitors when using analog inputs, and for finding pixels that are
stuck on or off.
diff --git a/graphics/lcdtest/pkg-plist b/graphics/lcdtest/pkg-plist
new file mode 100644
index 000000000000..ea29707aa589
--- /dev/null
+++ b/graphics/lcdtest/pkg-plist
@@ -0,0 +1,6 @@
+bin/lcdtest
+share/applications/lcdtest.desktop
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/pixmaps/lcdtest.svg
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications