aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2014-06-20 23:40:12 +0800
committerkmoore <kmoore@FreeBSD.org>2014-06-20 23:40:12 +0800
commitbcdc2b6590e64af1b67e43a8833dbd9ec19525ba (patch)
tree67f897c5eeb59e380af8ee32066457f285910acd
parent0b4ce206139c3c3c49248578b72703b4639ad2c3 (diff)
downloadfreebsd-ports-gnome-bcdc2b6590e64af1b67e43a8833dbd9ec19525ba.tar.gz
freebsd-ports-gnome-bcdc2b6590e64af1b67e43a8833dbd9ec19525ba.tar.zst
freebsd-ports-gnome-bcdc2b6590e64af1b67e43a8833dbd9ec19525ba.zip
- Update to 0.23
-rw-r--r--sysutils/grub2-bhyve/Makefile7
-rw-r--r--sysutils/grub2-bhyve/distinfo4
-rw-r--r--sysutils/grub2-bhyve/files/patch-grub-core-term-emu-console.c39
3 files changed, 5 insertions, 45 deletions
diff --git a/sysutils/grub2-bhyve/Makefile b/sysutils/grub2-bhyve/Makefile
index c7f9355d51be..f637b660acc3 100644
--- a/sysutils/grub2-bhyve/Makefile
+++ b/sysutils/grub2-bhyve/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= grub2-bhyve
-DISTVERSION= 0.22
-PORTREVISION= 2
+DISTVERSION= 0.23
CATEGORIES= sysutils
MAINTAINER= kmoore@FreeBSD.org
@@ -18,8 +17,8 @@ ONLY_FOR_ARCHS= amd64
SSP_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= grehan-freebsd
-GH_COMMIT= 10795f1
-GH_TAGNAME= v0.22
+GH_COMMIT= 8f5ad7a
+GH_TAGNAME= v0.23
USES= bison gmake
USE_GCC= yes
PLIST_FILES= sbin/grub-bhyve
diff --git a/sysutils/grub2-bhyve/distinfo b/sysutils/grub2-bhyve/distinfo
index 7a6a2fba329a..46a9c76d4a4a 100644
--- a/sysutils/grub2-bhyve/distinfo
+++ b/sysutils/grub2-bhyve/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grub2-bhyve-0.22.tar.gz) = 69a31b3621f3978690b91a8d97e6a6db9067918919e98d9983ed7333ad39a9ba
-SIZE (grub2-bhyve-0.22.tar.gz) = 8396496
+SHA256 (grub2-bhyve-0.23.tar.gz) = 6633123b40beee653cf9f76e04cbb2d9baa52a8ce53c7936da60ee42c51839d2
+SIZE (grub2-bhyve-0.23.tar.gz) = 8395963
diff --git a/sysutils/grub2-bhyve/files/patch-grub-core-term-emu-console.c b/sysutils/grub2-bhyve/files/patch-grub-core-term-emu-console.c
deleted file mode 100644
index 79add1cfca2f..000000000000
--- a/sysutils/grub2-bhyve/files/patch-grub-core-term-emu-console.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- grub-core/term/emu/console.c.bak 2014-04-17 20:03:51.000000000 +0400
-+++ grub-core/term/emu/console.c 2014-04-17 20:03:13.000000000 +0400
-@@ -42,6 +42,12 @@
- #error What the hell?
- #endif
-
-+#ifdef BHYVE /* should include <sys/param.h> */
-+#ifndef MIN
-+#define MIN(a,b) (((a)<(b))?(a):(b))
-+#endif
-+#endif
-+
- static int grub_console_attr = A_NORMAL;
-
- grub_uint8_t grub_console_cur_color = 7;
-@@ -176,6 +182,11 @@
-
- getyx (stdscr, y, x);
-
-+#ifdef BHYVE
-+ x = MIN(x, 255);
-+ y = MIN(y, 255);
-+#endif
-+
- return (x << 8) | y;
- }
-
-@@ -187,6 +198,11 @@
-
- getmaxyx (stdscr, y, x);
-
-+#ifdef BHYVE
-+ x = MIN(x, 255);
-+ y = MIN(y, 255);
-+#endif
-+
- return (x << 8) | y;
- }
-