aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2012-08-23 20:02:16 +0800
committerkuriyama <kuriyama@FreeBSD.org>2012-08-23 20:02:16 +0800
commitbe265fdad3f0eb944921066a68ac413079754b28 (patch)
tree75aa61c474b2e68a7853317e5821ad877b162cbd
parentbc282a175d4925cc88e4a97213a2206be39e4256 (diff)
downloadfreebsd-ports-gnome-be265fdad3f0eb944921066a68ac413079754b28.tar.gz
freebsd-ports-gnome-be265fdad3f0eb944921066a68ac413079754b28.tar.zst
freebsd-ports-gnome-be265fdad3f0eb944921066a68ac413079754b28.zip
Encrypted cookie-based session backend for Dancer.
WWW: http://search.cpan.org/dist/Dancer-Session-Cookie/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Session-Cookie/Makefile31
-rw-r--r--www/p5-Dancer-Session-Cookie/distinfo2
-rw-r--r--www/p5-Dancer-Session-Cookie/pkg-descr3
-rw-r--r--www/p5-Dancer-Session-Cookie/pkg-plist4
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5f0311739d9d..fbc4cbb96de4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -831,6 +831,7 @@
SUBDIR += p5-Dancer-Plugin-Feed
SUBDIR += p5-Dancer-Plugin-SiteMap
SUBDIR += p5-Dancer-Plugin-ValidationClass
+ SUBDIR += p5-Dancer-Session-Cookie
SUBDIR += p5-Dancer-Template-Xslate
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
diff --git a/www/p5-Dancer-Session-Cookie/Makefile b/www/p5-Dancer-Session-Cookie/Makefile
new file mode 100644
index 000000000000..e99f6c389d69
--- /dev/null
+++ b/www/p5-Dancer-Session-Cookie/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Dancer::Session::Cookie
+# Date created: 23 Aug 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Session-Cookie
+PORTVERSION= 0.15
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for encrypted cookie-based session backend for Dancer
+
+RUN_DEPENDS= \
+ p5-Crypt-CBC>0:${PORTSDIR}/security/p5-Crypt-CBC \
+ p5-Crypt-Rijndael>0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-Dancer>=1.13:${PORTSDIR}/www/p5-Dancer \
+ p5-String-CRC32>0:${PORTSDIR}/devel/p5-String-CRC32
+TEST_DEPENDS= \
+ p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Session::Cookie.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Session-Cookie/distinfo b/www/p5-Dancer-Session-Cookie/distinfo
new file mode 100644
index 000000000000..87f2d3db6e19
--- /dev/null
+++ b/www/p5-Dancer-Session-Cookie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Session-Cookie-0.15.tar.gz) = 0f3147fbd866873eacde0ba7e26895917a4d1b4d695b21ccc18e17e4b0489161
+SIZE (Dancer-Session-Cookie-0.15.tar.gz) = 5974
diff --git a/www/p5-Dancer-Session-Cookie/pkg-descr b/www/p5-Dancer-Session-Cookie/pkg-descr
new file mode 100644
index 000000000000..4a606bdb66c1
--- /dev/null
+++ b/www/p5-Dancer-Session-Cookie/pkg-descr
@@ -0,0 +1,3 @@
+Encrypted cookie-based session backend for Dancer.
+
+WWW: http://search.cpan.org/dist/Dancer-Session-Cookie/
diff --git a/www/p5-Dancer-Session-Cookie/pkg-plist b/www/p5-Dancer-Session-Cookie/pkg-plist
new file mode 100644
index 000000000000..586e2aa93107
--- /dev/null
+++ b/www/p5-Dancer-Session-Cookie/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Session/Cookie/.packlist
+%%SITE_PERL%%/Dancer/Session/Cookie.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Session/Cookie
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Session