aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-24 06:18:48 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-24 06:18:48 +0800
commitbe83a27855aaa2a677dec30f507ed18e277bafc8 (patch)
treee68634a7d7f25c5be89b242bf2af0a6cbf4f355b
parente0f5d2f4a561a2ba754ce516646db93d9e5959b9 (diff)
downloadfreebsd-ports-gnome-be83a27855aaa2a677dec30f507ed18e277bafc8.tar.gz
freebsd-ports-gnome-be83a27855aaa2a677dec30f507ed18e277bafc8.tar.zst
freebsd-ports-gnome-be83a27855aaa2a677dec30f507ed18e277bafc8.zip
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
-rw-r--r--converters/Makefile1
-rw-r--r--converters/php52-recode/Makefile14
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php52-readline/files/patch-config.m438
-rw-r--r--devel/php52-shmop/Makefile14
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/php52-snmp/Makefile14
-rw-r--r--net/Makefile1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/php52-simplexml/Makefile14
-rw-r--r--www/Makefile1
-rw-r--r--www/php52-session/Makefile14
12 files changed, 114 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 103ca5a29160..1eda23e67092 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -112,6 +112,7 @@
SUBDIR += php5-recode
SUBDIR += php52-iconv
SUBDIR += php52-mbstring
+ SUBDIR += php52-recode
SUBDIR += psiconv
SUBDIR += py-bsdconv
SUBDIR += py-cjkcodecs
diff --git a/converters/php52-recode/Makefile b/converters/php52-recode/Makefile
new file mode 100644
index 000000000000..825ef5093df0
--- /dev/null
+++ b/converters/php52-recode/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-recode
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -recode
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/Makefile b/devel/Makefile
index a702f36ca357..8bf288761803 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2475,6 +2475,7 @@
SUBDIR += php52-pcntl
SUBDIR += php52-pcre
SUBDIR += php52-readline
+ SUBDIR += php52-shmop
SUBDIR += phpbt
SUBDIR += phptags
SUBDIR += physfs
diff --git a/devel/php52-readline/files/patch-config.m4 b/devel/php52-readline/files/patch-config.m4
new file mode 100644
index 000000000000..b0b2bb521bc7
--- /dev/null
+++ b/devel/php52-readline/files/patch-config.m4
@@ -0,0 +1,38 @@
+--- config.m4.orig 2009-08-04 13:20:49.000000000 +0200
++++ config.m4 2009-09-22 11:13:12.000000000 +0200
+@@ -5,13 +5,8 @@
+ PHP_ARG_WITH(libedit,for libedit readline replacement,
+ [ --with-libedit[=DIR] Include libedit readline replacement (CLI/CGI only)])
+
+-if test "$PHP_LIBEDIT" = "no"; then
+ PHP_ARG_WITH(readline,for readline support,
+ [ --with-readline[=DIR] Include readline support (CLI/CGI only)])
+-else
+- dnl "register" the --with-readline option to preven invalid "unknown configure option" warning
+- php_with_readline=no
+-fi
+
+ if test "$PHP_READLINE" && test "$PHP_READLINE" != "no"; then
+ for i in $PHP_READLINE /usr/local /usr; do
+@@ -60,6 +55,13 @@
+ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
+ ])
+
++ PHP_CHECK_LIBRARY(readline, rl_completion_matches,
++ [
++ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1, [ ])
++ ],[],[
++ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
++ ])
++
+ AC_DEFINE(HAVE_LIBREADLINE, 1, [ ])
+
+ elif test "$PHP_LIBEDIT" != "no"; then
+@@ -97,7 +99,6 @@
+ fi
+
+ if test "$PHP_READLINE" != "no" || test "$PHP_LIBEDIT" != "no"; then
+- AC_CHECK_FUNCS([rl_completion_matches])
+ PHP_NEW_EXTENSION(readline, readline.c, $ext_shared, cli)
+ PHP_SUBST(READLINE_SHARED_LIBADD)
+ fi
diff --git a/devel/php52-shmop/Makefile b/devel/php52-shmop/Makefile
new file mode 100644
index 000000000000..5beac0bfee0e
--- /dev/null
+++ b/devel/php52-shmop/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-shmop
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -shmop
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 07c865a58ede..207f9a9b0fb1 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -212,6 +212,7 @@
SUBDIR += pftabled
SUBDIR += php4-snmp
SUBDIR += php5-snmp
+ SUBDIR += php52-snmp
SUBDIR += phpip
SUBDIR += pixilate
SUBDIR += pktstat
diff --git a/net-mgmt/php52-snmp/Makefile b/net-mgmt/php52-snmp/Makefile
new file mode 100644
index 000000000000..eb0516353729
--- /dev/null
+++ b/net-mgmt/php52-snmp/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-snmp
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= net-mgmt
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -snmp
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/Makefile b/net/Makefile
index c92bf7a61e9f..39a35289d6e7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -771,6 +771,7 @@
SUBDIR += php5-sockets
SUBDIR += php5-xmlrpc
SUBDIR += php52-ldap
+ SUBDIR += php52-soap
SUBDIR += phpldapadmin
SUBDIR += phpldapadmin098
SUBDIR += pimdd
diff --git a/textproc/Makefile b/textproc/Makefile
index efa55c9e5fd0..db5f1798f5df 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -937,6 +937,7 @@
SUBDIR += php52-ctype
SUBDIR += php52-dom
SUBDIR += php52-pspell
+ SUBDIR += php52-simplexml
SUBDIR += po4a
SUBDIR += pocketreader
SUBDIR += pootle
diff --git a/textproc/php52-simplexml/Makefile b/textproc/php52-simplexml/Makefile
new file mode 100644
index 000000000000..ec4280e590d1
--- /dev/null
+++ b/textproc/php52-simplexml/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-simplexml
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -simplexml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/Makefile b/www/Makefile
index efd0997de129..3c5e3f9eb578 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1339,6 +1339,7 @@
SUBDIR += php4-session
SUBDIR += php5-session
SUBDIR += php5-tidy
+ SUBDIR += php52-session
SUBDIR += phpbb
SUBDIR += phpbb-devel
SUBDIR += phpbb3
diff --git a/www/php52-session/Makefile b/www/php52-session/Makefile
new file mode 100644
index 000000000000..082ec4e02a04
--- /dev/null
+++ b/www/php52-session/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-session
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -session
+
+.include "${MASTERDIR}/Makefile"