aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-12-26 19:47:37 +0800
committerantoine <antoine@FreeBSD.org>2016-12-26 19:47:37 +0800
commitbfbac33221f4d2287b8611a3c5827b625c7cd67c (patch)
treed461856443ace3b5cf8d62a0c597fe84d471b5e0
parente590fcb712e5ec94f4435d8aec35f1f59c1f9ebd (diff)
downloadfreebsd-ports-gnome-bfbac33221f4d2287b8611a3c5827b625c7cd67c.tar.gz
freebsd-ports-gnome-bfbac33221f4d2287b8611a3c5827b625c7cd67c.tar.zst
freebsd-ports-gnome-bfbac33221f4d2287b8611a3c5827b625c7cd67c.zip
We don't need 4 versions of www/py-requests, 2 are enough
-rw-r--r--MOVED3
-rw-r--r--textproc/py3-asciinema/Makefile7
-rw-r--r--www/Makefile4
-rw-r--r--www/py-requests/Makefile2
-rw-r--r--www/py3-requests/Makefile (renamed from www/py33-requests/Makefile)2
-rw-r--r--www/py34-requests/Makefile7
-rw-r--r--www/py35-requests/Makefile7
7 files changed, 11 insertions, 21 deletions
diff --git a/MOVED b/MOVED
index 0026f84de9a7..8080b56da005 100644
--- a/MOVED
+++ b/MOVED
@@ -8845,3 +8845,6 @@ biology/p5-bioperl|biology/p5-BioPerl|2016-12-18|Rename to match upstream naming
biology/p5-bioperl-run|biology/p5-BioPerl-Run|2016-12-18|Rename to match upstream naming
databases/py-swiftclient|databases/py-python-swiftclient|2016-12-18|Rename to match pypi name
x11-toolkits/py-kiwi|x11-toolkits/py-kiwi-gtk|2016-12-24|Rename to match PyPI naming
+www/py33-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-requests
+www/py34-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-requests
+www/py35-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-requests
diff --git a/textproc/py3-asciinema/Makefile b/textproc/py3-asciinema/Makefile
index 0051d21ad0ec..dafe08cee2bf 100644
--- a/textproc/py3-asciinema/Makefile
+++ b/textproc/py3-asciinema/Makefile
@@ -2,6 +2,7 @@
PORTNAME= asciinema
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -9,10 +10,12 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= swills@FreeBSD.org
COMMENT= Tool for recording and sharing terminal sessions
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.1:www/${PYTHON_PKGNAMEPREFIX}requests \
+LICENSE= GPLv3+
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.1:www/py3-requests \
ca_root_nss>=0:security/ca_root_nss
-USES= python:3
+USES= python:3.3+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/www/Makefile b/www/Makefile
index c628a3929fcd..8544fa8d3f0e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1835,9 +1835,7 @@
SUBDIR += py-wsgidav
SUBDIR += py-zope.app.wsgi
SUBDIR += py3-cssutils
- SUBDIR += py33-requests
- SUBDIR += py34-requests
- SUBDIR += py35-requests
+ SUBDIR += py3-requests
SUBDIR += pyblosxom
SUBDIR += pycarddav
SUBDIR += pydio
diff --git a/www/py-requests/Makefile b/www/py-requests/Makefile
index afd48a8df4b9..972f992b446c 100644
--- a/www/py-requests/Makefile
+++ b/www/py-requests/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.1:devel/py-pytest
-USES= python
+USES?= python
USE_PYTHON= autoplist distutils
CONFLICTS_INSTALL= py*-requests1-*
diff --git a/www/py33-requests/Makefile b/www/py3-requests/Makefile
index 580d12a393cc..aefc280bc379 100644
--- a/www/py33-requests/Makefile
+++ b/www/py3-requests/Makefile
@@ -2,6 +2,6 @@
MASTERDIR= ${.CURDIR}/../py-requests
-PYTHON_VERSION= python3.3
+USES= python:3.3+
.include "${MASTERDIR}/Makefile"
diff --git a/www/py34-requests/Makefile b/www/py34-requests/Makefile
deleted file mode 100644
index e7fae4bf8b8b..000000000000
--- a/www/py34-requests/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-# $FreeBSD$
-
-MASTERDIR= ${.CURDIR}/../py-requests
-
-PYTHON_VERSION= python3.4
-
-.include "${MASTERDIR}/Makefile"
diff --git a/www/py35-requests/Makefile b/www/py35-requests/Makefile
deleted file mode 100644
index 9c5ee6f76258..000000000000
--- a/www/py35-requests/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-# $FreeBSD$
-
-MASTERDIR= ${.CURDIR}/../py-requests
-
-PYTHON_VERSION= python3.5
-
-.include "${MASTERDIR}/Makefile"