aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-02-24 22:22:01 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-02-24 22:22:01 +0800
commitc13580af6467d2c8c81b0b0ea08055c465a5f47d (patch)
treeafae7bfeb9a4441533d846a58da042cc469fae9e
parent025986011a598a2c111b5fb315e9bf0a7d87c663 (diff)
downloadfreebsd-ports-gnome-c13580af6467d2c8c81b0b0ea08055c465a5f47d.tar.gz
freebsd-ports-gnome-c13580af6467d2c8c81b0b0ea08055c465a5f47d.tar.zst
freebsd-ports-gnome-c13580af6467d2c8c81b0b0ea08055c465a5f47d.zip
Geresh is a multi lingual text editor, but there are a few features
for the benefit of users of Hebrew and Arabic, such as: the ability to display the signs point the Hebrew / Arabic (dash Hebrew) as an alternative, convenient editing of characters in the format of the BiDi (such as RLM, LRM), an alternative algorithm Greek paragraphs to set the emulation of the Hebrew keyboard. PR: ports/130087 Submitted by: Eitan Adler <EitanAdlerList at gmail.com>
-rw-r--r--hebrew/Makefile1
-rw-r--r--hebrew/geresh/Makefile20
-rw-r--r--hebrew/geresh/distinfo3
-rw-r--r--hebrew/geresh/files/patch-cxx.patch59
-rw-r--r--hebrew/geresh/pkg-descr6
-rw-r--r--hebrew/geresh/pkg-plist16
6 files changed, 105 insertions, 0 deletions
diff --git a/hebrew/Makefile b/hebrew/Makefile
index a69cbbc87215..3357b2ae1dae 100644
--- a/hebrew/Makefile
+++ b/hebrew/Makefile
@@ -6,6 +6,7 @@
SUBDIR += aspell
SUBDIR += culmus
SUBDIR += elmar-fonts
+ SUBDIR += geresh
SUBDIR += he2
SUBDIR += hspell
SUBDIR += kde3-i18n
diff --git a/hebrew/geresh/Makefile b/hebrew/geresh/Makefile
new file mode 100644
index 000000000000..6c8c55bc0c11
--- /dev/null
+++ b/hebrew/geresh/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: geresh
+# Date created: 30 December 2008
+# Whom: Eitan Adler <EitanAdlerList@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geresh
+PORTVERSION= 0.6.3
+CATEGORIES= hebrew editors
+MASTER_SITES= http://www.typo.co.il/~mooffie/geresh/download/
+
+MAINTAINER= EitanAdlerList@gmail.com
+COMMENT= A Hebrew console based text edtior
+
+LIB_DEPENDS= fribidi.0:${PORTSDIR}/converters/fribidi
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/hebrew/geresh/distinfo b/hebrew/geresh/distinfo
new file mode 100644
index 000000000000..235ba67a05d4
--- /dev/null
+++ b/hebrew/geresh/distinfo
@@ -0,0 +1,3 @@
+MD5 (geresh-0.6.3.tar.gz) = 60a1fd8801ef23edc481ad6474abfd0e
+SHA256 (geresh-0.6.3.tar.gz) = cb44f68adad3e2e59ab4635f14de3f11bb2882506b2e47266757410cdbacf63a
+SIZE (geresh-0.6.3.tar.gz) = 202272
diff --git a/hebrew/geresh/files/patch-cxx.patch b/hebrew/geresh/files/patch-cxx.patch
new file mode 100644
index 000000000000..cc0c5abac46a
--- /dev/null
+++ b/hebrew/geresh/files/patch-cxx.patch
@@ -0,0 +1,59 @@
+--- dialogline.cc
++++ dialogline.cc
+@@ -16,6 +16,7 @@
+
+ #include <config.h>
+
++#include <cstdlib>
+ #include <stdarg.h>
+
+ #include "dialogline.h"
+--- editbox2.cc
++++ editbox2.cc
+@@ -14,6 +14,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+
++#include <cstdlib>
+ #include <config.h>
+
+ #include "editbox.h"
+--- editbox.h
++++ editbox.h
+@@ -768,7 +768,7 @@
+ int para_num
+ );
+
+- void EditBox::redraw_unwrapped_paragraph(
++ void redraw_unwrapped_paragraph(
+ Paragraph &p,
+ int window_start_line,
+ bool only_cursor,
+@@ -780,7 +780,7 @@
+ bool eop_is_selected
+ );
+
+- void EditBox::redraw_wrapped_paragraph(
++ void redraw_wrapped_paragraph(
+ Paragraph &p,
+ int window_start_line,
+ bool only_cursor,
+--- io.cc
++++ io.cc
+@@ -16,6 +16,7 @@
+
+ #include <config.h>
+
++#include <cstdlib>
+ #include <stdarg.h>
+ #include <fcntl.h> // file primitives
+ #include <unistd.h>
+--- transtbl.cc
++++ transtbl.cc
+@@ -16,6 +16,7 @@
+
+ #include <config.h>
+
++#include <cstdlib>
+ #include <stdio.h>
+ #include <errno.h>
diff --git a/hebrew/geresh/pkg-descr b/hebrew/geresh/pkg-descr
new file mode 100644
index 000000000000..9eb783a76447
--- /dev/null
+++ b/hebrew/geresh/pkg-descr
@@ -0,0 +1,6 @@
+Geresh is a multi lingual text editor, but there are a few features
+for the benefit of users of Hebrew and Arabic, such as: the ability
+to display the signs point the Hebrew / Arabic (dash Hebrew) as an
+alternative, convenient editing of characters in the format of the
+BiDi (such as RLM, LRM), an alternative algorithm Greek paragraphs
+to set the emulation of the Hebrew keyboard.
diff --git a/hebrew/geresh/pkg-plist b/hebrew/geresh/pkg-plist
new file mode 100644
index 000000000000..ae72a46916b7
--- /dev/null
+++ b/hebrew/geresh/pkg-plist
@@ -0,0 +1,16 @@
+bin/geresh
+bin/pgeresh
+%%DATADIR%%/MANUAL.he
+%%DATADIR%%/kbdtab
+%%DATADIR%%/reprtab
+%%DATADIR%%/transtab
+%%DATADIR%%/themes/default.thm
+%%DATADIR%%/themes/default_bw.thm
+%%DATADIR%%/themes/mc.thm
+%%DATADIR%%/themes/green.thm
+%%DATADIR%%/themes/borland.thm
+%%DATADIR%%/themes/occult.thm
+%%DATADIR%%/themes/arnold.thm
+%%DATADIR%%/themes/README.themes
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%