aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchie <archie@FreeBSD.org>2004-04-02 23:27:23 +0800
committerarchie <archie@FreeBSD.org>2004-04-02 23:27:23 +0800
commitc149a1252bdbf2cab08bbb12af156dd6a6f1544c (patch)
treedecf70ff8aee02da14c67685e7b1602c8fd14d84
parent6d78b0d29a5e973a07450abef9da45df46a0e0c6 (diff)
downloadfreebsd-ports-gnome-c149a1252bdbf2cab08bbb12af156dd6a6f1544c.tar.gz
freebsd-ports-gnome-c149a1252bdbf2cab08bbb12af156dd6a6f1544c.tar.zst
freebsd-ports-gnome-c149a1252bdbf2cab08bbb12af156dd6a6f1544c.zip
Respect CC and CFLAGS.
PR: ports/65048
-rw-r--r--devel/a2dev/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/a2dev/Makefile b/devel/a2dev/Makefile
index 3950847f6f99..1dce61b08a0a 100644
--- a/devel/a2dev/Makefile
+++ b/devel/a2dev/Makefile
@@ -19,6 +19,7 @@ COMMENT= Apple II 6502 assembler, linker, loader, and object file viewer
USE_GMAKE= defined
PATCH_STRIP= -p1
MAN1= a2asm.1 a2link.1 a2load.1 a2objx.1
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -26,4 +27,8 @@ MAN1= a2asm.1 a2link.1 a2load.1 a2objx.1
BROKEN= "Does not compile on !i386"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-O3|${CFLAGS}|' \
+ ${WRKSRC}/Make.defs
+
.include <bsd.port.post.mk>